Recent content by [email protected]

  1. 98@Harsh

    Post Otcupdater

    It seems that the current version of OtcUpdaterZip file is only compatible with Windows 64-bit. I don't have a computer with this version. Does somebody have kept a previous version which may be 32-bit compatible?
  2. 98@Harsh

    Post Otcupdater

    what can i try