D
Reaction score
4

Profile posts Latest activity Postings About

  • I don't have the Telstra HD2 but if you go on the last tab in manila, choose Wireless Controls... and turn on 3g. if that does not resolve your issues, you may want to check your 3G settings ensure you are on the right band
  • Loading…
  • Loading…
  • Loading…