FORUMS
Remove All Ads from XDA

Huawei Mate 10 pro, homescreen won't go into landscape mode

80 posts
Thanks Meter: 5
 
By liviococcia, Member on 1st May 2018, 08:25 AM
Post Answer Email Thread
Hi Members
I have the above phone, with all the latest OTA updates offered for my Huawei Mate 10 pro, its currently running Android 8 EMUI 8

I've noticed if I hold down the homescreen, then go to settings, there doesn't appear to be the option to allow the homescreen to rotate.

In the quick toggles the auto rotate is on, and all other apps do rotate into landscape so there's no hardware issue.

Does anyone have a solution to this, I've done all the obvious things like clear caches, turn on/of phone, reset the phone twice to factory.

I'm not running many apps, the phone is not rooted, and I wouldn't consider resetting the phone again (as this doesn't do anything)

My only default launcher is the Huawei 'My Home', one of Huawei's OTG updates changed this to being the only launcher.

I don't want to use another launcher, as this is Huawei system default (I don't really want other issues to appear if I was to run another launcher)

Thanks for any advise
Cheers
The Following User Says Thank You to liviococcia For This Useful Post: [ View ] Gift liviococcia Ad-Free
Add a Comment
 
 

13 Answers

1st May 2018, 09:30 AM |#3  
Junior Member
Thanks Meter: 3
 
More
1 Votes
If you split-screen with the gesture and have any of the second screen return to home you can see it rotates into landscape mode. Sadly thats the only way i know
Add a Comment
1st May 2018, 08:46 AM |#2  
Senior Member
Thanks Meter: 30
 
More
0 Votes
I don't think the stock launcher supports landscape mode.
Add a Comment
1st May 2018, 04:19 PM |#4  
OP Member
Thanks Meter: 5
 
More
0 Votes
Thanks for all the replys, hopefully Huawei will change this, maybe I'll have to consider running Nova launcher, I've heard Huawei doesn't allow it to be a default launcher though?
madman_cro's Avatar
you can use whatever launcher you want if you dont use huawei widgets on it(primarily weather widget witch i disabled anyway cause i use another one) . I used nova since day one without issues. maybe there was bug on early software that prevented it but i never had issues.
Last edited by madman_cro; 1st May 2018 at 05:05 PM.
Add a Comment
1st May 2018, 06:19 PM |#6  
wooley4766's Avatar
Senior Member
Flag Swalmen
Thanks Meter: 128
 
More
0 Votes
I am on mate 10 no pro fw13 2c636
Original launcher. In screen enable screen rotate.
Works like a charm. Greetings
Add a Comment
1st May 2018, 09:52 PM |#7  
NiXiNiX's Avatar
Senior Member
Thanks Meter: 95
 
More
0 Votes
I used to have landscape mode too, until firmware update BLA-L09 8.0.0.137. It's gone since then.
Add a Comment
1st May 2018, 10:09 PM |#8  
madman_cro's Avatar
Senior Member
Thanks Meter: 122
 
More
0 Votes
thats strange. bla l29 on 137 firmware has that option. huawei probably screwed something up.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20180501-231020.jpg
Views:	538
Size:	225.5 KB
ID:	4490862   Click image for larger version

Name:	Screenshot_20180501-231003.jpg
Views:	516
Size:	161.3 KB
ID:	4490863  
Add a Comment
2nd May 2018, 06:16 AM |#9  
OP Member
Thanks Meter: 5
 
More
0 Votes
Yes, I am on BLA L09 8..0.0.137 (C432) kernel version 4.4.23+, and although I have the 'auto rotate' toggle and switch in settings, there isn't a specific switch or check box to allow Homescreen to rotate.

As you've said madman_cro, Huawei must have messed something up, unless they couldn't get some other aspect of the phone to work while in landscape, and they removed the setting.

I'll wait to see if they rectify it, I have sent Huawei an email

Thanks again everyone for the help
Add a Comment
2nd May 2018, 09:08 PM |#10  
OP Member
Thanks Meter: 5
 
More
0 Votes
I had an email reply back from Huawei, they said they looked at the settings of a Mate 10 pro at there end, and confirmed that there was a checkbox picker for 'disabling homescreen auto rotation' , whether the phone they had looked into at there end had been fully updated to it's current UK status, I don't know.

I have sent back a reply with screenshots of my phone as it currently stands in the settings, Android version, and firmware version
Add a Comment
3rd May 2018, 07:35 AM |#11  
Stripester's Avatar
Member
Flag Manchester
Thanks Meter: 19
 
More
0 Votes
I have the same issue, firmware 137 doesn't have landscape, plus it broke "OK Google" support on my phone...not happy
Add a Comment
3rd May 2018, 10:08 AM |#12  
OP Member
Thanks Meter: 5
 
More
0 Votes
I've come to the conclusion that the whole Huawei Android/EMUI/hardware eco system has many glitches, and bugs.

I've also found there watch 2 Pro also seems very inconsistent, sometimes i'm getting notifications sometimes not.

And no amount of turning on and off, or resetting, or fiddling with settings permissions, or power policies, or notification allowances seems to sort things.

Huawei need to address these problems... or they risk losing customer business through unreliability issues.
Add a Comment
3rd May 2018, 04:07 PM |#13  
OP Member
Thanks Meter: 5
 
More
0 Votes
Just let members know, I've had a reply back from Huawei support, and they have said it may be a bug with possibly there latest update, and that it may be resolved in the next update in due course.
Add a Comment
20th May 2018, 06:41 AM |#14  
Senior Member
Thanks Meter: 21
 
More
0 Votes
I can confirm the same issue, it was working for me in BLA L29 8.0.0.137 (C432) and forced an update to BLA L29 8.0.0.142 (C432) and it was not working anymore.
Tested Nova launcher and this one works for rotation.
I have noticed too “Ok Google” not working until I clear cache/data from the application “Google” after that “OK Google” was back on track.
I did the same from Huawei 'My Home' but no luck.
I have try this update because of this:
- to see how it fix BlueTooth
- add facial recognition
- and if the issue (I would like to be fixed) about stereo channel swap when recording a video from rear camera from stock camera app)
Seb.
Add a Comment
7th April 2019, 05:42 PM |#15  
Junior Member
Thanks Meter: 0
 
More
0 Votes
If you goto home screen, pinch gesture, setting, allow home screen to rotate

Took me ages to find this!
Add a Comment
Post Answer Subscribe to Thread

Answer Question (no urls or BBcode)
This form is used to answer the question presented at the top of this thread. If you are asking a clarifying question or want to comment on an existing answer, please click on the comment button below that post.
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes