FORUMS

Help - Huawei data management services is eating my battery

397 posts
Thanks Meter: 110
 
By vodovodo, Senior Member on 4th March 2019, 04:05 PM
Post Reply Email Thread
Hello,

So the day s10+ comes out is the day this freaky huawei software started to act funny!

Somehow I went down from 8+ SOT to less than 4, on the second charge I checked the battery usage and WOW! An app called huawei data management services is just running in the background and eating as much as a heavy game like future fight from my battery

What is this?? Anyone faced this issue? Is there a fix or huawei is just not happy with how much they frustrate us with the sh!ty EMUI and Decided to give us another present to make our choice much worse?
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20190304_185652_com.huawei.systemmanager.jpg
Views:	1460
Size:	135.9 KB
ID:	4716613  
4th March 2019, 07:48 PM |#2  
Darkat70's Avatar
Senior Member
Thanks Meter: 464
 
More
It's part of the android system process, what you could try is clearing the cache regularly I have done this before and I see a huge difference.

You can also try disabling the powergenie application There's a thread in here on how to do it.

If I don't clean up my cache I get 11 minutes before dropping to 99%

If I clean the cache I can get up to 43 minutes before dropping to 99%
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20190305_064301_com.gsamlabs.bbm.pro.jpg
Views:	1266
Size:	227.3 KB
ID:	4716707   Click image for larger version

Name:	Screenshot_20190303_144258_com.gsamlabs.bbm.pro.jpg
Views:	1290
Size:	186.7 KB
ID:	4716708  
The Following User Says Thank You to Darkat70 For This Useful Post: [ View ] Gift Darkat70 Ad-Free
4th March 2019, 07:49 PM |#3  
Darkat70's Avatar
Senior Member
Thanks Meter: 464
 
More
Android system processes
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20190305_064301_com.gsamlabs.bbm.pro.jpg
Views:	770
Size:	227.3 KB
ID:	4716709  
5th March 2019, 04:00 PM |#4  
OP Senior Member
Thanks Meter: 110
 
More
Clearing cache didn't help

The problem still there. Anyone can help?
5th March 2019, 05:35 PM |#5  
Darkat70's Avatar
Senior Member
Thanks Meter: 464
 
More
Yeah something isn't right now, put my phone down at 96% on the table, picked up 4 hours later it's at 85%

Android system & Kernel the two biggest issues over 6% Everything else had less than 1% to 0% used.
5th March 2019, 05:42 PM |#6  
Senior Member
Flag Chicago
Thanks Meter: 720
 
More
Quote:
Originally Posted by vodovodo

Clearing cache didn't help

The problem still there. Anyone can help?

Someone who reported the same problem on his P20 Pro said restoring his phone to factory settings fixed it.

But if it's caused by corrupted system data you would need to set up your phone as new rather than restore from a backup (including a Google Cloud Backup) because the backup could restore the system data that is causing your problem.

I think Huawei Data Management Services is similar to Google Play Services and that apps (including downloaded third party apps) use the process to sync data so a misbehaving app could cause the issue without showing up in the battery monitor as causing drain.

You could also try turning off Huawei Share to verify that it isn't causing your problem.
5th March 2019, 08:47 PM |#7  
Darkat70's Avatar
Senior Member
Thanks Meter: 464
 
More
What is annoying is battery/app launch 3 dots.... launch record's

I see apps being launched by other applications that I haven't even used in the last few hours, even when I have set secondary launch off for those apps.

Apps are also being launched when launch on Start up is deactivated.
7th May 2019, 03:57 AM |#8  
Junior Member
Thanks Meter: 0
 
More
Mate 20 pro battery drain
Help! My Mate 20 Pro is a battery draining monster. Huawei Data Management is taking over 30% of my consumption. I've tried factory data reset twice, but no improvement. Please help!
8th May 2019, 01:36 AM |#9  
ChongoDroid's Avatar
Senior Member
Flag Vancouver
Thanks Meter: 2,948
 
More
Clearing cache is not going to fix anything. Hasn't since probably Gingerbread.


In fact it just chews more resources to rebuild that cache.
8th May 2019, 10:29 AM |#10  
Senior Member
Thanks Meter: 28
 
More
I got this issue two update ago. Now on .243. I did a factory reset and set up my phone from scratch. No restores from Google drive or Huawei phone clone. The issue is gone since. Battery as good as ever.
29th May 2019, 07:49 AM |#11  
Junior Member
Thanks Meter: 3
 
More
Hello,
I have the same issue. Any way to solve it without restore ?
Thanks
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes