FORUMS
Remove All Ads from XDA

Memory Card Unexpectedly Removed Notification

9 posts
Thanks Meter: 0
 
By HermesHidayat, Junior Member on 10th February 2019, 02:24 PM
Post Reply Email Thread
So i was NOT touching my Mate 20 Pro and when i opened the flip cover case it had this notification saying Memory Card Unexpectedly Removed or sort of like that.

Problem is that i didnt even eject the sim/nm card adaptor nor was i even using the phone. Any idea why is this happening? Been using the NM Card for 2 weeks now.
24th February 2019, 09:51 AM |#2  
Junior Member
Thanks Meter: 4
 
More
I have the same isue. It happening about once a day or two
24th February 2019, 07:03 PM |#3  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by PawelSlowik

I have the same isue. It happening about once a day or two

Same for me. I hope the NM card is not defective. It has been working for some month without issue...
25th February 2019, 10:43 AM |#5  
madlive's Avatar
Senior Member
Thanks Meter: 7
 
More
Same thing here. Just got a card two weeks ago.
25th February 2019, 11:04 AM |#6  
Darkat70's Avatar
Senior Member
Thanks Meter: 311
 
More
It's possible it could be a software issue say for instance the powergenie application killing the system process for the card. I have uninstalled the powergenie but not got a card yet.
27th February 2019, 02:59 AM |#7  
Junior Member
Thanks Meter: 1
 
More
I had the same issue with my Mate 20 pro. I looks like NM card reader loose contacts. I used very thin double sided tape to stick my NM card to the tray. This will lift the card slightly and of course will create a tighter fit in the slot (the idea is to make NM card contacts press harder against card reader pins inside the phone) . So far so good. Message was appearing couple times a day, but now whole 24 hours and nothing. Tape must be very thin otherwise NM card pins inside the phone can be damaged while sliding the tray back in. I'll keep on monitoring. Hopefully it will solve the problem.
27th February 2019, 04:02 AM |#8  
Senior Member
Thanks Meter: 46
 
More
Quote:
Originally Posted by Darkat70

It's possible it could be a software issue say for instance the powergenie application killing the system process for the card.

Exactly what I thought. The stupid aggressive process-closing practice killing something it should not be.
I like my phone but this core system "feature" is making me think about changing back to Samsung, or even trying LG maybe..
27th February 2019, 11:44 AM |#9  
Junior Member
Thanks Meter: 1
 
More
Four days now since the fix and no error message.
The Following User Says Thank You to Lopsy1 For This Useful Post: [ View ] Gift Lopsy1 Ad-Free
6th March 2019, 08:25 AM |#10  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Lopsy1

I had the same issue with my Mate 20 pro. I looks like NM card reader loose contacts. I used very thin double sided tape to stick my NM card to the tray. This will lift the card slightly and of course will create a tighter fit in the slot (the idea is to make NM card contacts press harder against card reader pins inside the phone) . So far so good. Message was appearing couple times a day, but now whole 24 hours and nothing. Tape must be very thin otherwise NM card pins inside the phone can be damaged while sliding the tray back in. I'll keep on monitoring. Hopefully it will solve the problem.

Wow, i just got back here and theres a solution. But i mean how the hell a flagship has this kind of problem...
6th March 2019, 11:44 AM |#11  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by HermesHidayat

Wow, i just got back here and theres a solution. But i mean how the hell a flagship has this kind of problem...

It can happen to even most expensive /flagship device. I'm working in mobile industry and I've seen lots of problems with not only cheap ones, but with flagship ones as well, but anyway since the quick fix I don't have error any more.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes