FORUMS
Remove All Ads from XDA

[DEV][TREBLE] P-based vendor implementation

1,022 posts
Thanks Meter: 7,629
 
By flex1911, Recognized Developer / Retired Forum Moderator on 4th April 2019, 10:33 PM
Post Reply Email Thread
GuestK00164
8th April 2019, 05:47 PM |#21  
Guest
Thanks Meter: 0
 
More
Quote:
Originally Posted by justboryata

Is boot.img the kernel? Sorry if it's a stupid question, and does it work with 4.9 kernels?

Yes and yes
9th April 2019, 04:43 PM |#22  
Senior Member
Flag Sofia
Thanks Meter: 46
 
More
Should this work with OxygenOS GSI?
Any recommendations for GSIs?
Something CAF based? (not AOSP I mean)
*not sure but the last one may be a very stupid question*
9th April 2019, 05:43 PM |#23  
flex1911's Avatar
OP Recognized Developer / Retired Forum Moderator
Flag Volgograd
Thanks Meter: 7,629
 
Donate to Me
More
Quote:
Originally Posted by justboryata

Any recommendations for GSIs?

Yes, any real ROM for tissot.
The Following 3 Users Say Thank You to flex1911 For This Useful Post: [ View ]
10th April 2019, 09:51 PM |#24  
Senior Member
Thanks Meter: 538
 
More
Using your Pie vendor and 4.9 boot with Phh AOSP 112 ab-vanilla-nosu and magisk and open_gapps pico.
Seems to go well. I am happy
Keep maintaining the vendor and boot !
update:
Reverted back to rooted stock V10.0.7.0.PDHMIXM since above combination turned out too slow for comfortable usage after having reinstalled several applications. This is not to say vendor and boot are to blame. It may just as well be the particular combination I flashed.
Again, keep up the good work!
11th April 2019, 12:20 PM |#25  
flex1911's Avatar
OP Recognized Developer / Retired Forum Moderator
Flag Volgograd
Thanks Meter: 7,629
 
Donate to Me
More
Quote:
Originally Posted by Dior DNA

turned out too slow for comfortable usage after having reinstalled several applications. This is not to say vendor and boot are to blame.

they are though. That's a known issue that is going to be fixed soon™
The Following 3 Users Say Thank You to flex1911 For This Useful Post: [ View ]
11th April 2019, 01:15 PM |#26  
Senior Member
Thanks Meter: 538
 
More
Quote:
Originally Posted by flex1911

they are though. That's a known issue that is going to be fixed soon™

Good to hear improvement is under way.

By the way, just curious: does treble content in /vendor differ much from stock pie /system/vendor ?

Have a nice day
11th April 2019, 06:01 PM |#27  
flex1911's Avatar
OP Recognized Developer / Retired Forum Moderator
Flag Volgograd
Thanks Meter: 7,629
 
Donate to Me
More
New update is available now.

Changelog:
  • Updated with latest official LineageOS 16.0 changes
  • Fixed libbinder issue that rendered some custom GSIs unbootable
  • Resolved fingerprint issues on custom GSIs
  • Fixed excessive lag and instability caused by incorrect dalvik heap configuration

Download:
vendor.img and boot.img (11.04.2019)
The Following 29 Users Say Thank You to flex1911 For This Useful Post: [ View ]
12th April 2019, 06:38 PM |#28  
Senior Member
Thanks Meter: 538
 
More
vendor.img and boot.img (11.04.2019) have indeed fixed lag and instability.
amazing combination !
15th April 2019, 05:35 PM |#29  
GabrielHoward's Avatar
Senior Member
Flag Madrid
Thanks Meter: 292
 
Donate to Me
More
Quote:
Originally Posted by flex1911

New update is available now.

Changelog:
Updated with latest official LineageOS 16.0 changes
Fixed libbinder issue that rendered some custom GSIs unbootable
Resolved fingerprint issues on custom GSIs
Fixed excessive lag and instability caused by incorrect dalvik heap configuration


Download:
vendor.img and boot.img (11.04.2019)

Great job! Very smooth
The Following User Says Thank You to GabrielHoward For This Useful Post: [ View ] Gift GabrielHoward Ad-Free
21st April 2019, 06:44 PM |#30  
Mirdeusz's Avatar
Senior Member
Flag Tarnobrzeg
Thanks Meter: 119
 
More
Sadly Pixel sGSI (Pie) port from sailfish and marlin are not compatible with new 4.9 vendor.
I know I can use an old 3.18 vendor but this is unusable due to lags which are fixed on latest vendor, so there is no pixel like Pie gsi right now because Taimen port looks like aosp.
Could you please take a look at old vendor and maybe fix these lags? I really appreciate your hard work, but I have no knownledge how to do this stuff myself. Thanks in advance.
23rd April 2019, 11:21 AM |#31  
michkost858's Avatar
Senior Member
Thanks Meter: 111
 
More
@flex1911 I think that the latest boot.img link has been down for the last 2-3 days.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes