FORUMS
Remove All Ads from XDA

 View Poll Results: Did this method work for you?

Yes
 
115 Vote(s)
66.86%
No
 
45 Vote(s)
26.16%
It did on one device, but not another.
 
12 Vote(s)
6.98%

(5.0.2+5.1) (UPDATED 08/27/2016) How to: Use Verizon Moto E (2015) on ANY GSM network

1,789 posts
Thanks Meter: 417
 
By Whoareyou, Senior Member on 3rd May 2015, 05:11 AM
Post Reply Email Thread
Please follow the updated directions provided by Bendrexl below before attempting any other methods.
Quote:
Originally Posted by bendrexl

Here's a roundup of essential steps from this thread that worked for me...
HUGE THANKS to: Whoareyou, docna, caspar347, Dishe

Prepare for battle:

  1. Ensure your Verizon Moto E 2015 is configured for USB debugging.
  2. Ensure your Verizon Moto E 2015 has airplane mode enabled.
  3. Ensure your PC/Mac has the Android SDK Platform Tools installed & accessible via your terminal / command line (added to $PATH var).
  4. Download 5.0.2 factory image: http://forum.xda-developers.com/moto...age2?nocache=1 (Thanks to caspar347!)
  5. Unzip / expand this .zip archive.
  6. Open a terminal session in the directory you just unzipped (containing NON-HLOS.bin & fsg.mbn)

Execute!
In your terminal with phone plugged in:
  1. $ adb reboot bootloader (your phone should now reboot into bootloader, wait for this)
  2. $ fastboot flash modem NON-HLOS.bin
  3. $ fastboot erase modemst1
  4. $ fastboot erase modemst2
  5. $ fastboot flash fsg fsg.mbn
  6. $ fastboot reboot (WAIT for phone to fully boot before continuing)
  7. $ adb shell (your command prompt will change to something like [email protected]_cdma:/ $. If you get kicked out of the session while entering the next commands, just type adb shell again and pick up where you left off)
  8. [email protected]_cdma:/ $ pm clear com.android.providers.telephony
  9. [email protected]_cdma:/ $ settings put global preferred_network_mode 9
  10. [email protected]_cdma:/ $ settings put global preferred_network_mode1 9
  11. [email protected]_cdma:/ $ settings put global preferred_network_mode2 9
  12. [email protected]_cdma:/ $ pm hide com.motorola.setupwizard.phoneservice (optional)
  13. [email protected]_cdma:/ $ exit (or just unplug & reboot phone)
  14. $ adb reboot (or just unplug & reboot phone)

On the phone:
  1. Turn off Airplane mode
  2. Open Settings app > More > Cellular Networks
  3. Ensure Preferred network type selected is "4G (recommended)"
  4. Under Access Point Names, add the appropriate APNs for your specific carrier. (for Fi data, I only needed "h2g2").
  5. Disable all Verizon apps through settings or Titanium Backup. (Optional)

CREDITS: Whoareyou, docna, caspar347, Dishe




IF YOUR DEVICE IS RUNNING 5.1, FOLLOW THE GREEN INSTRUCTIONS!
In order to attempt to get Verizon/Motorola to push out a new update with a fix for the removal of the option to switch to GSM, please sign this petition on Change.org and share it to anyone who you know will sign it! https://www.change.org/p/verizon-dan...o-e-lte-xt1528
Background Info: I work at Walmart in the Connection Center, and today I had a customer wanting to switch to Family Mobile from AT&T, so I showed them our Family Mobile devices and T-Mobile Devices, they didnt seem interested in them and said they wanted somthing that had Android 5.0 Lollipop, I thought about it for a minute and remembered that the Moto E (2015) shipped with Lollipop installed, I also knew that Verizon phones come unlocked, so I showed them the device and they decided to go with it, they bought the Family Mobile Micro SIM starter kit, and the Moto E, but once I powered it on, I couldn't get it to connect to Family Mobile, so I tried to access the advanced radio menu (*#*#4636#*#*) to no avail, but I eventually got it working, with full LTE support, heres how:

POSSIBLE SIM SWAP WORKAROUND (Reported by wogeboy):
Disable vzwAPNpermissions.apk and vzwAPNservice.apk using this program: http://bit.ly/1HHyVao
I have not tested this as I dont have a VZW Moto E to test it on.


5.1 Updated Instrcutions:
With the SIM you want to use the the phone :
1. Put the phone into Airplane mode (I'm not sure this is needed, but it doesn't hurt)
2. Go to Settings -> About Phone and tap on "Build Number" until it says you are in Developer Mode (~10 times)
3. Go back one menu, and right above About Phone there should now be an option for Developer Options, go into that.
4. Turn on USB Debugging
5. Connect the phone to your computer and type "adb shell" in your CMD window
6. Run the following commands in adb shell :
pm clear com.android.providers.telephony

settings put global preferred_network_mode 9

settings put global preferred_network_mode1 9

settings put global preferred_network_mode2 9

7. Turn off Airplane mode

8. Power off and Restart the phone

9. Open up the settings app, go to the mobile networks panel, select "Prefered Network Mode" and change it to "4G"

10. Input the appropriate APNs for your specific carrier

11. (Optional). Disable all Verizon apps through settings or Titanium Backup.
CREDIT: docna
.


5.0.2 Instructions:
1. Power on the device with the GSM SIM card in the SIM card slot
2. Connect to WiFi and complete Google Sign-In
3. Go to the Play Store and search "Network" download the first app (A white circle with a black phone in it) (This will allow us access to the advance radio options)
4. Open the "Network" shortcut
5. Change the radio mode from "CDMA/LTE PRL" to "GSM/LTE Auto"
6. Open up the settings app, go to the mobile networks panel, select "Prefered Network Mode" and change it to "4G"
7. Input the appropriate APNs for your specific carrier
8 (Optional). Disable all Verizon apps through settings or Titanium Backup.
The only thing I couldnt solve was how to remove the "SIM Card is not from Verizon Wireless" error in the status bar permanently, but thats just an annoyance, and causes no usability decrease.
The Following 83 Users Say Thank You to Whoareyou For This Useful Post: [ View ] Gift Whoareyou Ad-Free
3rd May 2015, 11:19 AM |#2  
Member
Thanks Meter: 7
 
More
This Works!
Thanks a lot, had been trying to get the GSM working. The "Network" app in the Play Store give access to the hidden radio selection menu. Verizon was able to disable all other way to enter the radio selection menu but this one did it. I think there is a apk file somewhere which disables the annoying "NOT verizon SIM" message. I will post here if I find that works.
The Following User Says Thank You to tm515 For This Useful Post: [ View ] Gift tm515 Ad-Free
3rd May 2015, 12:25 PM |#3  
Junior Member
Thanks Meter: 5
 
More
That's a lot easier than poking around in NVram! Thanks, OP. And yeah, there's a Setup app or something you need to freeze for then sim error. I'll have to get mine out and find it.
3rd May 2015, 04:06 PM |#4  
Junior Member
Thanks Meter: 5
 
More
Here are screen snaps. The VZ phone is actually picking up LTE for Ting (T-Mobile).

Click image for larger version

Name:	ImageUploadedByTapatalk1430665550.594262.jpg
Views:	31290
Size:	143.6 KB
ID:	3294494Click image for larger version

Name:	ImageUploadedByTapatalk1430665566.232758.jpg
Views:	31096
Size:	54.9 KB
ID:	3294495
5th May 2015, 12:17 AM |#5  
Junior Member
Flag Los Angeles
Thanks Meter: 2
 
More
Nice. This is definitely some progress. Still waiting for the sprint version to be unlocked.
The Following User Says Thank You to metlahead3236 For This Useful Post: [ View ] Gift metlahead3236 Ad-Free
9th May 2015, 02:57 AM |#6  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by Whoareyou

Background Info: I work at Walmart in the Connection Center, and today I had a customer wanting to switch to Family Mobile from AT&T, so I showed them our Family Mobile devices and T-Mobile Devices, they didnt seem interested in them and said they wanted somthing that had Android 5.0 Lollipop, I thought about it for a minute and remembered that the Moto E (2015) shipped with Lollipop installed, I also knew that Verizon phones come unlocked, so I showed them the device and they decided to go with it, they bought the Family Mobile Micro SIM starter kit, and the Moto E, but once I powered it on, I couldn't get it to connect to Family Mobile, so I tried to access the advanced radio menu (*#*#4636#*#*) to no avail, but I eventually got it working, with full LTE support, heres how:
1. Power on the device with the GSM SIM card in the SIM card slot
2. Connect to WiFi and complete Google Sign-In
3. Go to the Play Store and search "Network" download the first app (A white circle with a black phone in it) (This will allow us access to the advance radio options)
4. Open the "Network" shortcut
5. Change the radio mode from "CDMA/LTE PRL" to "GSM/LTE Auto"
6. Open up the settings app, go to the mobile networks panel, select "Prefered Network Mode" and change it to "4G"
7. Input the appropriate APNs for your specific carrier
8 (Optional). Disable all Verizon apps through settings or Titanium Backup.
The only thing I couldnt solve was how to remove the "SIM Card is not from Verizon Wireless" error in the status bar permanently, but thats just an annoyance, and causes no usability decrease.

Thanks a ton for this! Do you know what the APN setting should be for T-Mobile? That's my current challenge. Every site has a different opinion. Including T-Mobile.
The Following User Says Thank You to Dogwithgoggles For This Useful Post: [ View ] Gift Dogwithgoggles Ad-Free
9th May 2015, 06:30 AM |#7  
Whoareyou's Avatar
OP Senior Member
Flag Olathe, KS
Thanks Meter: 417
 
More
APN: fast.t-mobile.com
MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc

that should be all you have to set
The Following 3 Users Say Thank You to Whoareyou For This Useful Post: [ View ] Gift Whoareyou Ad-Free
9th May 2015, 06:48 PM |#8  
Member
Thanks Meter: 6
 
More
Thumbs up Method Works on SPRINT AND BOOST too
Thanks

This method works on Boost and Sprint too.
Tested in INDIA working fine with indian GSM carriers.
The Following User Says Thank You to samratunlock For This Useful Post: [ View ] Gift samratunlock Ad-Free
11th May 2015, 08:11 PM |#9  
Junior Member
Flag Kyiv
Thanks Meter: 0
 
Donate to Me
More
Quote:
Originally Posted by Whoareyou

Background Info: I work at Walmart in the Connection Center, and today I had a customer wanting to switch to Family Mobile from AT&T, so I showed them our Family Mobile devices and T-Mobile Devices, they didnt seem interested in them and said they wanted somthing that had Android 5.0 Lollipop, I thought about it for a minute and remembered that the Moto E (2015) shipped with Lollipop installed, I also knew that Verizon phones come unlocked, so I showed them the device and they decided to go with it, they bought the Family Mobile Micro SIM starter kit, and the Moto E, but once I powered it on, I couldn't get it to connect to Family Mobile, so I tried to access the advanced radio menu (*#*#4636#*#*) to no avail, but I eventually got it working, with full LTE support, heres how:
1. Power on the device with the GSM SIM card in the SIM card slot
2. Connect to WiFi and complete Google Sign-In
3. Go to the Play Store and search "Network" download the first app (A white circle with a black phone in it) (This will allow us access to the advance radio options)
4. Open the "Network" shortcut
5. Change the radio mode from "CDMA/LTE PRL" to "GSM/LTE Auto"
6. Open up the settings app, go to the mobile networks panel, select "Prefered Network Mode" and change it to "4G"
7. Input the appropriate APNs for your specific carrier
8 (Optional). Disable all Verizon apps through settings or Titanium Backup.
The only thing I couldnt solve was how to remove the "SIM Card is not from Verizon Wireless" error in the status bar permanently, but thats just an annoyance, and causes no usability decrease.

Hello. It does not work in Ukraine. Tried many operators. Line GSM only emergency calls and all.I choose the network settings and 2G and 3G. Prompt what to do please.
12th May 2015, 01:59 AM |#10  
Whoareyou's Avatar
OP Senior Member
Flag Olathe, KS
Thanks Meter: 417
 
More
Quote:
Originally Posted by _Z_x_Z_

Hello. It does not work in Ukraine. Tried many operators. Line GSM only emergency calls and all.I choose the network settings and 2G and 3G. Prompt what to do please.

The device may not support Ukrainian bands, check with your carrier to see what band they use for HSPA/LTE
The Following User Says Thank You to Whoareyou For This Useful Post: [ View ] Gift Whoareyou Ad-Free
12th May 2015, 06:39 AM |#11  
Senior Member
Thanks Meter: 9
 
More
I'll have to get mine out and find it.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes