FORUMS
Remove All Ads from XDA

[ROM][Surnia] CyanogenMod 14 For Moto E LTE

203 posts
Thanks Meter: 683
 
Post Reply Email Thread


Code:
/*
 * Your warranty is now void.
 *
 * I am not responsible for bricked devices, dead SD cards,
 * thermonuclear war, or you getting fired because the alarm app failed. Please
 * do some research if you have any concerns about features included in this ROM
 * before flashing it! YOU are choosing to make these modifications, and if
 * you point the finger at me for messing up your device, I will laugh at you.
 */

Working
  • Boot
  • WiFi
  • Audio
  • Video Playback
  • RIL
  • Camera (photos)

Not Working
  • Video recording (work on CamRingo App)

Installation
- Copy ROM & Gapps
- Reboot in recovery
- Wipe System-Data/Factory reset
- Install the ROM zip
- Install the Gapps (OpenGapps - ARM/7.0/Pico)
- Reboot

Download

Here

XDA:DevDB Information
CyanogenMod 14 ROM for Moto E LTE, ROM for the Moto E 2015

Contributors
srfarias
Source Code: https://github.com/CyanogenMod

ROM OS Version: 7.x Nougat
ROM Kernel: Linux 3.10.x
Based On: CyanogenMod

Version Information
Status: Beta

Created 2016-09-17
Last Updated 2016-11-03
The Following 58 Users Say Thank You to srfarias For This Useful Post: [ View ] Gift srfarias Ad-Free
 
 
17th September 2016, 03:17 PM |#2  
srfarias's Avatar
OP Senior Member
Thanks Meter: 683
 
Donate to Me
More
Reserved
Changelog

Code:
2016/11/02
- First CM14.1 release

Credits: @Seraph08

2016/10/02
- Lot of CM fixes/updates
- Doze (on test)
- Perf profiles cherry-picked
- More..

Thanks @CodyF86 for built it. 

2016/09/18
- Partially fixed camera and some changes (only photos)
- Fixed SDCard issues
- Included FFMPEG codecs
- RIL changes (need test.. etc, i only have xt1527 variant)
- Other cm bugs fixes..

2016/09/17
- Initial release
The Following 18 Users Say Thank You to srfarias For This Useful Post: [ View ] Gift srfarias Ad-Free
17th September 2016, 03:17 PM |#3  
srfarias's Avatar
OP Senior Member
Thanks Meter: 683
 
Donate to Me
More
Reserved
The Following 5 Users Say Thank You to srfarias For This Useful Post: [ View ] Gift srfarias Ad-Free
17th September 2016, 03:28 PM |#4  
Senior Member
Thanks Meter: 109
 
More
Awesome! Thanks for your hard work!
17th September 2016, 03:56 PM |#5  
ElDainosor's Avatar
Senior Member
Thanks Meter: 337
 
Donate to Me
More
Amazing work srfarias!

The RIL is working perfectly (even data works), the audio redirection works too (i mean, how i can hear with headphones) and it's a sad news that the camera doesn't work... but after all, works so god damn stable! Thanks for all the work.

Question: It's there a chance to make the camera work with the libs that Alberto97 use for osprey? At least to have camera partially working...

EDIT

Power off charging and gestures is working great so far
17th September 2016, 04:49 PM |#6  
Sher1234's Avatar
Senior Member
Flag Delhi
Thanks Meter: 143
 
More
Awesome & Thanks @srfarias
Is Moto Actions/CM Actions Working on the build

Sent from my MotoE2(4G-LTE) using XDA-Developers mobile app
17th September 2016, 04:54 PM |#7  
beast99's Avatar
Senior Member
Flag Howrah
Thanks Meter: 127
 
More
You are on fire bro. Keep it up man

Sent from my Moto E LTE (2nd gen) using XDA-Developers mobile app
17th September 2016, 04:56 PM |#8  
VenomMOD's Avatar
Senior Member
Thanks Meter: 80
 
More
com.android.phone keeps force closing for me.
The Following 2 Users Say Thank You to VenomMOD For This Useful Post: [ View ] Gift VenomMOD Ad-Free
17th September 2016, 05:04 PM |#9  
Member
Thanks Meter: 30
 
More
Quote:
Originally Posted by VenomMOD

com.android.phone keeps force closing for me.

I get that as well. Did I miss something during the install, or?
17th September 2016, 05:17 PM |#10  
VenomMOD's Avatar
Senior Member
Thanks Meter: 80
 
More
Quote:
Originally Posted by CrashDSB

I get that as well. Did I miss something during the install, or?

Well, I'm on an XT1526. So I assume it's not working because I'm on a boost mobile variant, which is CDMA. Then again, it could be a bug in the ROM itself.
The Following User Says Thank You to VenomMOD For This Useful Post: [ View ] Gift VenomMOD Ad-Free
17th September 2016, 05:17 PM |#11  
Member
Thanks Meter: 30
 
More
Quote:
Originally Posted by VenomMOD

Well, I'm on an XT1526. So I assume it's not working because I'm on a boost mobile variant, which is CDMA. Then again, it could be a bug in the ROM itself.

I'm on XT1526 as well. If that's the case, then that's really a shame, oh well.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes