FORUMS

[ROM] [UNOFFICIAL] [8.1] LineageOS-15.1 [Otus]

646 posts
Thanks Meter: 1,753
 
By prakharluv, Senior Member on 15th April 2018, 02:30 PM
Post Reply Email Thread

LineageOS is a free, community built, aftermarket firmware distribution of Android 8 (oreo), which is designed to increase performance and reliability over stock Android for your device.

LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review.



Code:
/*
 * Your warranty is now void.
 *
 * I am not responsible for bricked devices, dead SD cards, dead cats,
 * thermonuclear war, or you getting fired because the alarm app failed.  
 * YOU are choosing to make these modifications, and no point
 * in pointing the finger at me for messing up your device
 */
  • Download the latest build and GApps
  • Reboot to recovery
  • Do a factory reset (wipe /data , /system and /cache)
  • Flash the latest build and GApps
  • Reboot



LineageOS 15.1 for Moto E 2015(OTUS)
Open GApps

  • LineageOS Team
  • Google AOSP
  • CodeAurora Forums
  • CyanogenMod Team
  • Anderson Mendes (For Kernel Source)

SOURCES-

LineageOS Github
LineageOS Gerrit
Kernel Source

XDA: DevDB Information
LineageOS-15.1, ROM for the Moto E 2015 (Otus)

Contributors
@prakharluv
Source Code: https://github.com/LineageOS

ROM OS Version: 8.x Oreo
ROM Kernel: Linux 3.10.x

Version Information
Status: Stable
Current Stable Version: 15.1
Stable Release Date: 2018-04-14

Created 2018-04-14
Last Updated 2018-04-14
The Following 8 Users Say Thank You to prakharluv For This Useful Post: [ View ] Gift prakharluv Ad-Free
15th April 2018, 02:31 PM |#2  
prakharluv's Avatar
OP Senior Member
Flag Allahabad
Thanks Meter: 1,753
 
Donate to Me
More
Screenshots
Screenies
Attached Thumbnails
Click image for larger version

Name:	IMG_20180415_185633.jpg
Views:	1750
Size:	33.8 KB
ID:	4477041   Click image for larger version

Name:	IMG_20180415_185634.jpg
Views:	1788
Size:	50.2 KB
ID:	4477042   Click image for larger version

Name:	IMG_20180415_185636.jpg
Views:	1766
Size:	39.5 KB
ID:	4477043   Click image for larger version

Name:	IMG_20180415_185637.jpg
Views:	1668
Size:	46.1 KB
ID:	4477044  
15th April 2018, 02:31 PM |#3  
prakharluv's Avatar
OP Senior Member
Flag Allahabad
Thanks Meter: 1,753
 
Donate to Me
More
Reserved 2
15th April 2018, 10:54 PM |#5  
Junior Member
Thanks Meter: 6
 
More
Pattern lock issue still available.
27th May 2018, 01:30 PM |#6  
Senior Member
Flag Bengaluru
Thanks Meter: 44
 
More
It's a great ROM everything works but
Bug : Whenever I turn on Total Silence mode and then switch back to Normal mode, the speaker itself stops playing any audio including alarms, notifications,music, etc. no FCs but the loudspeaker simply fails. Idk if there's a possible workaround. Sorry I couldn't log it.
27th May 2018, 02:59 PM |#7  
Senior Member
Thanks Meter: 417
 
More
Quote:
Originally Posted by rpravenclaw

It's a great ROM everything works but
Bug : Whenever I turn on Total Silence mode and then switch back to Normal mode, the speaker itself stops playing any audio including alarms, notifications,music, etc. no FCs but the loudspeaker simply fails. Idk if there's a possible workaround. Sorry I couldn't log it.

How long do you keep it on total silence? I keep my phone on alarm only for hours, but I don't face this issue. I also tried putting my phone on total silence for about 5 mins and the speaker still works.
27th May 2018, 04:32 PM |#8  
Senior Member
Flag Bengaluru
Thanks Meter: 44
 
More
Quote:
Originally Posted by Dev_Mashru

How long do you keep it on total silence? I keep my phone on alarm only for hours, but I don't face this issue. I also tried putting my phone on total silence for about 5 mins and the speaker still works.

I keep it Max for one hour or so... This happened twice, both clean flash... Restarts don't fix it..
Okay which GApps do you use? Let me try this ROM again I don't mind..
28th May 2018, 11:20 AM |#9  
Senior Member
Thanks Meter: 417
 
More
Quote:
Originally Posted by rpravenclaw

I keep it Max for one hour or so... This happened twice, both clean flash... Restarts don't fix it..
Okay which GApps do you use? Let me try this ROM again I don't mind..

I kept for about 1-2 hours and it still worked fine... I used nano variant of opengapps.
The Following User Says Thank You to Dev_Mashru For This Useful Post: [ View ] Gift Dev_Mashru Ad-Free
29th May 2018, 04:56 AM |#10  
Member
Thanks Meter: 10
 
More
Can anyone tell me the bugs because this is my primary device. Thank you
13th June 2018, 03:39 AM |#11  
Senior Member
Flag Seremban
Thanks Meter: 111
 
Donate to Me
More
two minor bug, always show vendor image not up to date .but still able to use it.
can't flash magisk.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes