FORUMS
Remove All Ads from XDA

[Recovery] Unofficial CWM - 6.0.5.0 - peregrine

4,881 posts
Thanks Meter: 5,422
 
By shabbypenguin, Inactive Recognized Developer on 16th July 2014, 05:53 PM
Post Reply Email Thread
Shabbypenguin and the OUDHS
presents to you

ClockWorkMod Recovery 6.0.5.0
for your Moto G LTE

You need to be unlocked to use this i suggest following this guide

CWM-6.0.5.0 https://mega.co.nz/#!sdRBTKQZ!Km20It...NinAC_dihtyoSY
CWM-Touch-6.0.5.0 https://mega.co.nz/#!ZNxiFBjL!0w7Jdy..._IA5KAngpst130

Code:
fastboot flash recovery CWM-6.0.5.0-peregrine.img
-----------------------------------------------------------------------------------------------------------------
Congrats you now have CWM now if you wish to root youll need to follow these instructions
-----------------------------------------------------------------------------------------------------------------


SuperSU


Directions:

1) Download the above file
2) Connect your phone and copy them to your phone or your sdcard
3) Once they are copied power down your device
4) Hold volume up, down and power to enter bootloader mode
5) using volume down scroll to recovery and then use volume up to select
6) Navigate recovery by using the volume keys and power to select
7) Choose install zip from sdcard, then pick internal or external (where you copied it to)
8) Scroll down to the SuperSU.zip and select it to install

-----------------------------------------------------------------------------------------------------------------
Congrats you are rooted! this procedure will work on any firmware update you guys get
-----------------------------------------------------------------------------------------------------------------


Bugs:
Certain SDcards dont appear to work in recovery even though they work when booted, may be a brand or speed thing not sure :/.

Credits:
eteles - testing
suhridkhan - testing
dhacker - for all the heavy lifting on previous moto devices.


The Following 48 Users Say Thank You to shabbypenguin For This Useful Post: [ View ] Gift shabbypenguin Ad-Free
 
 
16th July 2014, 06:08 PM |#2  
Member
Flag Maplewood, MN
Thanks Meter: 10
 
More
Thumbs up
Thanks for your hard work
The Following User Says Thank You to djcody For This Useful Post: [ View ] Gift djcody Ad-Free
16th July 2014, 06:31 PM |#3  
Member
Flag Naples
Thanks Meter: 2
 
More
Is there a Moto X dt version?
16th July 2014, 06:34 PM |#4  
stephtban's Avatar
Member
Flag Toulouse
Thanks Meter: 58
 
More
Hello @shabbypenguin !

Thanks for porting CWM to our awesome Moto G 4G!
Is this fully functional? Does sdcard works?
Thx
16th July 2014, 06:35 PM |#5  
shabbypenguin's Avatar
OP Inactive Recognized Developer
Thanks Meter: 5,422
 
Donate to Me
More
Quote:
Originally Posted by stephtban

Hello @shabbypenguin !

Thanks for porting CWM to our awesome Moto G 4G!
Is this fully functional? Does sdcard works?
Thx

yes spent several hours last night trying to work on the dts files and seif i could figure it out and had a test build this morning only to find out that moto pushed new source that fixed it :P
The Following 2 Users Say Thank You to shabbypenguin For This Useful Post: [ View ] Gift shabbypenguin Ad-Free
16th July 2014, 06:37 PM |#6  
stephtban's Avatar
Member
Flag Toulouse
Thanks Meter: 58
 
More
Awesome!
A new world is there!!
Thanks a lot!

...and sorry for your wasted time ^^
16th July 2014, 06:52 PM |#7  
vpnair's Avatar
Senior Member
Melbourne
Thanks Meter: 186
 
More
Running Motorola XT1039 - Peregrine

Have already rooted via SuperSU flash from fastboot boot. First time flashing custom recovery on this phone.

Cant access or mount external SD. Also, I cannot boot into recovery from bootloader.

I:Checking for extendedcommand...
I:Skipping execution of extendedcommand, file not found...
I: Cannot load volume /misc
mount: mounting /dev/block/mmcblk1p1 on /external_sd failed: No such file or directoy
E: Can't mount /external_sd
mount: mounting /dev/block/mmcblk1p1 on /external_sd failed: No such file or directoy
E: Can't mount /external_sd
I: Cannot load volume /misc
I: using /data/media/0/ for /sdcard
mount: mounting /dev/block/mmcblk1p1 on /external_sd failed: No such file or directoy
E: Can't mount /external_sd
I: Cannot load volume /misc
I: Cannot load volume /misc

I have no issues with accessing SD card once Android boots up. I have tried, reflashing recovery and erasing cache via fastboot. Anything I should try?

EDIT: Fixed by swapping out my Samsung 32gb UHS-1 MicroSD (that was working fine when I booted android) with an 8gb Class 4 Kingston! No UHS-1 in recovery?
The Following User Says Thank You to vpnair For This Useful Post: [ View ] Gift vpnair Ad-Free
16th July 2014, 07:00 PM |#8  
shabbypenguin's Avatar
OP Inactive Recognized Developer
Thanks Meter: 5,422
 
Donate to Me
More
interesting, @eteles has a xt1040 i believe and he reported that it was working with the new dtb files.
16th July 2014, 07:05 PM |#9  
Senior Member
Thanks Meter: 134
 
More
Quote:
Originally Posted by shabbypenguin

interesting, @eteles has a xt1040 i believe and he reported that it was working with the new dtb files.

It works flawlessly on XT1040... Using 32GB sandisk class 10 sdcard...
16th July 2014, 07:06 PM |#10  
stephtban's Avatar
Member
Flag Toulouse
Thanks Meter: 58
 
More
Flashed it via the app rashr on my XT1039
I can access my sdcard files and backup to it (that's all i tested so far)
@vpnair : maybe you can try to download it again
The Following 2 Users Say Thank You to stephtban For This Useful Post: [ View ] Gift stephtban Ad-Free
16th July 2014, 07:10 PM |#11  
Narkoa's Avatar
Junior Member
Thanks Meter: 10
 
More
Congrats and thank you a lot !
You guys are amazing. Seriously ^^
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes