Remove All Ads from XDA
Honor 9 Lite

[Q] MTP not working.

8 posts
Thanks Meter: 0
Post Reply Email Thread
Hi! I need help with an issue on my device, it's a Moto G XT1032 running the optimized version of Kitkat 4.4.4 provided by user lost101 and previously available here: .
My laptop is running Windows 7, 64 bits.

The problem I'm having is that whenever I connect it to my laptop the device starts charging the battery (hence the cable works) but doesn't allow me to use MTP. The USB icon doesn't prompt on the status bar and on the laptop nothing pops up.

I've turned off and on again the MTP check box on setings/storage. Already uninstalled and reinstalled the Motorola Device Manager (at least three times). Also tried installing the Drivers by themselves and is still not working. Found a thread ( where multiple users claim to have find the method as a solution but doesn' work for me.

Any solution you can provide? Thanks in advance.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes