FORUMS

[DISCONTINUED] LineageOS 17.1

47 posts
Thanks Meter: 13
 
By AgentICS, Member on 3rd January 2020, 04:52 AM
Post Reply Email Thread
Originally, this was thread was centered on the LineageOS 17 GSI by AndyYan, however, CodeF86 has so very generously made a working GSI for the Moto G6 which you can try out now!

Unlike AndyYan's generic GSI, for this you do NOT need to flash johnaltg1's LineageOS 16 image (if you do, this GSI will NOT boot). It is recommended you use stock Pie firmware. Oreo firmware has not been tested and may result in bugs.
Download here—Compiled Feb 22nd, w/ working LTE!
See CodyF86's thread post

Some notes:
  • Unlike the generic GSI, calling works.
  • Also unlike the GSI, the colors don't invert randomly.
  • Magisk DOES NOT work at the moment, neither phhuson's nor regular Magisk. Flashing it will cause a bootloop.
  • Bluetooth audio has been reported to not work
  • As with many Android 10 GSIs/ROMs, Chrome freezes or crashes because GApps packages currently are missing the new Trichrome WebView implementation which replaces Chrome as the default WebView. This being worked on (see OpenGApps wiki and issue #773 on their GitHub.) For now, use another browser (like LineageOS's default browser) if you install GApps. —As soon as Trichrome is added onto the ARM package just as it has for ARM64, Chrome should be stable.

For now, that's all I can think of. However, if you notice any other bugs or caveats, let me know so I can add it to the list.

This is a GSI based on phhuson's prereleased GSI work and also based on the prereleased LineageOS 17. This is a pre-release so please be careful and don't use this as a daily driver. Things may break randomly, whoops, so please be patient! If you see any bugs, report them here.

Extremely huge shoutout to CodyF86 for this GSI!

The developer of this ROM has moved on to another phone and the community now has a full fledged 64-bit ROM which has much better support for things.
The Following 7 Users Say Thank You to AgentICS For This Useful Post: [ View ] Gift AgentICS Ad-Free
4th January 2020, 07:17 PM |#2  
Junior Member
Flag San Diego, CA
Thanks Meter: 0
 
More
Lightbulb
Quote:
Originally Posted by AgentICS

The LineageOS 17 GSI works great on the Moto G6. There are some caveats however for anyone willing to try it:

  1. You MUST first flash the LineageOS 16.0 ROM first or else you will bootloop.
  2. Use this Magisk from phhuson's official GitHub
  3. Your screen may change colors and look weird, when this happens, go to Settings > Display > LiveDisplay> Color mode and change it to the value under the value selected on the menu and then back to the original one and that should fix it
  4. If you flash GApps before first boot, follow AndyYan's suggestions as the Setup Wizard is broken for some reason on most GApps packages.
  5. Calling while not on WiFi is broken for now.
For now, that's all I can think of. However, if you notice any other bugs or caveats, let me know so I can add it to the list.

This is a GSI based on phhuson's prereleased GSI work and also based on the prereleased LineageOS 17. Things may break randomly, whoops, so please be patient!

Just to reiterate, you are stipulating that this pre-release build doesn't permit me to make an outgoing phone call (nor possibly receive any) unless connected to a WiFi network? Please pardon my not-so-subtle-sarcasm ... but, why would anyone release this with a bug (or limitation) which inhibits the core functionality of the device? I could see a million other issues being permissible but not being able to make normal phone calls (or possibly even receive them) doesn't warrant any kind of release for testing. That being said, I'd be happy to help if possible and eagerly await a usable version of Android 10 to put on my Moto G6 which I only got a month ago (happily unlocked at a great price on Amazon). However, it is (currently) my main phone for making calls.
6th January 2020, 08:48 AM |#3  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by xda4joe

Just to reiterate, you are stipulating that this pre-release build doesn't permit me to make an outgoing phone call (nor possibly receive any) unless connected to a WiFi network? Please pardon my not-so-subtle-sarcasm ... but, why would anyone release this with a bug (or limitation) which inhibits the core functionality of the device? I could see a million other issues being permissible but not being able to make normal phone calls (or possibly even receive them) doesn't warrant any kind of release for testing. That being said, I'd be happy to help if possible and eagerly await a usable version of Android 10 to put on my Moto G6 which I only got a month ago (happily unlocked at a great price on Amazon). However, it is (currently) my main phone for making calls.

everything works for me
7th January 2020, 09:45 AM |#4  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by taiyofurukawa

everything works for me

so you can make phone calls without WIFI conection?
8th January 2020, 06:16 AM |#5  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by xavcasgar

so you can make phone calls without WIFI conection?

yesssss
14th January 2020, 03:23 AM |#6  
OP Member
Thanks Meter: 13
 
More
Quote:
Originally Posted by xda4joe

Just to reiterate, you are stipulating that this pre-release build doesn't permit me to make an outgoing phone call (nor possibly receive any) unless connected to a WiFi network? Please pardon my not-so-subtle-sarcasm ... but, why would anyone release this with a bug (or limitation) which inhibits the core functionality of the device? I could see a million other issues being permissible but not being able to make normal phone calls (or possibly even receive them) doesn't warrant any kind of release for testing. That being said, I'd be happy to help if possible and eagerly await a usable version of Android 10 to put on my Moto G6 which I only got a month ago (happily unlocked at a great price on Amazon). However, it is (currently) my main phone for making calls.

It is pre-release so not all the bugs are ironed out, I should have added that this should not be used on your daily driver. But yes, it's dumb to use a phone that can't make calls without WiFi. Just as a note, you can make and receive calls however if you're not using WiFi, the caller can't hear you. I have filed a bug upstream with phhusson as this affects every GSI built using his work (Pixel Experience, Lineage and AOSP which I've tested). I hope this gets fixed soon so stay tuned to that GitHub issue
14th January 2020, 03:25 AM |#7  
OP Member
Thanks Meter: 13
 
More
Quote:
Originally Posted by taiyofurukawa

everything works for me

Quote:
Originally Posted by xavcasgar

so you can make phone calls without WIFI conection?

Quote:
Originally Posted by taiyofurukawa

yesssss

How? What is your modem version/phone model?
25th January 2020, 07:46 AM |#8  
Junior Member
Thanks Meter: 0
 
More
Can't Boot
Quote:
Originally Posted by AgentICS

The LineageOS 17 GSI works great on the Moto G6. There are some caveats however for anyone willing to try it:

  1. You MUST first flash the LineageOS 16.0 ROM first or else you will bootloop.
  2. Use this Magisk from phhuson's official GitHub
  3. Your screen may change colors and look weird, when this happens, go to Settings > Display > LiveDisplay> Color mode and change it to the value under the value selected on the menu and then back to the original one and that should fix it
  4. If you flash GApps before first boot, follow AndyYan's suggestions as the Setup Wizard is broken for some reason on most GApps packages.
  5. Calling while not on WiFi is broken for now.
  6. Bluetooth is horribly broken for now, it causes the app playing audio to lag and crash so please stay away from it.
  7. Chrome is wonky at the moment. It'll work and then all of a sudden cause the whole OS to lag and crash or become unresponsive. This is possibly an upstream GApps issue.
For now, that's all I can think of. However, if you notice any other bugs or caveats, let me know so I can add it to the list.

This is a GSI based on phhuson's prereleased GSI work and also based on the prereleased LineageOS 17. This is a pre-release so please be careful and don't use this as a daily driver. Things may break randomly, whoops, so please be patient!

I am documenting everything on here. Stay tuned to that page for more info and further updates. Addiotionally, I have filed a bug report regarding calling, please add on to that GitHub issue and bump it so it can get resolved.

Ok, so I installed and flashed Lineage 16 first. Then I flashed Lineage 17 GSI in system img, but then when I did that I go into twrp and it said an os was not installed and wouldn't boot. But if I just flash Lineage 16 it would boot. Am I doing something wrong?
26th January 2020, 01:18 AM |#9  
OP Member
Thanks Meter: 13
 
More
Quote:
Originally Posted by SomeAndrodGuyWithInternet

Ok, so I installed and flashed Lineage 16 first. Then I flashed Lineage 17 GSI in system img, but then when I did that I go into twrp and it said an os was not installed and wouldn't boot. But if I just flash Lineage 16 it would boot. Am I doing something wrong?

First off, are you unzipping the file? The standalone uncompressed file is unflashable. It needs to be decompressed from it's .gz (or whatever it was compressed to) form. If you have, have you tried using fastboot flash system <lineage file name> from a PC?
3rd February 2020, 03:13 AM |#10  
Senior Member
Thanks Meter: 70
 
More
Quote:
Originally Posted by AgentICS

It is pre-release so not all the bugs are ironed out, I should have added that this should not be used on your daily driver. But yes, it's dumb to use a phone that can't make calls without WiFi. Just as a note, you can make and receive calls however if you're not using WiFi, the caller can't hear you. I have filed a bug upstream with phhusson as this affects every GSI built using his work (Pixel Experience, Lineage and AOSP which I've tested). I hope this gets fixed soon so stay tuned to that GitHub issue

Just wanted to jump in here and say I'm seeing same bug on xt1925-6 with callers not able to hear me on any 10 gsi's and speakerphone does not work at all. Phh aosp 10 build 209 with stock pie 55-37-7-2 boot vendor boots fine, other gsi's will only boot using the Ali lineage full ROM boot- vendor but call audio is broken as well. Thanks for submitting the bug report, hopefully it will get fixed in future builds.
16th February 2020, 10:41 PM |#11  
CodyF86's Avatar
Senior Member
Flag Grand Junction, CO
Thanks Meter: 3,967
 
Donate to Me
More
Hello friends,

It's been a while since i've posted on XDA. I was the person who originally rooted the g6 play. I managed to build a GSI image of 17.1 with the latest code as of today if anyone is interested I can upload it to gdrive or something, didn't feel like making a new thread.

It boots, mobile calls work, dark mode works (which is amazing), it all seems to work.

Getting it to compile was just short of a miracle...lol.

Only bad thing is I cannot get it to boot with any version of magisk even the version specifically for phh / Android 10, but with just the stock kernel with the ,verify removed it boots fine.
The Following 4 Users Say Thank You to CodyF86 For This Useful Post: [ View ] Gift CodyF86 Ad-Free
Post Reply Subscribe to Thread

Tags
android 10, gsi, lineageos, treble

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes