FORUMS
Remove All Ads from XDA

XT1095 - forgot to unlock before attempting to downgrade 5.1->5.0

59 posts
Thanks Meter: 19
 
By MondoMor, Member on 28th June 2015, 02:12 PM
Post Reply Email Thread
I have an XT1095. I flashed the 23.1.28 leaked OTA a couple of months ago to get to 5.1, and now I'm attempting to get to the final 5.1 OTA. My phone was unrooted, and had the stock recovery.

I downloaded the nycgraffix 5.0 image. I followed this guide, but I forgot to unlock the bootloader. I got partway though flashing the files before I realized my mistake. Here's how it went, to the best of my memory:
  • Unzip the stock 5.0 image SUCCEEDED
  • Boot into fastboot SUCCEEDED
  • fastboot flash logo logo.bin SUCCEEDED
  • fastboot flash boot boot.img SUCCEEDED
  • fastboot flash recovery recovery.img SUCCEEDED
  • fastboot flash system system.img_sparsechunk.0 FAILED

Here's what happened on the failure:
Code:
C:\android\x\gnyc>fastboot flash system system.img_sparsechunk.0
target reported max download size of 536870912 bytes
sending 'system' (256598 KB)...
OKAY [  8.081s]
writing 'system'...
(bootloader) Invalid signed image
(bootloader) Preflash validation failed
FAILED (remote failure)
finished. total time: 8.190s
At this point, I realized I forgot to unlock, so I issued the "fastboot oem unlock" command with the key I got from Motorola. Unfortunately, this now fails:

Code:
C:\android\x\gnyc>fastboot oem unlock JQ3QVNTEBxxxxxxxxxx
...
(bootloader) Check 'Enable OEM Unlock' in Developer Options.
FAILED (remote failure)
finished. total time: 0.016s
The phone now only boots into fastboot, saying "Fastboot Reason: Last time flashing failed".

I'd be grateful for any help bailing out of this.
 
 
28th June 2015, 02:51 PM |#2  
OP Member
Thanks Meter: 19
 
More
I decided to try the stock image that Motorola posted (note: this image won't allow you to get the 5.1 OTA!). Using the fastboot from Android's SDK, I did this:

Code:
1. Make sure you have a Moto Pure Edition or a Developer Edition device.
2. Make sure you download the corresponding recovery image from the above portal.
3. To flash, put the phone in fastboot mode: Power OFF...then Power ON+Volume Down .Alternatively, you can reboot into fastboot mode if you have adb... adb reboot bootloader
4. Next flash the images using fastboot:

$ fastboot flash partition gpt.bin
$ fastboot flash motoboot motoboot.img
$ fastboot reboot-bootloader
$ fastboot flash logo logo.bin
$ fastboot flash boot boot.img
All these succeeded except the boot.img. So I tried unlocking again:

Code:
C:\android\x\official\TMO_LXE22.46-11_22.21.11.victara_tmo.tmo.en.US\TMO_LXE22.4
6-11_22.21.11.victara_tmo.tmo.en.US>fastboot oem unlock JQ3QVxxxxxxxxxxxx
...
(bootloader) Unlock code = JQ3QVxxxxxxxxxxxx

(bootloader) Unlock completed! Wait to reboot
Since that succeeded, I tried again:

Code:
$ fastboot flash logo logo.bin
$ fastboot flash boot boot.img
$ fastboot flash recovery recovery.img
$ fastboot flash system system.img
$ fastboot flash modem NON-HLOS.bin
$ fastboot erase modemst1 
$ fastboot erase modemst2 
$ fastboot flash fsg fsg.mbn
$ fastboot reboot
These all succeeded and I'm booting to 5.0 again. Now I'll re-attempt the nycgraffix image so I can finally get the real 5.1 OTA.
28th June 2015, 03:08 PM |#3  
OP Member
Thanks Meter: 19
 
More
I got the 5.1 OTA update as soon as I booted into the GraffixNYC image. I donated $20, since Motorola's own image is screwed up.

My next phone will be a Nexus. This phone has been a complete mess.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes