FORUMS
Remove All Ads from XDA

[ROM][8.1.0_r52] LineageOS 15.1 [LUX] [UNOFFICIAL]

1,404 posts
Thanks Meter: 2,350
 
By althafvly, Recognized Contributor on 14th February 2018, 01:14 AM
Post Reply Email Thread
Hey ,

Welcome to the goodness of Oreo. This topic will be dedicated to our bring up of Oreo for Moto X Play


Disclamier:

* Include <std_disclaimer.h>
* Your warranty is now void.
* I am not responsible for bricked devices, dead SD cards,
* thermonuclear war, or you getting fired because the alarm app failed. Please
* do some research if you have any concerns about features included in this ROM
* before flashing it! YOU are choosing to make these modifications, and if
* you point the finger at me for messing up your device, I will laugh at you.
*







- Please Do Not Mirror our files without talking to us. We can do that ourselves should we desire to. -



What's working?
RIL
Camera
WiFi
Camcorder
Storage
4G


What's not working?

..


Downloads:


Download ( lux )



Credits:

AOSP
Open Gapps
LineageOS
TheMuppets


XDA:DevDB Information
[ROM][8.1.0_r26] LineageOS 15.1 [LUX] [UNOFFICIAL], ROM for the Moto X Play

Contributors
althafvly, squid2
Source Code: https://github.com/moto-m8916/device_motorola_lux

ROM OS Version: 8.x Oreo
Based On: Lineage

Version Information
Status: Beta

Created 2018-02-14
Last Updated 2018-05-25
The Following 24 Users Say Thank You to althafvly For This Useful Post: [ View ] Gift althafvly Ad-Free
 
 
14th February 2018, 01:14 AM |#2  
althafvly's Avatar
OP Recognized Contributor
Flag Malappuram
Thanks Meter: 2,350
 
Donate to Me
More
Reserved
13-02-2018

-Initial Build
The Following 5 Users Say Thank You to althafvly For This Useful Post: [ View ] Gift althafvly Ad-Free
15th February 2018, 05:04 AM |#3  
estuardo4's Avatar
Senior Member
Thanks Meter: 104
 
More
Hello. Thank you for this build. I've installed it, Everything seems to be running as it should, except the battery. The draining is greater than usual as when you install a new ROM. And charging the phone is also taking longer than usual. From 100% to 10% in four hours, and about 30 minutes of SOT and almost no activity.

Other than that, it is running fine. I've installed Xposed, Magisk and substratum with no issue.

Thank you again.
The Following User Says Thank You to estuardo4 For This Useful Post: [ View ] Gift estuardo4 Ad-Free
16th February 2018, 01:11 PM |#4  
Member
Flag Curitiba
Thanks Meter: 8
 
More
I got an error installing:

Updater process ended with ERROR: 7
Error installing zip file '/external_sd/Flash/lineage-15.1-20180213-UNOFFICIAL-lux.zip'

Do I need a specific version of TWRP? I'm using 3.1.1-r1


I'm sorry, I just updated to TWRP 3.2.1-r1 and it's flashing properly. I'll report back later with the ROM status.
16th February 2018, 01:39 PM |#5  
plb-dev's Avatar
Senior Member
Flag Trivandrum
Thanks Meter: 94
 
More
Can confirm insane battery drain. Also the NFC bug.
19th February 2018, 09:43 PM |#6  
Senior Member
Thanks Meter: 68
 
More
Quote:
Originally Posted by plb-dev

Can confirm insane battery drain. Also the NFC bug.

Sorry I must have missed that...what NFC bug exactly?
20th February 2018, 03:14 AM |#7  
plb-dev's Avatar
Senior Member
Flag Trivandrum
Thanks Meter: 94
 
More
Quote:
Originally Posted by x2k13

Sorry I must have missed that...what NFC bug exactly?

XenonHD dev had mentioned about it in that thread. The NFC service keeps toggling on and off automatically. Sometimes you won't be able to turn it off. As I don't need NFC, i disabled the NFC app and it's services.
The Following User Says Thank You to plb-dev For This Useful Post: [ View ] Gift plb-dev Ad-Free
21st February 2018, 07:08 PM |#8  
amunarjoh's Avatar
Senior Member
Flag Hundvåg
Thanks Meter: 69
 
Donate to Me
More
Also experiencing bad battery drain. Nice and smooth, though
21st February 2018, 07:39 PM |#9  
estuardo4's Avatar
Senior Member
Thanks Meter: 104
 
More
Quote:
Originally Posted by amunarjoh

Also experiencing bad battery drain. Nice and smooth, though

I uninstalled (like others have recommended on other Oreo 8.1 forums for the X Play) com.android.nfc and battery life has increased. But more importantly, the phone is running cooler than before.
The Following User Says Thank You to estuardo4 For This Useful Post: [ View ] Gift estuardo4 Ad-Free
21st February 2018, 08:10 PM |#10  
amunarjoh's Avatar
Senior Member
Flag Hundvåg
Thanks Meter: 69
 
Donate to Me
More
Quote:
Originally Posted by estuardo4

I uninstalled (like others have recommended on other Oreo 8.1 forums for the X Play) com.android.nfc and battery life has increased. But more importantly, the phone is running cooler than before.

Thank you for the advise. Will try that next ROM flash
26th February 2018, 02:45 AM |#11  
Junior Member
Thanks Meter: 0
 
More
What version of twrp did you use to install the room? I have twrp 3.0 and I get erro
Quote:
Originally Posted by estuardo4

Hello. Thank you for this build. I've installed it, Everything seems to be running as it should, except the battery. The draining is greater than usual as when you install a new ROM. And charging the phone is also taking longer than usual. From 100% to 10% in four hours, and about 30 minutes of SOT and almost no activity.

Other than that, it is running fine. I've installed Xposed, Magisk and substratum with no issue.

Thank you again.

Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes