FORUMS

[ROM] [Q][10] Evolution-X 4.0 for Moto Z-Griffin[TREBLE]

57 posts
Thanks Meter: 32
 
Post Reply Email Thread
Thanks to your feedback I have added some extra steps to ensure that everyone can enjoy the GSI ROM

First of all I am not the creator of this ROM-GSI I only share it in the XDA community and give all the credit to @turbolukex5
You can download and try all of his work from
https://sourceforge.net/projects/expressluke-gsis/files You can see all the work of him in https://forum.xda-developers.com/pro...-gsis-t4003457

Evolution X 4.0 has all the extra features of the AOSP ROMs plus extra features of Evolution X and all the sweetness of the Pixel. Tested by myself, like Lineage is stable for daily use without any problem of any kind (obviously we all know that moto-mods don't work, only the moto-mod battery in default mode) when used in Moto Z. Needless to say, as you read in the title this ROM is GSI so if you want to try it you need to have Official Lineage OS 16 installed in your Moto Z before attempting to install the GSI image.

So let's go to the installation steps:

Steps when you are already in another GSI
1. Download the GSI image from https://sourceforge.net/projects/exp...X/Ten/ARM64/A/ EvolutionX_4.0_ARM64A-10.0-20200112-2146-GSI.img.xz
2. Unzip the file to extract the system image and copy it inside your Moto Z
3. Go to TWRP and wipe Data(not internal storage) /Cache/System
4. Go to Install and change to Install image
5. Select the image of Evolution X and flash as system partition
6. Flash Magisk Canary if you want root, gapps already included
6. Reboot to System
7. Wait fist boot and enjoy Evolution X 4.0

First Install/Clean install

1. Install Official Lineage OS 16
2. Boot to Lineage 16
3. Reboot TWRP
4. Wipe System, Data, Cache, Internal Storage
5. Reboot to recovery
6. Copy Evolution X 4 GSI image to Internal storage
7. Go Install IMAGE and select as System partition
8. Flash permissiver_v4
9. Reboot to System
10. Wait first boot and enjoy Evolution X 4.0

By far the best GSI I have tested for our Moto Z

Screenshots

https://imgur.com/a/vxLkVUj

Extra Tips:
Magisk Modules
LSpeed Magisk Module for extra battery life
Magisk Dolby ATMOS Q. Although the GSI already comes with very good audio

One more:
Arnova Gcam


Android OS version: 10.0
Security patch level: January 2020
GSI author: turbolukex5
Source code: https://github.com/Evolution-X
ROM Developer: joeyhuab
ROM Kernel: Linux 3.18
ROM Firmware Required: Official Lineage OS 16
Based On: AOSP

Version Information
Status: Stable
Current Stable Version: 4.0
Stable Release Date: 2020-01-12
Attached Files
File Type: zip Permissiver_v4.zip - [Click for QR Code] (1.10 MB, 32 views)
The Following 5 Users Say Thank You to mosfet321 For This Useful Post: [ View ] Gift mosfet321 Ad-Free
11th February 2020, 08:33 AM |#2  
Senior Member
Thanks Meter: 255
 
More
Quote:
Originally Posted by mosfet321


Evolution X 4.0
Status: Stable
Current Stable Version: 4.0
Stable Release Date: 2020-01-12

Hey, thanks for the great share!

1. 'By far the best GSI I have tested for our Moto Z' - have you already tested havoc 3 gsi?
2. please, change this in the description "no gapps already included" it's not clear if they are included or not. simply state 'gapps included'
3. how long should one wait for boot? - for me it's on boot animation min 15 already.
3.1 currently can't pass boot animation (-05 china version of Moto Z)
4. is latest official twrp OK for flashing this image?
The Following User Says Thank You to dimdimdim For This Useful Post: [ View ] Gift dimdimdim Ad-Free
11th February 2020, 02:57 PM |#3  
OP Member
Flag Aguascalientes, Mex.
Thanks Meter: 32
 
More
Quote:
Originally Posted by dimdimdim

Hey, thanks for the great share!

1. 'By far the best GSI I have tested for our Moto Z' - have you already tested havoc 3 gsi?
2. please, change this in the description "no gapps already included" it's not clear if they are included or not. simply state 'gapps included'
3. how long should one wait for boot? - for me it's on boot animation min 15 already.
3.1 currently can't pass boot animation (-05 china version of Moto Z)
4. is latest official twrp OK for flashing this image?

Thank you for your advice, I tried Havoc but the battery life was not ideal for me but it is still a great option. You need to use twrp-3.3.1-0 but I'm not sure if the official version works in the CN version. Already installed does not take more than 3 minutes to boot. Try to erase Data and flash Magisk.
11th February 2020, 04:57 PM |#4  
Senior Member
Thanks Meter: 255
 
More
Quote:
Originally Posted by mosfet321

Thank you for your advice, I tried Havoc but the battery life was not ideal for me but it is still a great option. You need to use twrp-3.3.1-0 but I'm not sure if the official version works in the CN version. Already installed does not take more than 3 minutes to boot. Try to erase Data and flash Magisk.

Yeah, official 331 works just fine.
The case is it's 2 sim phone and aosp on this phone even has no sim up.
What do you mean by erase data? - format or factory reset or wipe?
By the way, which partitions do you backup in twrp for successful full restore?
11th February 2020, 05:56 PM |#5  
OP Member
Flag Aguascalientes, Mex.
Thanks Meter: 32
 
More
Quote:
Originally Posted by dimdimdim

Yeah, official 331 works just fine.
The case is it's 2 sim phone and aosp on this phone even has no sim up.
What do you mean by erase data? - format or factory reset or wipe?
By the way, which partitions do you backup in twrp for successful full restore?


I mean Wipe data partition where you have to write "yes" to wipe data. I had a similar problem when I started trying GSI everything was solved when I did a full wipe of System, Data, Cache then reboot to TWRP and install Lineage 16 afther that reboot to system and after full boot again TWRP and start to flash gsi, never had problems again when I want to try a GSI image I just do wipe cache and system and that's it


I do not make any backup I only make a backup copy of google that saves my contacts, photos, Wi-Fi networks, etc. and does not wipe data partition

Remember permissive and fixzygote are not needed for GSI builds made after 25th September
The Following User Says Thank You to mosfet321 For This Useful Post: [ View ] Gift mosfet321 Ad-Free
11th February 2020, 08:07 PM |#6  
Senior Member
Thanks Meter: 255
 
More
Quote:
Originally Posted by mosfet321

I mean Wipe data partition where you have to write "yes" to wipe data. I had a similar problem when I started trying GSI everything was solved when I did a full wipe of System, Data, Cache then reboot to TWRP and install Lineage 16 afther that reboot to system and after full boot again TWRP and start to flash gsi, never had problems again when I want to try a GSI image I just do wipe cache and system and that's it


I do not make any backup I only make a backup copy of google that saves my contacts, photos, Wi-Fi networks, etc. and does not wipe data partition

Remember permissive and fixzygote are not needed for GSI builds made after 25th September

Will try... Later
11th February 2020, 08:31 PM |#7  
Member
Thanks Meter: 14
 
More
I don't know what I'm doing wrong but I can't damn install it
12th February 2020, 12:32 AM |#8  
OP Member
Flag Aguascalientes, Mex.
Thanks Meter: 32
 
More
Quote:
Originally Posted by piotriix

I don't know what I'm doing wrong but I can't damn install it


Give us more information to help you. What is the error that shows you or where are you stopped in the process?
12th February 2020, 10:23 AM |#9  
Member
Thanks Meter: 14
 
More
There is no mistake.
The installation ends with the boot image evolution and nothing further happens.
I wait about 20 minutes
I even did a clean LineageOS installation and it did nothing.

---------- Post added at 10:23 AM ---------- Previous post was at 09:55 AM ----------

Quote:
Originally Posted by mosfet321

2. Unzip the file to extract the system image and copy it inside your Moto Z

winrar ? 7z?
12th February 2020, 12:33 PM |#10  
Senior Member
Thanks Meter: 255
 
More
Quote:
Originally Posted by piotriix

There is no mistake.
The installation ends with the boot image evolution and nothing further happens.
I wait about 20 minutes
I even did a clean LineageOS installation and it did nothing.

---------- Post added at 10:23 AM ---------- Previous post was at 09:55 AM ----------


winrar ? 7z?

winrar work pretty ok
check the consequence above by author with format via "yes" - BE SURE TO BACKUP INTERNAL STORAGE BEFORE AS IT CLEANS IT OUT.
I have the same problem as you, only can get a life long boot animation. even though aosp 210 boots up (with no ril unfortunately).
but I have not tried to do it with yes-format yet. so, if you are up to it now, would be great to know if you succeeded.
which device do you own? mine is -05 chineese 2 sim
12th February 2020, 04:03 PM |#11  
Junior Member
Flag Brasília
Thanks Meter: 3
 
More
Quote:
Originally Posted by piotriix

There is no mistake.
The installation ends with the boot image evolution and nothing further happens.
I wait about 20 minutes
I even did a clean LineageOS installation and it did nothing.

---------- Post added at 10:23 AM ---------- Previous post was at 09:55 AM ----------


winrar ? 7z?

Into the TWRP, folow these steps:

1- Go Wipe - Format Data (DON'T BOOT the System Yet)
2- Go Reboot - Recovery
3- Now you flash the System img. Be patient and wait the process. It can take 3-5 minutes, maybe more. (DON'T BOOT the System Yet)
4- Go Reboot - Recovery
5- Now go Wipe - Format Data - Boot Rom
The Following 2 Users Say Thank You to Blackigor For This Useful Post: [ View ] Gift Blackigor Ad-Free
Post Reply Subscribe to Thread

Tags
aosp, griffin, gsi, pixel, treble

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes