FORUMS
Remove All Ads from XDA

[ROM][LineageOS][16.0][UNOFFICIAL][Nexus10] -> 20191112

3,670 posts
Thanks Meter: 10,360
 
By followmsi, XDA Ad-Free Senior Member on 16th February 2017, 06:34 PM
Post Reply Email Thread
10th October 2019, 12:24 AM |#1211  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by HAK

Somehow on my N10 the hardwarecomposer HWC started working again and later even the wallpaper did something (although I don't know if I selected this one). It came back after (re)installing v2.0-2399-ci-alpha of the Lawnchair v2 launcher (apkmirror), which I am using for some time. At first I was a bit wary if the icons would stay, but it's already one week ago since I did the upgrade, and they are still there, also in the app drawer. I have attached a photo. Can it be true?

I'll be honest, i didn't think this would solve the issue but I gave it a try and boom icons showing up although my wallpapers still don't work. Still, I cannot thank you enough for discovering and sharing this weird solution to this weird problem. I can also confirm sometimes, some of the icons take time to show up after a restart but they work flawlessly if you download icon packs from Lawnchair Settings (I used Pixel Pie Icon Pack).
The Following User Says Thank You to Egolino For This Useful Post: [ View ] Gift Egolino Ad-Free
15th October 2019, 09:57 PM |#1212  
Member
Thanks Meter: 21
 
More
I may try this solution.
Right now when I reboot the Nexus 10, I go to the "home settings", then go to "Change Icon Shape", then I change the icon shape to something different, and they return for that session.
When you reboot, you have to set them to a different shape (like circle, square, squircle, teardrop).

Quote:
Originally Posted by Egolino

I'll be honest, i didn't think this would solve the issue but I gave it a try and boom icons showing up although my wallpapers still don't work. Still, I cannot thank you enough for discovering and sharing this weird solution to this weird problem. I can also confirm sometimes, some of the icons take time to show up after a restart but they work flawlessly if you download icon packs from Lawnchair Settings (I used Pixel Pie Icon Pack).

16th October 2019, 01:11 PM |#1213  
OP Senior Member
Thanks Meter: 10,360
 
More
Quote:
Originally Posted by HAK

Somehow on my N10 the hardwarecomposer HWC started working again and later even the wallpaper did something (although I don't know if I selected this one). It came back after (re)installing v2.0-2399-ci-alpha of the Lawnchair v2 launcher (apkmirror), which I am using for some time. At first I was a bit wary if the icons would stay, but it's already one week ago since I did the upgrade, and they are still there, also in the app drawer. I have attached a photo. Can it be true?

Thanks for reporting !

Not sure if different launcher will solve the root cause .. it may just "bypass" the problem.

Actually I have started with Android 10 development already.. here it looks different too.
It seems there is no need to "hack" framework/base anymore to get proper navigation bar .. not checked for icons yet.

Still too many other problems .. not sure when the first Android 10 build is ready for "public" testing.

Cheers
The Following 6 Users Say Thank You to followmsi For This Useful Post: [ View ] Gift followmsi Ad-Free
17th October 2019, 10:11 AM |#1214  
OP Senior Member
Thanks Meter: 10,360
 
More
Lineage-16.0 - October 2019

lineage-16.0-20191017-UNOFFICIAL-manta.zip

Changes:
- Google security updates -> October 2019
- Latest LineageOS changes

Sources:
https://github.com/followmsi/manifes...a-lineage-16.0

Tested with latest Magisk 20.0.
If Safety.net check does not work just enable/disable "Magisk Hide" in Magisk settings menu.

For the System and Cache repartitioning / Opengapps: Error 70 topic pls have a look on the first page.

Enjoy
The Following 10 Users Say Thank You to followmsi For This Useful Post: [ View ] Gift followmsi Ad-Free
21st October 2019, 06:09 PM |#1215  
Junior Member
Thanks Meter: 1
 
More
As a long time LineageOS user on my Manta, I'd like to say a big thank you to all those here who have help extend the life of my now quite ancient device!

I recently attempted an upgrade from LOS15.1 (20190310) to LOS16.0 (20191017), which proved to be very painful but I got there in the end by following this process:

- Repartioned memory using "lanchon-repit-09180102-cache=max+wipe-system=1228M-manta.zip"
- Installed TWRP 3.3.1.0 but couldn't find a combination of partition wiping that resulted in a successful ROM install from Recovery (bootloop to Recovery).
- So then followed instructions (https://wiki.lineageos.org/devices/manta/install) for a new ADB sideloaded LOS16.0 [20191017] + OpenGapps9.0 PICO [20191006] + Magisk v19.4 install.
- Success!

However, once I started to play around inside the new LOS I noticed the icon image problem and then discovered that one of the key apps I use on this device didn't work correctly.

The BBC iPlayer app [v4.81.1.1] will play audio but no video. The issue is also described by another user here: https://forum.xda-developers.com/nex...creen-t3876964

Once I'd reverted back to LOS15.1 [20190310] + OpenGapps8.1 PICO [20190313] + Magisk v19.4, the app worked correctly.

Any idea what might be going wrong here please?

P.S. I understand the need to save space on the ROM servers but it's disappointing to see that all the LOS15.1 ROMs for Manta have been deleted whilst this new package is at such an early stage and still suffering from issues like this.
25th October 2019, 02:02 AM |#1216  
greg285's Avatar
Senior Member
Thanks Meter: 73
 
More
Hi,

First of all thanks for giving this device a second life
I was using Resurrection remix for a long time on my old nexus10 and all was working ok ...recently I saw that the tablet and apps were getting slower, so I decided today to check for an updated version.
Looks like RR is not active anymore on this device so I checked for a replacement.

Wanted to flash the latest rom of this rom, got error 3004, saw that this is due to TWRP ...of course my TWRP was quite old ...downloaded the latest version for the manta device ...booted in recovery flashed the image as recovery partition and now my tablet is blocked on the screen with the little android bot complaining...

No way to get back into recovery mode...is there anything i can do/flash to be able to get my recovery back ?
I'm running macos on a macbook pro, would be grateful if any mac tools are available to flash whatever recovery to get the tablet back to live and get this rom installed.

Thanks
Greg
25th October 2019, 05:10 AM |#1217  
Senior Member
Thanks Meter: 728
 
More
Quote:
Originally Posted by greg285

Hi,

First of all thanks for giving this device a second life
I was using Resurrection remix for a long time on my old nexus10 and all was working ok ...recently I saw that the tablet and apps were getting slower, so I decided today to check for an updated version.
Looks like RR is not active anymore on this device so I checked for a replacement.

Wanted to flash the latest rom of this rom, got error 3004, saw that this is due to TWRP ...of course my TWRP was quite old ...downloaded the latest version for the manta device ...booted in recovery flashed the image as recovery partition and now my tablet is blocked on the screen with the little android bot complaining...

No way to get back into recovery mode...is there anything i can do/flash to be able to get my recovery back ?
I'm running macos on a macbook pro, would be grateful if any mac tools are available to flash whatever recovery to get the tablet back to live and get this rom installed.

Thanks
Greg

Using mac Terminal and fastboot would be the easiest way.
Some setup required.

Download the newest TWRP image.
(The .img file. Not the img.tar file.
The .tar files are to be used with odin.)

TWRP for manta
TeamWin-Downloads twrp.me - Link

Download platform tools (select for Mac)
SDK Platform Tools developer.android - Link

How to boot into fastboot (bootloader) mode.
Flashing Devices source.android - Link

macOS is based on BSD (darwin kernel). The default terminal is bash.

Setting it up on macOS is OT for this thread but, to get you back up and running.

Download twrp-3.3.1-0-manta.img
Download and unzip platform-tools_r29.0.4-darwin.zip, you will now have a directory (folder) in Downloads called platform-tools
Boot manta into fastboot (bootloader) mode and connect to computer
Open Terminal app and type
Code:
cd ~/Downloads
platform-tools/fastboot erase recovery
platform-tools/fastboot reboot bootloader
platform-tools/fastboot flash recovery twrp-3.3.1-0-manta.img
Then use the volume keys to switch to Recovery Mode and press the power button to select.
The erase and reboot commands might not be needed in your case.

PM me if you need more help or configuring platform-tools fully on your mac.

Cheers.
The Following 2 Users Say Thank You to ipdev For This Useful Post: [ View ] Gift ipdev Ad-Free
25th October 2019, 09:12 AM |#1218  
greg285's Avatar
Senior Member
Thanks Meter: 73
 
More
Quote:
Originally Posted by ipdev

Using mac Terminal and fastboot would be the easiest way.
Cheers.

This is why I love this forum !
Thanks a lot for the clear instructions ...all good now ...got access again and TWRP 3.3.1.0 is installed !
Let's now flash this rom !
The Following User Says Thank You to greg285 For This Useful Post: [ View ] Gift greg285 Ad-Free
29th October 2019, 12:27 AM |#1219  
Senior Member
Thanks Meter: 51
 
More
Still using this daily thanks
The Following 2 Users Say Thank You to mazsuper For This Useful Post: [ View ] Gift mazsuper Ad-Free
7th November 2019, 03:40 PM |#1220  
Junior Member
Thanks Meter: 3
 
More
I want to report some results of testing this rom. (lineage-16.0-20191017-UNOFFICIAL-manta)

1.
NFC should be switched off by default in rom, it's only one little entry ! (/etc/libnfc-nci.conf)
Drains battery really much, driver HAL Error catlog:
libnfc_nci: [ERROR:gki_ulinux.cc(98)] gki_task task_id=0 terminating

2. Trebuchet Launcher error, crashed by loading table, workaround is to change manually the icon style in settings
Solution-> apply to the rom the nova launcher, it's fully bugfree and works fine in this rom.

3. After wiping all data, flashing the ROM zip and wiping it again, system bootet fine. But after installing the latest Magisk 20.1, I got a reproducible bootloop. With Super Su flashing in twrp all works fine. So only info for all others.

at all, I've tested really a lot of android versions and their Roms. This one is definately the fastest for the Nexus 10 (my meaning /opinion)
The Following 3 Users Say Thank You to marndra For This Useful Post: [ View ] Gift marndra Ad-Free
12th November 2019, 02:06 PM |#1221  
OP Senior Member
Thanks Meter: 10,360
 
More
Quote:
Originally Posted by scallywagger

As a long time LineageOS user on my Manta, I'd like to say a big thank you to all those here who have help extend the life of my now quite ancient device!

I recently attempted an upgrade from LOS15.1 (20190310) to LOS16.0 (20191017), which proved to be very painful but I got there in the end by following this process:

- Repartioned memory using "lanchon-repit-09180102-cache=max+wipe-system=1228M-manta.zip"
- Installed TWRP 3.3.1.0 but couldn't find a combination of partition wiping that resulted in a successful ROM install from Recovery (bootloop to Recovery).
- So then followed instructions (https://wiki.lineageos.org/devices/manta/install) for a new ADB sideloaded LOS16.0 [20191017] + OpenGapps9.0 PICO [20191006] + Magisk v19.4 install.
- Success!

However, once I started to play around inside the new LOS I noticed the icon image problem and then discovered that one of the key apps I use on this device didn't work correctly.

The BBC iPlayer app [v4.81.1.1] will play audio but no video. The issue is also described by another user here: https://forum.xda-developers.com/nex...creen-t3876964

Once I'd reverted back to LOS15.1 [20190310] + OpenGapps8.1 PICO [20190313] + Magisk v19.4, the app worked correctly.

Any idea what might be going wrong here please?

P.S. I understand the need to save space on the ROM servers but it's disappointing to see that all the LOS15.1 ROMs for Manta have been deleted whilst this new package is at such an early stage and still suffering from issues like this.

Did you read first page before writing this text ?
It seeems not ..

You will find download links to my last 14.1 and 15.1 builds .. as well links to new thread with fresh 14.1 and 15.1 builds.

HWC is partly broken on Pie .. and some apps will have problems - your favourite app seems to have the same problem.

Cheers
Post Reply Subscribe to Thread

Tags
lineage, manta, nexus 10, oreo, pie

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes