FORUMS
Remove All Ads from XDA

[UNOFFICIAL][ROM] Android 5.1.1 for mako v0.6 [14.05.2015]

7,705 posts
Thanks Meter: 15,783
 
By eagleeyetom, Developer Committee Lead / XDA Portal Team / Senior Moderator on 10th March 2015, 11:49 AM
Post Reply Email Thread
I didn't initially plan to release more than one version of this ROM, so yay, time to re-write the OP


Here's an unofficial Android 5.1 for the Google Nexus 4. No significant modifications, just a plain, good ol' AOSP, which becomes more usable every release. Before we proceed. At this moment, Google has not released binary files for Android 5.1, so I'm using the 5.0.1 ones.

Code:
package aosp;

import disclaimer;

public class AOSP extends Disclaimer {

    /**
     * Your warranty is now likely void.
     *
     * I am not responsible for bricked devices, dead SD cards,
     * spontaneous combustion, or any other host of cosmic penalties
     * which may befall you, your family, animals or your phone.
     *
     */
    public AOSPDisclaimer(){
        warranty.set(0);
    }

}
Installation
  • Download the ROM from AndroidFileHost or Mega (mirrors in the second post)
  • Copy the ROM to your SD Card or launch the adb sideload in the recovery
  • Install the ROM
  • Install GAPPs (these are recommended)
  • Install SuperSU
  • Install Xposed Framework if you like
  • Wipe the data if you're coming from other ROMs
  • Reboot

Changelog in post #2

Enjoy!
The Following 72 Users Say Thank You to eagleeyetom For This Useful Post: [ View ] Gift eagleeyetom Ad-Free
 
 
10th March 2015, 01:09 PM |#2  
eagleeyetom's Avatar
OP Developer Committee Lead / XDA Portal Team / Senior Moderator
Flag Gdańsk
Thanks Meter: 15,783
 
Donate to Me
More
Changelog

10.03.2015 - v0.1 (mega mirror)
  • Initial release
  • Pure AOSP without any modifications

14.03.2015 - v0.2 (mega mirror)
  • Fixed the Network Location bug by adding the according overlay in XML
  • Advanced Reboot (Thanks @craigacgomez)
  • Changed the wallpaper
  • Recovery will not be overwritten
  • Added more sounds (ringtones and alerts)

26.03.2015 - v0.3/0.3b
  • Android updated to revision 5.1.0_r3

16.04.2015 - v0.4 (mega mirror)
  • Binaries updated to official release
  • Android 5.1.0_r5

22.04.2015 v0.5
  • Android 5.1.1
Kernel source will be available here once Google posts it.
The Following 6 Users Say Thank You to eagleeyetom For This Useful Post: [ View ] Gift eagleeyetom Ad-Free
10th March 2015, 01:09 PM |#3  
Senior Member
Thanks Meter: 107
 
More
yeah baby! this is wonderful!!! thx for your hard work!!! i will give it a try today later when i find the time as i am curious if xposed is working on 5.1. the 5 blobs should not be a problem as 5.1 is a small update.

one question. did you find any bugs that might be a deal breaker for some people?
The Following User Says Thank You to ttheodorou For This Useful Post: [ View ] Gift ttheodorou Ad-Free
10th March 2015, 01:10 PM |#4  
Junior Member
Thanks Meter: 3
 
More
Installed
As far as i used it so far no bugs! great work! Very smooth!
Could it be possible to post a modified settings apk with ambient display?
I know it's not fully functional on the Nexus 4 but however i miss that notification-thing
The Following 2 Users Say Thank You to mathn69 For This Useful Post: [ View ] Gift mathn69 Ad-Free
10th March 2015, 01:27 PM |#5  
Senior Member
Flag Gujrat
Thanks Meter: 62
 
More
I appreciate your hardwork sir and want to let you know that I just clean flashed your ROM along with latest PA Gapps and SuperSU v2.46.

ROM flashed successfully but Gapps failed.

TWRP screen shows this package of Gapps is only for 5.0.x and cannot be used with 5.1.

It would really be great if you very kindly take out some more time to keep the good work up.

I'll try to install apk files of Play Svcs and Play Store etc and will see if it works.
10th March 2015, 01:32 PM |#6  
eagleeyetom's Avatar
OP Developer Committee Lead / XDA Portal Team / Senior Moderator
Flag Gdańsk
Thanks Meter: 15,783
 
Donate to Me
More
As far as I know, 5.1 gapps are not available yet. I will try to create a separate package soon.
The Following 6 Users Say Thank You to eagleeyetom For This Useful Post: [ View ] Gift eagleeyetom Ad-Free
10th March 2015, 02:04 PM |#7  
Rick Roll's Avatar
Senior Member
Flag Rio de Janeiro
Thanks Meter: 776
 
Donate to Me
More
Quote:
Originally Posted by eagleeyetom

As far as I know, 5.1 gapps are not available yet. I will try to create a separate package soon.

PA Gapps works if you change "req_android_version" to 5.1 on installer.data
The Following 2 Users Say Thank You to Rick Roll For This Useful Post: [ View ] Gift Rick Roll Ad-Free
10th March 2015, 02:08 PM |#8  
eagleeyetom's Avatar
OP Developer Committee Lead / XDA Portal Team / Senior Moderator
Flag Gdańsk
Thanks Meter: 15,783
 
Donate to Me
More
Quote:
Originally Posted by Rick Roll

PA Gapps works if you change "req_android_version" to 5.1 on installer.data

Yes, this method works too. Google released new apps though which can be used with 5.1
The Following 2 Users Say Thank You to eagleeyetom For This Useful Post: [ View ] Gift eagleeyetom Ad-Free
10th March 2015, 02:09 PM |#9  
Junior Member
Thanks Meter: 3
 
More
GPS
Noticed that my GPS isn't working. It just shows the icon in the statusbar and stays there forever (Tested with Google Maps & Android Device Manager)
10th March 2015, 02:12 PM |#10  
Senior Member
Flag Gujrat
Thanks Meter: 62
 
More
May be it's not the best time to run 5.1 on mako, at least for me.

Using Nexus Root Toolkit, I have installed apks of Google Play Services, Play Store, Gmail, Google Now Launcher and Google Search but now every time I click on Google Settings or Play Store (even in System Settings --> Accounts--> Add Account--> Google) a pop up persistently appears and says "Unfortunately, Google Play Services has stopped" .

Looks like old apks cannot make friends with new OS version.
10th March 2015, 02:16 PM |#11  
Junior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by MusadiqManas

May be it's not the best time to run 5.1 on mako, at least for me.

Using Nexus Root Toolkit, I have installed apks of Google Play Services, Play Store, Gmail, Google Now Launcher and Google Search but now every time I click on Google Settings or Play Store (even in System Settings --> Accounts--> Add Account--> Google) a pop up persistently appears and says "Unfortunately, Google Play Services has stopped" .

Looks like old apks cannot make friends with new OS version.


Try updating your google play services with Aptoide. The newest version from there worked very well for me.
The Following User Says Thank You to mathn69 For This Useful Post: [ View ] Gift mathn69 Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes