FORUMS
Remove All Ads from XDA
Honor 7x
Win an Honor 7X!

Resolved - Nexus 4 Video playback issue: Android System Webview

382 posts
Thanks Meter: 89
 
By redandwhitearmy, Senior Member on 12th August 2015, 09:58 PM
Post Reply Email Thread
I am adding a new thread because this is a very peculiar issue and i still feel something is really wrong in my N4 settings but i have seen some similar or even worse cases with some old gen nexus devices and i have tried some workarounds which don't seem to work so far.

Here is the problem description:

I cant play any videos in Facebook or Twitter official apps.
Facebook says "Error occurred while trying to play this video"
Twitter end up with a black screen and shows nothing( some 1 out of 10 times it acts as audio only with black screen again)
Strange thing is I cant play fb or twitter videos even in chrome browser in my mobile.

Youtube or other players work fine (Vimeo etc.)
Near about everything else works. Youtube app or browser playback is fine with no issues. Mx player runs fine too.

Some background about my device settings:

Android 5.1.1 stock, not rooted
Its using AwesomePlayer instead of NuPlayer in dev options.

There was one time when i was not able to play any video in my device because nuplayer was selected once by mistake and changing to AwesomePlayer helped.
But after that issue around 6 months back, i have done complete factory reset and everything was working fine for 3-4 months, i started getting this issue in last two months or so.

I read some similar issues in Nexus 7 2013 with Android Lollipop but not exactly this.

Is anyone else is facing or had ever faced anything like this?
Any suggestions on how to get rid of this? Don't want to factory reset again.

I have tried all usual things like clearing cache, reinstalling those apps but i think this issue is something else as i cant even play those videos in browser too.
Again i enabled the dev options last week and thought changing to NuPlayer might help but that also didnt help. All others settings are default settings.

PS: Intentionally not posting as Q&A as i believe some other older gen nexus devices are facing similar issues with new updates so this might fit well as discussion thread.

-----------------------------------------------------------------------------
Note its solved: Reason was the older version of Android System Webview app. Updated it and this issue went away. Hope this helps others facing similar issue.
 
 
13th August 2015, 04:46 AM |#2  
jimyiak's Avatar
Senior Member
Flag Aigio
Thanks Meter: 103
 
More
I think it's something about google webview apk...do you have this app??

sent by nexy 4
13th August 2015, 06:20 PM |#3  
ariesgodofwar's Avatar
Senior Member
Flag Fenton
Thanks Meter: 187
 
More
Quote:
Originally Posted by redandwhitearmy

I am adding a new thread because this is a very peculiar issue and i still feel something is really wrong in my N4 settings but i have seen some similar or even worse cases with some old gen nexus devices and i have tried some workarounds which don't seem to work so far.

Here is the problem description:

I cant play any videos in Facebook or Twitter official apps.
Facebook says "Error occurred while trying to play this video"
Twitter end up with a black screen and shows nothing( some 1 out of 10 times it acts as audio only with black screen again)
Strange thing is I cant play fb or twitter videos even in chrome browser in my mobile.

Youtube or other players work fine (Vimeo etc.)
Near about everything else works. Youtube app or browser playback is fine with no issues. Mx player runs fine too.

Some background about my device settings:

Android 5.1.1 stock, not rooted
Its using AwesomePlayer instead of NuPlayer in dev options.

There was one time when i was not able to play any video in my device because nuplayer was selected once by mistake and changing to AwesomePlayer helped.
But after that issue around 6 months back, i have done complete factory reset and everything was working fine for 3-4 months, i started getting this issue in last two months or so.

I read some similar issues in Nexus 7 2013 with Android Lollipop but not exactly this.

Is anyone else is facing or had ever faced anything like this?
Any suggestions on how to get rid of this? Don't want to factory reset again.

I have tried all usual things like clearing cache, reinstalling those apps but i think this issue is something else as i cant even play those videos in browser too.
Again i enabled the dev options last week and thought changing to NuPlayer might help but that also didnt help. All others settings are default settings.

PS: Intentionally not posting as Q&A as i believe some other older gen nexus devices are facing similar issues with new updates so this might fit well as discussion thread.

What Android System Webview APK do you have installed? (This is essentially the applet which allows 3rd Party apps to access the web). The latest version, 45.0.2454.37 came out yesterday. While I have had this same issue in the past with older Webview versions, yesterdays seems to be working just fine. Go to the Play Store and update to the latest version and see if that resolves.
13th August 2015, 06:49 PM |#4  
OP Senior Member
Flag New Delhi
Thanks Meter: 89
 
More
Yes i have this, In my device it says the version is 44.0.2403.90 and it says its up to date. So maybe the update is not out yet for my region. It makes sense that this is responsible for it as i have auto update on and some new version might be causing this.

What do you guys suggest should i uninstall/reinstall this. Or maybe get an older version?

Thanks for your help.
13th August 2015, 07:38 PM |#5  
KcLKcL's Avatar
Senior Member
Flag Jakarta
Thanks Meter: 630
 
Donate to Me
More
Btw, Facebook video playback issue affects other device too, not only the Nexus 4. It happened on my aunt's phone.
Plus it's not a Lollipop issue, my aunt's phone is still on 4.2.2, and I had my Nexus 4 at 4.4.4.
13th August 2015, 10:06 PM |#6  
ariesgodofwar's Avatar
Senior Member
Flag Fenton
Thanks Meter: 187
 
More
Quote:
Originally Posted by redandwhitearmy

Yes i have this, In my device it says the version is 44.0.2403.90 and it says its up to date. So maybe the update is not out yet for my region. It makes sense that this is responsible for it as i have auto update on and some new version might be causing this.

What do you guys suggest should i uninstall/reinstall this. Or maybe get an older version?

Thanks for your help.

Go to http://www.apkmirror.com/apk/google-...-apk-download/ and you can download the latest Android System Webview module and not have to wait for it to become available to you in the Play Store.
The Following User Says Thank You to ariesgodofwar For This Useful Post: [ View ] Gift ariesgodofwar Ad-Free
13th August 2015, 11:33 PM |#7  
OP Senior Member
Flag New Delhi
Thanks Meter: 89
 
More
Quote:
Originally Posted by ariesgodofwar

Go to http://www.apkmirror.com/apk/google-...-apk-download/ and you can download the latest Android System Webview module and not have to wait for it to become available to you in the Play Store.

Boom! it worked. Thanks a ton!
13th August 2015, 11:40 PM |#8  
OP Senior Member
Flag New Delhi
Thanks Meter: 89
 
More
Quote:
Originally Posted by KcLKcL

Btw, Facebook video playback issue affects other device too, not only the Nexus 4. It happened on my aunt's phone.
Plus it's not a Lollipop issue, my aunt's phone is still on 4.2.2, and I had my Nexus 4 at 4.4.4.

Yes i have tweaked the subject and hashtags accordingly when i know the exact problem.
20th November 2017, 12:55 AM |#9  
Junior Member
Thanks Meter: 1
 
More
A solution for another possible N4 video playback issue
I came across this thread searching for a solution for for my video playback issue, with my N4 being unable to play videos occasionally.
I eventually narrowed down the problem to firefox, and setting
Code:
media.android-media.codec.enabled=false
in
Code:
about:config
finally solved the issue I had for years.
If anyone else finds this information helpful, send me a PM please
The Following User Says Thank You to katzelad For This Useful Post: [ View ] Gift katzelad Ad-Free
Post Reply Subscribe to Thread

Tags
android system webview, lollipop 5.1.1, nexus 4, video playback

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes