FORUMS
Remove All Ads from XDA

Wifi network connectivity issues and a possible fix

47 posts
Thanks Meter: 131
 
By bganley, Member on 30th December 2012, 01:55 AM
Post Reply Email Thread
17th June 2013, 01:06 AM |#501  
namurt's Avatar
Senior Member
Flag Philadelphia
Thanks Meter: 283
 
More
Quote:
Originally Posted by andy o

Does anyone know how to set a static ARP on DD-WRT? I just installed it on a Netgear WNDR4000, but all the references to static ARP I googled were regarding Wake-on-LAN. Much appreciated in advance.

here's how to do it:

1.) find the mac address of your phone (this can be found under advanced menu option within the system -> wifi settings (or alternatively under about phone)
2.) login to your dd-wrt control panel
3.) go to services
4.) under static leases click add and then enter the mac address of your phone, pick any host name and ip address you'd like, and leave lease time blank
5.) scroll down and click apply settings and then save
6.) go to administration
7.) go to commands
8.) enter the following:

arp -i br0 -s xxx.xxx.xxx.xxx xx:xx:xx:xx:xx:xx

obviously, you'll need to use the static ip you set in step 4 and the second string will be your phone's mac address

9.) scroll down and click save startup
10.) reboot your router
11.) reboot your phone
12.) you're done!

if you want to be sure the settings took, log back into your router control panel and go to administration -> commands and type "arp -a" minus the quotes, then click run commands. this will give you a list of all active clients in your arp table, and you should see your phone listed.


note: the only item within this list that i'm unsure about is whether or not the host name matters. i set my host name on my router control panel as "nexus4" whereas by default your phone will have a hostname of android-<serial-number>. just to be sure there were no issues, i used trickster to manually set my host name on my phone to nexus4. ymmv.
The Following 3 Users Say Thank You to namurt For This Useful Post: [ View ] Gift namurt Ad-Free
 
 
17th June 2013, 05:42 PM |#502  
Senior Member
Thanks Meter: 151
 
More
Quote:
Originally Posted by namurt

here's how to do it:

Thanks a lot, unfortunately setting a static ARP doesn't fix the problem here, I still can't ping the phone with the screen off, and notifications on WiFi are still delayed. I checked with arp -a and the phone was indeed in the list, with the others. I had already set static IPs for all my devices, and all of them are showing, the only difference is that the Nexus 4 has "PERM" in its line.

I haven't changed anything from the wifi file referenced in the first post, and using CM 10.1 and Faux's 4.2.2. stock kernel. Not sure if that would do anything.
17th June 2013, 06:54 PM |#503  
Salty Wagyu's Avatar
Senior Member
Flag England
Thanks Meter: 138
 
More
Quote:
Originally Posted by Fire-Dragon-DoL

I may have found a temporary fix for this which doesn't involve rooting or static ARP table.
The basic problem is that I have a Tasker task that when it loses my home wireless network connection, it does some things (which involves even turning on the screen and showing a scene). So basically this "blocks" from deep sleep AND waste battery because it turns on the screen, yay.

I've disabled the "optimize Wi-Fi" option (under Wifi => advanced), this seems to stop deep sleep or, in any case, solve the problem.
I also noticed that the issue happens earlier with 5Ghz network and a bit later with 2.4Ghz.

This should also allow people to keep using OTA. Hope this helps you guys.
If anyone can confirm, let me know. Also tell us the consequences, I have no idea how much battery will drain.

Didn't work.
17th June 2013, 10:22 PM |#504  
namurt's Avatar
Senior Member
Flag Philadelphia
Thanks Meter: 283
 
More
Quote:
Originally Posted by andy o

Thanks a lot, unfortunately setting a static ARP doesn't fix the problem here, I still can't ping the phone with the screen off, and notifications on WiFi are still delayed. I checked with arp -a and the phone was indeed in the list, with the others. I had already set static IPs for all my devices, and all of them are showing, the only difference is that the Nexus 4 has "PERM" in its line.

I haven't changed anything from the wifi file referenced in the first post, and using CM 10.1 and Faux's 4.2.2. stock kernel. Not sure if that would do anything.

forgive me for not having the time to do the requisite research, but do either cm 10.1 or faux's kernel have any known wifi issues? i'm running aospa and franco, so i simply don't know if they do. i believe faux's enhanced stock kernel has a custom "hsic fix" but i don't recall if he's touched anything in the way of wifi in his stock kernel.

following the steps i outlined, i have no problems with aospa and franco. i'm running the latest franco nightly (r155) and i know franco didn't touch wifi. it's as stock as stock can be.
17th June 2013, 10:49 PM |#505  
Senior Member
Thanks Meter: 151
 
More
Quote:
Originally Posted by namurt

forgive me for not having the time to do the requisite research, but do either cm 10.1 or faux's kernel have any known wifi issues? i'm running aospa and franco, so i simply don't know if they do. i believe faux's enhanced stock kernel has a custom "hsic fix" but i don't recall if he's touched anything in the way of wifi in his stock kernel.

following the steps i outlined, i have no problems with aospa and franco. i'm running the latest franco nightly (r155) and i know franco didn't touch wifi. it's as stock as stock can be.

Yeah, I'm using enhanced stock 4.2.2. I reinstalled CM so with the CM kernel apparently notifications come immediately, though I have to do some more testing. I still can't ping the phone with the screen off though, can you? I get destination host unreachable.

Unfortunately I need one of faux's kernels more than I need this fix right now cause I use FauxSound to lower the mic gain. If you happen to know if Franco's has the required code for it (published in the Play Store FauxSound page), I'd be happy to know.

Thanks again.
17th June 2013, 11:13 PM |#506  
namurt's Avatar
Senior Member
Flag Philadelphia
Thanks Meter: 283
 
More
Quote:
Originally Posted by andy o

Yeah, I'm using enhanced stock 4.2.2. I reinstalled CM so with the CM kernel apparently notifications come immediately, though I have to do some more testing. I still can't ping the phone with the screen off though, can you? I get destination host unreachable.

Unfortunately I need one of faux's kernels more than I need this fix right now cause I use FauxSound to lower the mic gain. If you happen to know if Franco's has the required code for it (published in the Play Store FauxSound page), I'd be happy to know.

Thanks again.

i just tried pinging my phone with the screen off, and i also got host unreachable. i don't get it, though, because i've tested notifications alongside a verizon phone and the two deliver the same push notifications at virtually the same time. there is an ever-so-slight delay on my nexus 4, but i'm betting that's just the difference between t'mo's and verizon's networks. the verizon phone is a thunderbolt with the latest radio and a custom ics rom (liquid smooth).

i'm not so sure any of this quirkiness is going to be ultimately resolved until 4.3 drops. google damn well better have fixed these issues with the upcoming release!
24th June 2013, 06:46 PM |#507  
Member
Thanks Meter: 41
 
More
I really can't believe this. Just switched from iPhone 5 because i was sick of iOs, just to find myself stuck with a phone that won't receive any notification. Welcome to Android...

Read all this thread, rooted and tried the fix that DID NOT WORK for me.

I don't even have a comment for how Google is -not- handling this. His top smartphone can't really do the only thing they are designed for.

The only solution I found is to use Advanced Wifi Lock to keep the connection alive. That would be good if only it wasn't responsible for draining 60% of the battery overall...
24th June 2013, 08:07 PM |#508  
Senior Member
Long Island, NY
Thanks Meter: 252
 
More
Hmmmm. This problem was just brought to my attention as a potential cause of some issues I'm having receiving notifications from my Pebble watch. However, I've had the N4 since launch and am on WiFi for the majority of every day, and have never had any problems with delayed notifications from the stock GMail app. I wonder why? This seems like it's something that should affect all N4s across the board, no?
The Following User Says Thank You to nyijedi For This Useful Post: [ View ] Gift nyijedi Ad-Free
26th June 2013, 01:02 AM |#509  
lyall29's Avatar
Senior Member
Flag Arkadelphia, AR
Thanks Meter: 249
 
More
Quote:
Originally Posted by nyijedi

Hmmmm. This problem was just brought to my attention as a potential cause of some issues I'm having receiving notifications from my Pebble watch. However, I've had the N4 since launch and am on WiFi for the majority of every day, and have never had any problems with delayed notifications from the stock GMail app. I wonder why? This seems like it's something that should affect all N4s across the board, no?

I have had 3 nexus 4's (or nexi however you say it), the first 2 had no problems but my new one would not stay connected to WiFi. That is until I flashed this mod today! I am now connected at all times. Thank you bganley for this mod! I only flashed it today, but so far so good.

Sent from my Nexus 4 using xda premium
26th June 2013, 02:14 AM |#510  
Senior Member
Thanks Meter: 151
 
More
Quote:
Originally Posted by namurt

i just tried pinging my phone with the screen off, and i also got host unreachable. i don't get it, though, because i've tested notifications alongside a verizon phone and the two deliver the same push notifications at virtually the same time. there is an ever-so-slight delay on my nexus 4, but i'm betting that's just the difference between t'mo's and verizon's networks. the verizon phone is a thunderbolt with the latest radio and a custom ics rom (liquid smooth).

i'm not so sure any of this quirkiness is going to be ultimately resolved until 4.3 drops. google damn well better have fixed these issues with the upcoming release!

FWIW, the problem eventually showed up with the cm kernel as well.
4th July 2013, 07:59 AM |#511  
Member
Thanks Meter: 4
 
More
Experiencing the same thing over here ...
GCM messages are received with a delay of 10 seconds or so.

However, I perceive this behaviour only on 1 of my 2 AP's.
On the other one the messages are received instantaneously.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes