FORUMS
Remove All Ads from XDA

[Q] msm_hsic_host wakelock

113 posts
Thanks Meter: 12
 
By liput_81, Senior Member on 18th November 2012, 07:43 AM
Post Reply Email Thread
Does anyone know what causes msm_hsic_host wake lock?

I've left my phone idle overnight and it has had a lot of this wakelock showing in better battery stats

WiFi was left on if that is relevant

Can't really find any references to this wakelock via our friend Google

Thanks

[EDIT: it appears the wakelock is 'normal' for stock builds and is linked to the radio sending data. some custom kernels can reduce the wakelock]
The Following User Says Thank You to liput_81 For This Useful Post: [ View ] Gift liput_81 Ad-Free
18th November 2012, 12:13 PM |#2  
Senior Member
Thanks Meter: 1,542
 
Donate to Me
More
REGULATOR_SUPPLY("EXT_HUB_VDDIO", "msm_hsic_host")

http://forum.xda-developers.com/show...951704&page=11

didn't find much else on it.
18th November 2012, 12:32 PM |#3  
OP Senior Member
Thanks Meter: 12
 
More
Quote:
Originally Posted by ziddey

REGULATOR_SUPPLY("EXT_HUB_VDDIO", "msm_hsic_host")

http://forum.xda-developers.com/show...951704&page=11

didn't find much else on it.

I saw that thread, though it seems to not really answer the question from what I can tell
18th November 2012, 07:14 PM |#4  
Senior Member
Thanks Meter: 25
 
More
Probably won't help but I'm having this problem with my Optimus G as well. More likely a hardware/firmware problem?
18th November 2012, 07:37 PM |#5  
Senior Member
Thanks Meter: 116
 
More
hsic = high-speed inter-chip, perhaps some kind of transfer from the SoC to another chip(Perhaps for the modem?).

VDDIO might have something to do with voltage regulation of the bus itself?

Maybe try in airplane mode and see if it solves anything? Otherwise it probably requires an update from Qualcomm if it appears on both Neuxs 4 and Optimus G
The Following User Says Thank You to FISKER_Q For This Useful Post: [ View ] Gift FISKER_Q Ad-Free
18th November 2012, 07:40 PM |#6  
Junior Member
Thanks Meter: 0
 
More
I've been having the same problem as well. Battery is draining way too much due to this wakelock when it should be in deep sleep.
18th November 2012, 07:49 PM |#7  
Senior Member
Thanks Meter: 323
 
More
Getting the same issue here.
Attached Thumbnails
Click image for larger version

Name:	uploadfromtaptalk1353268154030.jpg
Views:	7425
Size:	61.1 KB
ID:	1492201  
The Following User Says Thank You to dwang For This Useful Post: [ View ] Gift dwang Ad-Free
19th November 2012, 12:20 AM |#8  
darkamikaze's Avatar
Senior Member
Flag Candyland
Thanks Meter: 174
 
More
kernel dev needs to shine some light on this
19th November 2012, 07:39 AM |#9  
OP Senior Member
Thanks Meter: 12
 
More
Quote:
Originally Posted by FISKER_Q

hsic = high-speed inter-chip, perhaps some kind of transfer from the SoC to another chip(Perhaps for the modem?).

VDDIO might have something to do with voltage regulation of the bus itself?

Maybe try in airplane mode and see if it solves anything? Otherwise it probably requires an update from Qualcomm if it appears on both Neuxs 4 and Optimus G

In air plane mode the wakelock dropped from 15% to 6.6% so I'd guess it is related to the modem in some way
The Following 2 Users Say Thank You to liput_81 For This Useful Post: [ View ] Gift liput_81 Ad-Free
19th November 2012, 01:15 PM |#10  
Senior Member
Thanks Meter: 19
 
More
little bump for this... seem to be getting same thing.

Around an hours worth of wakelock in a standard day..
20th November 2012, 04:51 AM |#11  
MXIIA's Avatar
Senior Member
Flag error
Thanks Meter: 9
 
More
I'm having the same issue with mine, 95 minutes of wake lock over a 10 hour period - using in BetterBatteryStats.
The Following User Says Thank You to MXIIA For This Useful Post: [ View ] Gift MXIIA Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes