Remove All Ads from XDA
Honor View 10

[Q] Nexus 4 with AOKP won't connect to Wifi, "WPS failed" error

7 posts
Thanks Meter: 0
By hashtagcats, Junior Member on 10th June 2014, 09:23 AM
Post Reply Email Thread
My Nexus 4 isn't connecting to wifi. More specifically, if I am connected to a remembered network, my phone does not automatically reconnect when I leave the range then come back into it.

Now, there are 2 wifi networks in the apartment and I've tried both. I actually just "forgot network" on the last remembered network on my phone because I was trying to connect to the better one.

Since I've done that, I am unable to connect to wifi at all, because the only way for me to connect to wifi before was to restart my phone and have it automatically connect to the remembered network.

Now that I don't have a remembered network, I cannot connect to anything, and my Wifi page on my phone will not show any wifi networks available and it won't even give the option to turn on wifi or to refresh the list. I have to reboot my phone, making sure the wifi is off first (using the toggle on the dropdown notification menu), then I can at least refresh the empty list. When I refresh the list, it gives me an error, "WPA failed. Retry in a few minutes."

I need this fixed. I live in a basement apartment and my cell signal is usually unavailable while I'm home.

I was running the AOKP 4.3 milestone when I started having the problem, then went back to stock, put on a 4.4 nightly ROM, had the same problem, then went back to the same 4.3 milestone. Unfortunately, I didn't leave my phone on stock 4.4 long enough to see if the problem persisted there.

Is there anything I can do at this point before going through the process of bringing my phone back to stock again?

11th June 2014, 05:51 AM |#2  
OP Junior Member
Thanks Meter: 0
Update: After restarting my phone some 20 or more times, I was eventually able to see the list of networks and put the password in for the new network. So I at least have wifi now because my phone automatically connects.

However, all the problems stated above are still the same. I lose connection and cannot automatically reconnect when I go out and back into range of the signal, and can only regain the connection when I restart my phone and it automatically connects to the one known network on reboot.

If there's any information or anyway to try to fix it, I'd love to know.

Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes