FORUMS

How to get your Nexus 4 sync working with Fitbit

331 posts
Thanks Meter: 49
 
By newtonfb, Senior Member on 8th September 2013, 01:06 PM
Post Reply Email Thread
28th September 2013, 02:23 PM |#21  
dimfish's Avatar
Senior Member
Saint-Petersburg
Thanks Meter: 388
 
More
Quote:
Originally Posted by Lucke

sweet, thanks. i've already got 2 usb dongles (work and home), but this will be great when traveling.

any idea how future updates will be handled once Fitbit pushes them out? will those updates screw up this version and take functionality away?

Actually it costs 2 min to patch app if you know how to patch and where
The Following User Says Thank You to dimfish For This Useful Post: [ View ] Gift dimfish Ad-Free
28th September 2013, 06:02 PM |#22  
snapper.fishes's Avatar
Senior Member
Flag Hong Kong
Thanks Meter: 302
 
More
Quote:
Originally Posted by newtonfb

You need to turn background sync off and have it only sync when you open the app

Sent from my GT-I9505G using xda app-developers app

And how does one do that? There doesn't seem to be a setting in the app that says background sync.
28th September 2013, 07:14 PM |#23  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by dimfish

I've successfully patched application to masquerade Nexus 4 as GT-I9505G!! So now you can revert your original build.prop
PS Tested on CM10.2 nightly

Working in CM 10.2 Nightly. I saw the official app update. Could be modified too?? Thank you very much.
28th September 2013, 10:04 PM |#24  
CaraMuuu's Avatar
Senior Member
Flag Granada / Kraków
Thanks Meter: 29
 
More
Quote:
Originally Posted by dimfish

Actually it costs 2 min to patch app if you know how to patch and where

Could you please patch the latest version, or else share the patch method?

Thanks a lot!
29th September 2013, 08:05 AM |#25  
dimfish's Avatar
Senior Member
Saint-Petersburg
Thanks Meter: 388
 
More
Quote:
Originally Posted by CaraMuuu

Could you please patch the latest version, or else share the patch method?

Thanks a lot!

I've all developer tools installed at work - so please wait till Monday...
The Following 2 Users Say Thank You to dimfish For This Useful Post: [ View ] Gift dimfish Ad-Free
30th September 2013, 08:04 AM |#26  
dimfish's Avatar
Senior Member
Saint-Petersburg
Thanks Meter: 388
 
More
Damn - they completely changed Bluetooth support checking....
However I spoofed it again
PS It should be working on all other Bluetooth 4.0 with LE devices (not only Nexus 4)
Attached Files
File Type: apk FitbitMobile-1.8N4.apk - [Click for QR Code] (6.56 MB, 2717 views)
The Following 28 Users Say Thank You to dimfish For This Useful Post: [ View ] Gift dimfish Ad-Free
30th September 2013, 09:22 PM |#27  
URPREY's Avatar
Senior Member
Flag Louisville, KY
Thanks Meter: 123
 
More
Quote:
Originally Posted by ryoniyk

Any reason you can think of why my phone would start the install process for the apk but not allow me to click the actual 'install' button?

I assume you are using some sort of screen filter/overlay (to adjust backlight). Turn that off and it will work.
2nd October 2013, 03:47 PM |#28  
Junior Member
Thanks Meter: 0
 
More
So it was working with my Nexus 4 until I plugged my fitbit into the charger. After that, the fitbit app can no longer sync with it. Any thoughts?

Edit: It is probably due to the 4.3 48 hour sync bug they mention on their website.
2nd October 2013, 08:37 PM |#29  
Member
Thanks Meter: 11
 
More
Thumbs up
Quote:
Originally Posted by jookalook

So it was working with my Nexus 4 until I plugged my fitbit into the charger. After that, the fitbit app can no longer sync with it. Any thoughts?

Edit: It is probably due to the 4.3 48 hour sync bug they mention on their website.

Wow, it is working on my S3 running Cyanogenmod 10.2.

Thank you!!!
3rd October 2013, 07:44 AM |#30  
Junior Member
Thanks Meter: 0
 
More
Reset & turn off background syncing
Quote:
Originally Posted by jookalook

So it was working with my Nexus 4 until I plugged my fitbit into the charger. After that, the fitbit app can no longer sync with it. Any thoughts?

Edit: It is probably due to the 4.3 48 hour sync bug they mention on their website.

Reset your Flex:
1. Plug your charging cable into the USB port and insert your tracker into the charging cable.
2. Insert a paperclip into the small pinhole on the back of the charger.
3. Press the pinhole for 3-4 seconds.

Turn off Background syncing (in the App -> Menu -> Devices -> Tap on your Flex -> remove the tick from Background Syncing)
8th October 2013, 11:55 AM |#31  
Senior Member
Flag Melbourne
Thanks Meter: 281
 
More
Talking
Awesome!
Working on my galaxy nexus running Paranoid Android 3.99 r2.
It still gives the message "there are known issues with bluetooth on your device" but syncs perfectly (and in fact just updated the firmware on my One) regardless.
Much more convenient than having to spoof the config files each time I want to connect!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes