FORUMS
Remove All Ads from XDA

[TUTORIAL] [ROOT] Light Flow - Enable LED For Notifications

1,188 posts
Thanks Meter: 354
 
By hutzdani, Senior Member on 30th December 2014, 02:07 PM
Post Reply Email Thread



Quote:

Okay so we all know by now that you can enable the "Charging LED" to use as a Notification light.
A lot of people have been having issues with getting it up and running, so here is a in depth look at whats needed to get it going.

Sections :
  • Kernels
  • Pre-Requisites
  • General Settings
  • Root Settings
  • Per-Notification Settings
  • SuperUser Settings



*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
Purchase from the playstore : Light Flow PAID APP
*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*




Custom Kernels

Quote:

After Flashing a new kernel you may find that Light Flow will no longer work with the previous settings, you can either clear its cache and data and start again or uninstall and re install.


Kernels tested :
  • Elemental X - Needs Mixer Mode (? 1 Report of working without needing mixer enabled)
  • Franco's - Does not need mixer mode
  • Stock CM - Needs Mixer Mode
  • Stock - Needs Mixer Mode

*If you have used Light Flow with another kernel please PM me and I'll add it to the list*



--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--

Pre-Requisites

1. You MUST be Rooted for this to work

2. The PAID / Donate Version of Light Flow, if yours says LIGHT FLOW LIGHT it is not officially supported by the dev !

3. Make Sure you have a fresh install of light flow so everything is set to default values to make this easy to follow.


--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--

General Settings

1. Once your in Light Flow allow it Root Access if Superuser asks and allow it accessibility access to notifications ( YOU MUST ALLOW THIS ! )

2. Hit the Three horizontal lines in the top left corner of the screens and head for settings

3. Go into General Settings and make sure all the following Settings are Ticked :
  • Enable Light Flow
  • Show LED in Priority Mode
  • Enable Clear All
  • Accessibility check
  • Version Upgrade Reminder ( you don't need this one but i keep it on regardless )



You may find that Lightflow will run in the foreground and leave a persistent notification, this is done to solve issues with the app from stopping running in some cases.
So far I have not had this issue with the N6 so you can go ahead and untick that in Settings -> Persistent Icon.


--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--

Root Settings

Back in the settings menu go into Device Settings and Root

You need to enable the following options if your system is set to SELinux - Enforcing
  • Direct Mode
  • Root Mode
  • Run Every Command as Root
  • Nexus 5 force LED Reset ( this mode does not have to be enabled unless you have issues with your LED messing up )



Quote:

If your system is set to Permissive you can Untick :

  • Run Every command as root
  • Nexus 5 force LED Reset ( this mode does not have to be enabled unless you have issues with your LED messing up )

--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--

Per-Notification Settings

This is all the settings you need to let light flow have control of the LED, now you need to configure Notifications to use the light.

Head into the Notification settings and select one of the Default Profiles ( Im using charging battery )

You need to scroll across the screen to the tab called "LIGHT", on this page scroll down until you see Enable Mixer Mode make sure this is ticked.

Depending on your kernel you may find you don't need to enable Mixer mode, however its more than likely you will need mixer mode enabled !

Now you have control over the 3 Primary colors R/G/B and their brightness ( 1-20 ) - I have played with the brightness settings here and it seems to not affect the LED as of Version 3.51.1

If you are using the LED without mixer mode, you will find that it can't display any colors that are not Red or Green or Blue it.

For example picking Orange from the color picker resulted in a Green LED.
  • You have the same settings for each color however the SOLID option is the only one that seems to work !
  • You can select 1 LED on or all 3 on and mix them together to make other colors but because of the led it does not work as well as the Nexus 5's LED.




--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--

Red / Blue / Green LEDs


SUPERSU Settings

Quote:

You may find that Flightflow appears to show SU notifications constantly, this is because Show notifications is enable in your SU app.
Dive into settings and un-tick the option.

The Following 46 Users Say Thank You to hutzdani For This Useful Post: [ View ] Gift hutzdani Ad-Free
 
 
30th December 2014, 02:22 PM |#2  
Senior Member
Thanks Meter: 639
 
More
Thanks for pulling this together.
Only problem now is 8-10 second delay for screen to wake up.
30th December 2014, 04:02 PM |#3  
Senior Member
Thanks Meter: 91
 
More
Finally seems to work better. This morning w/ slightly different settings it was unusable. Any way to make them flash? A flashing sms light would be perfect.
30th December 2014, 06:15 PM |#4  
Recognized Developer
Flag New York, NY
Thanks Meter: 37,924
 
Donate to Me
More
Quote:
Originally Posted by hutzdani

1. Once your in Light Flow allow it Root Access if Superuser asks and allow it accessibility access to notifications ( YOU MUST ALLOW THIS ! )

use the one in Settings > Sounds & Notifications > App Notifications > Light Flow (Enable) not the one in Accessibility.

The one in accessibility has a warning, [b]"this option is not recommended to be used in android 4.3 upwards and the new notification access method should be used instead"[b/]
I use the one in Sounds & Notifications and LED works fine.

Other than that, great guide. Should help people get it to work Hopefully the LED can be worked on and we won't need Light Flow in the future.
The Following 3 Users Say Thank You to zephiK For This Useful Post: [ View ]
30th December 2014, 06:37 PM |#5  
Senior Member
Flag Long Island N.Y.
Thanks Meter: 151
 
More
Has messaging been fixed yet for texts?
30th December 2014, 06:38 PM |#6  
springer.music's Avatar
Senior Member
Flag Planet Earth
Thanks Meter: 272
 
More
Thumbs up
Thanks for the tutorial.
It would be great to have this guide as a Sticky.
30th December 2014, 09:16 PM |#7  
Senior Member
Thanks Meter: 91
 
More
It's weird so picking the color from the circle drop down doesn't choose the color. You have to tweak/create the color yourself in the mixer options. Either way I like it because it works. Now we just need flashing.
30th December 2014, 09:19 PM |#8  
springer.music's Avatar
Senior Member
Flag Planet Earth
Thanks Meter: 272
 
More
Quote:
Originally Posted by jawmail

It's weird so picking the color from the circle drop down doesn't choose the color. You have to tweak/create the color yourself in the mixer options. Either way I like it because it works. Now we just need flashing.

The colour picker works for me, even without enabling the mixer option.
30th December 2014, 09:36 PM |#9  
OP Senior Member
Flag London
Thanks Meter: 354
 
More
Quote:
Originally Posted by Hand76

Has messaging been fixed yet for texts?


Its working for my "google messenger" ( blue and white chat bubbles icon) I have selected SMS as the notification.
30th December 2014, 09:44 PM |#10  
Senior Member
Thanks Meter: 91
 
More
Quote:
Originally Posted by springer.music

The colour picker works for me, even without enabling the mixer option.

OK yes it does work either way, thanks still trying to learn this app.
31st December 2014, 05:21 AM |#11  
NICEGYPT's Avatar
Senior Member
Flag Grovetown
Thanks Meter: 87
 
Donate to Me
More
How can I get this massage to go away. It's keep poping up every 30 sec. It's driving me crazy
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-12-31-00-18-11.png
Views:	2486
Size:	175.3 KB
ID:	3090631  
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes