FORUMS

e: createTarFork() process ended with ERROR=255

80 posts
Thanks Meter: 15
 
By MiuKing, Member on 27th January 2016, 05:42 PM
Post Reply Email Thread
Hi,

I'm getting this error --> e: createTarFork() process ended with ERROR=255 , when trying to make a backup on TWRP 2.8.7.1. I'm on BenzoRom. Any idea what to do?

I've already tried:
-Reloading TWRP
-Restoring default settings in TWRP
-Setting my time zone in TWRP
-Check data and cache only for Mount partitions
-Already have enough space for the backup itself
The Following User Says Thank You to MiuKing For This Useful Post: [ View ] Gift MiuKing Ad-Free
4th February 2016, 01:09 PM |#2  
Junior Member
Thanks Meter: 5
 
More
Quote:
Originally Posted by MiuKing

Hi,

I'm getting this error --> e: createTarFork() process ended with ERROR=255 , when trying to make a backup on TWRP 2.8.7.1. I'm on BenzoRom. Any idea what to do?

I've already tried:
-Reloading TWRP
-Restoring default settings in TWRP
-Setting my time zone in TWRP
-Check data and cache only for Mount partitions
-Already have enough space for the backup itself

Same here and I've been Googling for hours. Any help? I have my log if that's useful.
4th February 2016, 04:38 PM |#3  
OP Member
Thanks Meter: 15
 
More
I'm not exactly sure why I got that message but I fixed the problem by using a different nandroid backup to restore back to an earlier point. After this, I did a nandroid and it worked perfectly. The latest nandroid was probably corrupt.

I realized that not all nandroids will be completely reliable even using the latest TWRP, so I got a lesson from it that you should always keep multiple nandroids just in case one nandroid back up doesn't work.
The Following 2 Users Say Thank You to MiuKing For This Useful Post: [ View ] Gift MiuKing Ad-Free
Yoinx
6th February 2016, 03:53 AM |#4  
Guest
Thanks Meter: 0
 
More
I've answered this numerous times... So I'm positive that a search would have yielded the answer....

You need to look at /tmp/recovery.log while in recovery (adb pull it). Look in it for the last file that it tried to read before it gave the error. Your options are either delete that file or pull it then delete it. However, the file is corrupt in some way and the backup will never finish.

Restoring an older nandroid fixes this because it deletes the existing files and writes your nandroid back over them.
The Following 7 Users Say Thank You to For This Useful Post: [ View ] Gift Ad-Free
6th February 2016, 04:00 AM |#5  
OP Member
Thanks Meter: 15
 
More
The search feature on xda is subpar at best. I've googled as much as I could before asking this question and I didn't get any solutions from that.
The Following 2 Users Say Thank You to MiuKing For This Useful Post: [ View ] Gift MiuKing Ad-Free
6th February 2016, 04:05 AM |#6  
ComradeCase's Avatar
Junior Member
Flag South Houston
Thanks Meter: 2
 
More
Quote:
Originally Posted by MiuKing

Hi,

I'm getting this error --> e: createTarFork() process ended with ERROR=255 , when trying to make a backup on TWRP 2.8.7.1. I'm on BenzoRom. Any idea what to do?

I've already tried:
-Reloading TWRP
-Restoring default settings in TWRP
-Setting my time zone in TWRP
-Check data and cache only for Mount partitions
-Already have enough space for the backup itself

This happened to me a few months ago and I just had to bite the bullet and do a fresh install of my ROM without backing anything up.
7th February 2016, 09:10 AM |#7  
gman88667733's Avatar
Senior Member
Thanks Meter: 100
 
More
Quote:
Originally Posted by Yoinx

I've answered this numerous times... So I'm positive that a search would have yielded the answer....

You need to look at /tmp/recovery.log while in recovery (adb pull it). Look in it for the last file that it tried to read before it gave the error. Your options are either delete that file or pull it then delete it. However, the file is corrupt in some way and the backup will never finish.

Restoring an older nandroid fixes this because it deletes the existing files and writes your nandroid back over them.

What do you mean by ADB pull it? How can I do this?
9th February 2016, 06:44 PM |#8  
OP Member
Thanks Meter: 15
 
More
Apparently, I'm still getting this issue... I don't know what is triggering this.

This is the recovery.log file i pulled from my tmp folder...

/system/addon.d ---- is this the issue? If so, twrp is looking for this file, how would I be able to fix this? delete that addon.d file?

I: Operation_start: 'Nandroid'
Updating partition details...
I: Data backup size is 5212MB, free: 23014MB.
I:Unable to mount '/usb-otg'
I:Actual block device: '', current file system: 'vfat'
...done
I:Backup Name is: '2016-02-09--13-32-48_MMB29T'
I:Full_Backup_Path is: '/data/media/0/TWRP/BACKUPS/ZX1G32284P/2016-02-09--13-32-48_MMB29T/'
I:Calculating backup details...
* Total number of partitions to back up: 9
* Total size of all data: 8174MB
* Available space: 23014MB

[BACKUP STARTED]
* Backup Folder: /data/media/0/TWRP/BACKUPS/ZX1G32284P/2016-02-09--13-32-48_MMB29T/
Backing up System...
E:Error opening '/system/addon.d' -- error: Not a directory
E:Error in Generate_TarList!
I:InfoManager saving '/data/media/0/TWRP/BACKUPS/ZX1G32284P/2016-02-09--13-32-48_MMB29T/system.info'
E:createTarFork() process ended with ERROR=255
Backup Failed.
Cleaning Backup Folder
I:Copying file /tmp/recovery.log to /data/media/0/TWRP/BACKUPS/ZX1G32284P/2016-02-09--13-32-48_MMB29T/recovery.log
I:Set page: 'action_complete'
I: Operation_end - status=1
I:Set page: 'clear_vars'
I:Set page: 'main2'
I:Set page: 'advanced'
9th February 2016, 11:42 PM |#9  
OP Member
Thanks Meter: 15
 
More
bump
11th February 2016, 08:48 AM |#10  
Junior Member
Thanks Meter: 5
 
More
Quote:
Originally Posted by MiuKing

bump

Hey man, I was able to resolve mine so should work for you:
- Ran a Titanium backup of all my apps and exported these to a PC to be safe.
- Performed a factory reset.
- Installed a fresh ROM.
- Restored my app backups. The wipe didn't reach them
- That's it. Standard wipe doesn't delete media so that's safe.

Whole process took about an hour. Good luck!
The Following User Says Thank You to The_Fuzz22 For This Useful Post: [ View ] Gift The_Fuzz22 Ad-Free
11th February 2016, 04:08 PM |#11  
OP Member
Thanks Meter: 15
 
More
Quote:
Originally Posted by The_Fuzz22

Hey man, I was able to resolve mine so should work for you:
- Ran a Titanium backup of all my apps and exported these to a PC to be safe.
- Performed a factory reset.
- Installed a fresh ROM.
- Restored my app backups. The wipe didn't reach them
- That's it. Standard wipe doesn't delete media so that's safe.

Whole process took about an hour. Good luck!

Yeah I realized that it wasn't even worth it. Clean installed BenzoRom. Everything is fine now.
The Following User Says Thank You to MiuKing For This Useful Post: [ View ] Gift MiuKing Ad-Free
Post Reply Subscribe to Thread

Tags
createtarfork(), error=255, twrp

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes