FORUMS
Remove All Ads from XDA

Cannot Disable Native Captive Portal Detection

47 posts
Thanks Meter: 5
 
By The Wrath of Kahn, Member on 1st May 2017, 08:25 PM
Post Reply Email Thread
Starting shortly after the 7.1.2 official builds, I can no longer successfully disable native captive portal detection on my 6P.

I used to be able to use the following command in adb shell: adb shell settings put global captive_portal_detection_enabled 0

However, this no longer has any effect, even though I can run the next command: adb shell settings get global captive_portal_detection_enabled and it will return 0 like it is supposed to, indicating that it has been disabled.

It seems that this functionality has been broken in the latest security patches, and I have searched far and wide with no answers except for what I already know. If I cannot disable native captive portal detection, it will not permit "Hello Guest Wifi" (an app that used to work reliably) to automatically sign into the public network at my workplace and requires manual connection multiple times per day. Any help would be greatly appreciated!
 
 
7th May 2017, 08:41 AM |#2  
Junior Member
Flag Paris
Thanks Meter: 18
 
More
Hi, I had the same issue. After digging into android_framework_base, this was not broken, but the configuration has changed.

Now there is 3 captive portal settings:
https://github.com/LineageOS/android...ngs.java#L8273
- ignore: Don't attempt to detect captive portals
- prompt (default): When detecting a captive portal, display a notification that prompts the user to sign in.
- avoid: When detecting a captive portal, immediately disconnect from the network and do not reconnect to that network in the future.

The setting to configure is no more captive_portal_detection_enabled. Instead, use captive_portal_mode

Quote:

settings put global captive_portal_mode 0

The Following 8 Users Say Thank You to guilc For This Useful Post: [ View ] Gift guilc Ad-Free
12th May 2017, 12:28 PM |#3  
Frogger4600's Avatar
Senior Member
Flag Shanghai
Thanks Meter: 58
 
More
Quote:
Originally Posted by guilc

Hi, I had the same issue. After digging into android_framework_base, this was not broken, but the configuration has changed.

Now there is 3 captive portal settings:
https://github.com/LineageOS/android...ngs.java#L8273
- ignore: Don't attempt to detect captive portals
- prompt (default): When detecting a captive portal, display a notification that prompts the user to sign in.
- avoid: When detecting a captive portal, immediately disconnect from the network and do not reconnect to that network in the future.

The setting to configure is no more captive_portal_detection_enabled. Instead, use captive_portal_mode

Oh, thank you so much. I was having this issue with my Lenovo Zuk Z1 and you just saved me a huge amount of frustration. lol
18th October 2017, 09:19 PM |#4  
Senior Member
Thanks Meter: 11
 
More
Quote:
Originally Posted by guilc

use captive_portal_mode

works awesome on android 7.1
you saved my live
5th December 2017, 09:26 PM |#5  
Senior Member
Thanks Meter: 49
 
More
Angry this is it!
@guilc
well done!
@wannabe-developers
u should be condemned to have only access to networks
that block access to your hard-coded:
'yes i can curl that, now the system has internet access'
targets for the rest of time.
and no root or adb access!

thx for breaking the user
30th December 2017, 01:32 AM |#6  
salimtn's Avatar
Senior Member
Flag kairouan
Thanks Meter: 122
 
More
Quote:
Originally Posted by guilc

Hi, I had the same issue. After digging into android_framework_base, this was not broken, but the configuration has changed.

Now there is 3 captive portal settings:
https://github.com/LineageOS/android...ngs.java#L8273
- ignore: Don't attempt to detect captive portals
- prompt (default): When detecting a captive portal, display a notification that prompts the user to sign in.
- avoid: When detecting a captive portal, immediately disconnect from the network and do not reconnect to that network in the future.

The setting to configure is no more captive_portal_detection_enabled. Instead, use captive_portal_mode

thank you so much
you saved my time clearing this annoying notification.
19th April 2018, 09:18 PM |#7  
b1k3rdude's Avatar
Senior Member
Flag London
Thanks Meter: 26
 
More
I get permission denial message when I try this command, its a shame there isnt an xposed module for this..
19th April 2018, 10:43 PM |#8  
Senior Member
Thanks Meter: 49
 
More
Location well...
got root?
if not try adb from pc...

i guess: no root, no luck! though
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes