FORUMS
Remove All Ads from XDA

[ROM][7.x] nAOSProm for Nexus 7 (2012)

286 posts
Thanks Meter: 807
 
By millosr, Senior Member on 23rd September 2016, 01:29 PM
Post Reply Email Thread
24th September 2016, 01:45 AM |#11  
OP Senior Member
Flag Belgrade
Thanks Meter: 807
 
Donate to Me
More
Quote:
Originally Posted by frov

[B01] I tried some 720p movie on youtube and that ran great.
Video in other apps just does not run at all.
Not in Kodi, nor in the NOS app (Dutch news), nor Horizon app (Dutch TV app).

Quote:
Originally Posted by supertiger1234

I'm sorry but I didn't really understand xD
So you installed b01 and then installed b07 and YouTube ran fine?
Sorry, thanks ;D

Edit: also where is b07? Am I missing something?
Thanks

I have retested now Youtube with 720p video and it works fine for me. Maybe it was some background task before that caused youtube video freeze.
I did clean install - wipe data/cache then install rom + gapps

I've tested video playing in MXPlayer and it doesn't work. I will investigate.
24th September 2016, 08:01 AM |#12  
frov's Avatar
Senior Member
Flag Tilburg
Thanks Meter: 186
 
More
Quote:
Originally Posted by millosr

I've tested video playing in MXPlayer and it doesn't work. I will investigate.

I reckon this is related to the video problems I have with these apps:
https://play.google.com/store/apps/d....nos.app&hl=nl
https://play.google.com/store/apps/d...bmc.kodi&hl=nl

Great when this is fixed (then my wife can watch TV again in this app (need password):https://play.google.com/store/apps/d...nandroid&hl=nl )
24th September 2016, 07:51 PM |#13  
Senior Member
Flag Vancouver, Canada
Thanks Meter: 18
 
More
Anyone played any working games? They don't seem to be working for me.
24th September 2016, 08:47 PM |#14  
frov's Avatar
Senior Member
Flag Tilburg
Thanks Meter: 186
 
More
Quote:
Originally Posted by Ludespeed

Anyone played any working games? They don't seem to be working for me.

No, did not play games: give me an example app so I can try & test.
24th September 2016, 11:30 PM |#15  
OP Senior Member
Flag Belgrade
Thanks Meter: 807
 
Donate to Me
More
Quote:
Originally Posted by Ludespeed

Anyone played any working games? They don't seem to be working for me.

I have tried Sky Force, Subway Surfers, Push Box, they all work fine. Those are games that my son is playing on this device.
This is an old device with only 1 GB of RAM and some newer games may not work on it.
The Following 2 Users Say Thank You to millosr For This Useful Post: [ View ] Gift millosr Ad-Free
25th September 2016, 10:57 AM |#16  
Senior Member
Flag Manchester - United Kingdom
Thanks Meter: 11
 
More
hello guys and girls.. I posted this as the NFC does not work with this build.

But there is a temporary solution to fix the NFC not working untill the op updates his thread. I thank @millosr for all this hard work with this rom.
i wish him the best of luck to make this device alive again

But all you need to do is FLASH this with the rom http://forum.xda-developers.com/atta...0&d=1474186454

and the NFC should work again (works with both nexus 7 2012 devices) Thanks to @daniel_hk for letting me provide this. All credit goes to him for making this for this thread

I have fully tested this with beaming facebook to nexus 7 2013 and google app to nexus 7 2012 and works 100%. Enjoy
The Following User Says Thank You to swiftyste For This Useful Post: [ View ] Gift swiftyste Ad-Free
25th September 2016, 12:40 PM |#17  
OP Senior Member
Flag Belgrade
Thanks Meter: 807
 
Donate to Me
More
Quote:
Originally Posted by swiftyste

hello guys and girls.. I posted this as the NFC does not work with this build.

But there is a temporary solution to fix the NFC not working untill the op updates his thread. I thank @millosr for all this hard work with this rom.
i wish him the best of luck to make this device alive again

But all you need to do is FLASH this with the rom http://forum.xda-developers.com/atta...0&d=1474186454

and the NFC should work again (works with both nexus 7 2012 devices) Thanks to @daniel_hk for letting me provide this. All credit goes to him for making this for this thread

I have fully tested this with beaming facebook to nexus 7 2013 and google app to nexus 7 2012 and works 100%. Enjoy

Thanks, for this patch Who needs NFC can use this until next build.

I've actually already fixed NFC, and it will be in the next build. It is the same fix as for nAOSP-6:
https://github.com/millosr/android_p...0f7595443927f3

NFC wasn't priority for me so I didn't fix it for the first build.

Currently priority is fixing video playing in various applications. MX player actually works, it was just permission issue since I was restore it with Titanium Backup and it wasn't given Storage Permission.

There is also issue with placing widgets on the home screens. That will also be fixed in the next build.
The Following User Says Thank You to millosr For This Useful Post: [ View ] Gift millosr Ad-Free
25th September 2016, 01:17 PM |#18  
Senior Member
Flag Manchester - United Kingdom
Thanks Meter: 11
 
More
Quote:
Originally Posted by millosr

Thanks, for this patch Who needs NFC can use this until next build.

I've actually already fixed NFC, and it will be in the next build. It is the same fix as for nAOSP-6:
https://github.com/millosr/android_p...0f7595443927f3

NFC wasn't priority for me so I didn't fix it for the first build.

Currently priority is fixing video playing in various applications. MX player actually works, it was just permission issue since I was restore it with Titanium Backup and it wasn't given Storage Permission.

There is also issue with placing widgets on the home screens. That will also be fixed in the next build.

Your very welcome. Glad i could help. Its hard work but they surly be fixed real soon. Great work
25th September 2016, 04:13 PM |#19  
frov's Avatar
Senior Member
Flag Tilburg
Thanks Meter: 186
 
More
Quote:
Originally Posted by millosr

Thanks, for this patch Who needs NFC can use this until next build. I've actually already fixed NFC, and it will be in the next build. It is the same fix as for nAOSP-6:
https://github.com/millosr/android_p...0f7595443927f3 NFC wasn't priority for me so I didn't fix it for the first build. Currently priority is fixing video playing in various applications. MX player actually works, it was just permission issue since I was restore it with Titanium Backup and it wasn't given Storage Permission. There is also issue with placing widgets on the home screens. That will also be fixed in the next build.

On the video playing: I tried the other ROM on my Nexus 7, Dirty Unicorns by Daniel_HK, but that one also does not play any of the video related apps (or the video related parts in these apps).
I just tried on the Android 7 ROM for the Xperia S and there it does work fine: I tried the NOS app and I tried to run video trailers (Apple Movie Trailer) in Kodi for Android. On the XS it works.
26th September 2016, 12:44 PM |#20  
frov's Avatar
Senior Member
Flag Tilburg
Thanks Meter: 186
 
More
Quote:
Originally Posted by frov

On the video playing: I tried the other ROM on my Nexus 7, Dirty Unicorns by Daniel_HK, but that one also does not play any of the video related apps (or the video related parts in these apps). I just tried on the Android 7 ROM for the Xperia S and there it does work fine: I tried the NOS app and I tried to run video trailers (Apple Movie Trailer) in Kodi for Android. On the XS it works.

Hmmm, I now see that I flashed the wrong / old Dirty Unicorns ROM by Daniel_HK: in this other thread and post he refers to having fixed the Video problems:
http://forum.xda-developers.com/nexu...icial-t3467615
He says in the changelog: Find a way to fix the hwcomposer for video/audio playback, need to review later
And refers to having fixed it in this post:
http://forum.xda-developers.com/show...9&postcount=27
So I guess (I do not have access to my N7 right now) I flashed his 20160917 ROM whereas I should try this one: aosp_grouper-ota-eng.20160923.zip
So I reckon that insight in howto fix video can be found there.
26th September 2016, 11:10 PM |#21  
frov's Avatar
Senior Member
Flag Tilburg
Thanks Meter: 186
 
More
Quote:
Originally Posted by frov

Hmmm, I now see that I flashed the wrong / old Dirty Unicorns ROM by Daniel_HK: in this other thread and post he refers to having fixed the Video problems:
http://forum.xda-developers.com/nexu...icial-t3467615
He says in the changelog: Find a way to fix the hwcomposer for video/audio playback, need to review later
And refers to having fixed it in this post:
http://forum.xda-developers.com/show...9&postcount=27
So I guess (I do not have access to my N7 right now) I flashed his 20160917 ROM whereas I should try this one: aosp_grouper-ota-eng.20160923.zip
So I reckon that insight in howto fix video can be found there.

Again reply to myself: I now flashed the newer ROM by Daniel_HK (Sept23 version), as I pointed out above, and now video works
BTW, flashing that ROM was a fight to get Gapps to work, but in the end that ran and I could test the video apps I pointed out before in this thread. All work: kodi / nos / horizon go.
So now looking forward to nAOSP to include this video fix
Post Reply Subscribe to Thread

Tags
7.0, grouper, nexus 7, nougat, tilapia

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes