FORUMS

[GUIDE] How to get "classic" google visual vm back after sprint integration

1,307 posts
Thanks Meter: 209
 
By zikronix, Senior Member on 12th May 2011, 04:50 AM
Post Reply Email Thread
Ok so I orginally thought the idea of GV integration with sprint was awesome...after fiddling with it. I was very disappointed.

The problems I had with it were...I dont want to use my GV number as my primary. I dont want to change my GV number to my cell number. Each option had issues that I felt needed to be addressed. Changing my GV number to my cell made it to where txt would be comming into my phone via gv app. Yes there is a work around but ita annoying and I dont want my text stored on line. I also didnt want to change my gv number, this to me sounds like it could be a bad idea at some point in time, and cause other issues. So I set out how to get classic google voice back with the new app that will not let you just use it for vm heres how i did it, now I know this affects the Nexus S 4G with the version of GV they include...however the market version does seem to be different.

Option 1 (For Rooted Phones)

1) Use Titanium backup or some other root explorer to delete the stock voice apk, then reboot recovery and wipe dalvik

2) Once back inside the rom download voice from the market as that version doesnt seem to suffer from the shitty options that are stock on the phone


Option 2 (The proper way for rooted and non rooted phones)


1) Launch GV app on phone, and sign in, when it ask choose to change your gv number to your cell number.

2) Get annoyed and go get a shot of vodka, and wait about 15 minutes (honestly because you wont be able to change it back for at least 15 minutes.)

3) Login to gv on the web (voice.google.com)

4) once in there click the gear, and pick voice settings. Under the phone area choose to disable the sprint port number (your google voice number). It will disable and revert back to your old gv number

5) Where you mobile number is at you should see enable google voice mail for this line. Click that, and follow the instructions.

6) Click on voice mail and text uncheck email message and send sms.

7) on your phone open gv, goto more then settings make sure it says. Making calls do not use gv to make calls. make sure this phones number is your actual mobile number adjust sync options as you wish and make sure My gv number is indeed your gv number.

8) DO NOT SIGN OUT OF THE APP (Im not sure what will happen but my guess is it will break)

9) Edit your voice mail settings under call settings and change your vm settings to GV from "My Carrier" and make sure your GV number is in there.


Options: Now if you dont want to use the gv app at all you can have gv send you an sms or an email instead or manually check your voice mail by phone.


Enjoy
The Following 3 Users Say Thank You to zikronix For This Useful Post: [ View ] Gift zikronix Ad-Free
12th May 2011, 06:36 AM |#2  
herbthehammer's Avatar
Senior Member
Thanks Meter: 51
 
More
I kinda did this a different way but not as elegant. I used root manager to remove google voice. I might have used root manager to remove the data too but I can't recall. I rebooted. Then I tried downloading google voice again. I think it installed. I tried running it and there was a problem. I uninstalled it. Then installed it again. That must have flushed out all the references to the program that I missed. Ran the program, signed in, chose let me choose to use google voice for every call. Then I clicked the link for conditional call forwarding and hit send. It's *28(google voice number with area code) then send. After that I hit back until I got back to the gv setup. I chose skip then next then I think I was done. It's working now the old way. Separate numbers and google voice for voicemail.
17th May 2011, 03:13 PM |#3  
dkratter14's Avatar
Senior Member
Flag New York, NY
Thanks Meter: 26
 
More
Quote:
Originally Posted by zikronix

Changing my GV number to my cell made it to where txt would be comming into my phone via gv app. Yes there is a work around but ita annoying and I dont want my text stored on line.

Can you explain what this workaround is? I'm not too thrilled with how the GV app handles SMS either.
17th May 2011, 03:18 PM |#4  
styckx's Avatar
Senior Member
Thanks Meter: 1,481
 
More
The most annoying thing about this is the app options seems useless for configuration purposes. You really have to configure this through the web to work right.

After I first set it up and tested a voice mail I got

An email, an MMS, and a notification bar alert from GVM app itself even though in the app I had the first two disabled.. Finally got it down to just a notification bar alert from the GVM app only after configuring through the web. It's stupid that by default it lets you know THREE different ways you have a damn voice mail.
17th May 2011, 03:35 PM |#5  
Senior Member
Thanks Meter: 45
 
More
I love it!

My texts come to my phone just as they are supposed to and since I turned off notifications in GV app I don't get notifications in the app. I get emails and texts telling me of voice messages just like before. Yes the app still receives text messages and stores them online, but I see this as a plus since txt is mainly how I communicate and my job has me working in a lot of places with internet access but no cell coverage. win win in my book.

To get texts sent to your phone you have to check the little box in your settings that says "Receive text messages on this phone (mobile phones only)"

It took me a while to messing around to get everything set up, but I'm liking it now.
17th May 2011, 03:58 PM |#6  
ookees's Avatar
Member
Thanks Meter: 7
 
More
I use option 2 (GV number in place of cell number). It works flawlessly. I have had no issues. For me this was easy because I made people use my GV # as my primary number years ago. It just takes a little time an patience getting all your friends and family to use the GV #, but once its done its the best move you'll ever make.
17th May 2011, 08:37 PM |#7  
Senior Member
Thanks Meter: 4
 
More
Quote:
Originally Posted by dkratter14

Can you explain what this workaround is? I'm not too thrilled with how the GV app handles SMS either.

I second that.
17th May 2011, 09:57 PM |#8  
Senior Member
Thanks Meter: 45
 
More
Quote:
Originally Posted by Blackhawk163

I second that.

It doesn't have to handle sms. Check that little checkbox and the sms will be delivered to your phone like they were before. Then go into GV app and turn off notifications.
17th May 2011, 10:59 PM |#9  
Member
Flag California
Thanks Meter: 2
 
More
Nice guide. Well since my Nexus is stock and I couldn't stand how broken gv and sprint are together I wanted it to go back to go it was.

That is to say, texts and voicemails come through notifications by the Google voice app and texts sent to my mobile number come through the default messaging app. That's how its supposed to be.

It's quite easy to do, in settings for Google voice in your phone turn off all notifications and inbox synchronization. Basically nothing should be checked. Then in the web go to your Google voice settings and under phones next to your mobile number click on "disable Google voice on your sprint phone".

That should make everything normal again. Hope that helps. I don't see the point of what sprint and Google were trying to do here. The Google voice app works just fine the way it is. Don't mess with a good thing.

Sent from my Nexus S 4G using XDA Premium App
17th May 2011, 11:18 PM |#10  
Junior Member
Flag Waipahu
Thanks Meter: 2
 
More
Quote:
Originally Posted by eagercrow

It doesn't have to handle sms. Check that little checkbox and the sms will be delivered to your phone like they were before. Then go into GV app and turn off notifications.

I think the folks asking, like myself, are looking for slightly more detail.

After rooting around for the setting mentioned I found it.

1. Log in to Google Voice online
2. Click on the little gear in the upper right hand corner to access Options
3. Click on Voice Settings
4. On the Phones tab under "Forward calls to" click on the Edit button for your Google Voice enabled mobile phone
5. Where it says "Text Settings" check the box for "Receive text messages on this phone (mobile phones only)"

This should send texts to your phones SMS app rather than through the Google Voice app.

Hope this saves others some time searching.
The Following 2 Users Say Thank You to shardinite For This Useful Post: [ View ] Gift shardinite Ad-Free
17th May 2011, 11:44 PM |#11  
Junior Member
Thanks Meter: 2
 
More
My biggest pet peeves were:

1. Incoming messages from the same sender would sometimes create multiple threads inside of Google Voice.

2. SMS messages received from contacts that were not stored in Google account (i.e. corporate account) would commonly show up from a telephone number versus a name.

3. SMS messages initiated from Google Voice would not show up as threads until they were responded to.

4. Messaging application was rendered useless bloatware.

5. I don't want/need Google Voice to archive 300 - 500 text messages a day.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes