FORUMS
Remove All Ads from XDA

[Q] GSM Nexus S ICS 4.0.4 OTA update released?

4 posts
Thanks Meter: 0
 
By ishkibble, Junior Member on 28th March 2012, 02:56 PM
Post Reply Email Thread
Last night (27-3-2012) I had a notification pop up on my stock 4.0.3 (rooted with AIR kernel) Nexus S. It was a notification for an OTA 4.0.4 update. I downloaded it (it was about 17.5 megs) and when I tried to update it, it gave an error saying the package couldn't be verified (or something to that effect). I tried searching the SDcard and system folders for the update but couldn't find one. I tried to go to settings and recheck for update but nothing comes up. My wife has the same phone (a Nexus S) and she didn't get a notification and nothing pops up when I do a check for update. I'd love to find the update file and upload it for you guys but I just can't find the bugger. Anyone have an idea where to look? It was late and I didn't take any screen caps cuz I though Google was finally rolling out ICS 4.0.4 but I can't find anything online about this latest update. Any ideas?

EDIT: This is for GSM Nexus S's, NOT Nexus S 4G. My wife and I each have a GSM Nexus S with T-Mobile.

EDIT 2: See Meisze's post for the link. I'll flash it as soon as it downloads and I'll post some info.

EDIT 2.5: I tried to update but got Status Error 7. I'm going to flash the full 4.0.3 update, then the lite 4.0.4 update and that should work.

EDIT 2.5.5: ok, I get Status Error 7 when i try to flash the full stock 4.0.3 update. I'm going to flash 2.3.6 -> 4.0.3 -> 4.0.4 and see if that works.

EDIT 3: WARNING YOU CAN BRICK YOU'RE PHONE! I bricked mine in the process and just got it working again. I was trying to flash the 4.0.4 lite update and it kept saying Status Error 7. So I restore a backup of the phone from 2.3.6. Without rebooting I then flashed the full 4.0.3 update (ot error 7) and then the lite 4.0.4 (again, no error 7). I reboot and nothing... No Google/lock logo, no recovery, no fastboot nothing. I used Adams tool and get into fastboot. I tried flashing CWM recovery and still nothing.

I fixed it by doing this.
1. Used Adam's toll to get into fastboot. Adam's UnBrickable Resurrector program for Linux http://forum.xda-developers.com/show....php?t=1397393 I used Backtrack 5 (Based on Ubuntu)
2. ran fastboot boot recovery.img (Flashed latest CWM touch recovery 5.8.0.2, renamed to recovery.img)
3. In CWM ran the stock 2.3.6 full update
4. Rebooted and everything was back to normal.
5. Went back into CWM, Flashed stock 4.0.3 full
6. Rebooted, everything still fine...
7. Went back to CWM flashed stock 4.0.4 lite
8. Rebooted and everything is working great.
 
 
28th March 2012, 03:05 PM |#2  
Member
Thanks Meter: 11
 
More
Funny you mention it because I saw this today...
http://www.androidcentral.com/motoro...oid-404-update
28th March 2012, 03:06 PM |#3  
Member
Thanks Meter: 11
 
More
I found it from miui China : http://www.miui.com/thread-504894-1-1.html
28th March 2012, 03:12 PM |#4  
Member
Thanks Meter: 11
 
More
Niiiice!
28th March 2012, 03:19 PM |#5  
Senior Member
Thanks Meter: 59
 
More
I flashed it.It is booted now.
To flash it you have to be on 4.0.3. stock unrooted
it is android 4.0.4 IMM76D
baseband I9023XXKI1
kernel 3.0.8-g6656123
so it has a new kernel
browser now works as it should have worked in 4.0.3 now it is fast smooth and no white pages.
Recovery works
The Following User Says Thank You to vick33 For This Useful Post: [ View ] Gift vick33 Ad-Free
28th March 2012, 03:21 PM |#6  
Member
Thanks Meter: 11
 
More
same here =)
28th March 2012, 03:22 PM |#7  
shockem's Avatar
Inactive Recognized Developer
Flag Singapore
Thanks Meter: 339
 
Donate to Me
More
A.W.E.S.O.M.E !

Sent from my Nexus S using Tapatalk
The Following User Says Thank You to shockem For This Useful Post: [ View ] Gift shockem Ad-Free
28th March 2012, 03:23 PM |#8  
Member
Thanks Meter: 11
 
More
oops, Iforgot I'm running the 4.0.4 leak. Can't update now.
28th March 2012, 03:23 PM |#9  
thegtfusion's Avatar
Senior Member
Flag Utrecht
Thanks Meter: 2,254
 
More
Sooo if I get back to stock 2.3.6 I will get the 4.0.4 otA?
28th March 2012, 03:26 PM |#10  
Senior Member
Thanks Meter: 27
 
More
make pics and post it here! please

need root for that?
28th March 2012, 03:28 PM |#11  
Senior Member
Thanks Meter: 629
 
More
Quote:
Originally Posted by thegtfusion

Sooo if I get back to stock 2.3.6 I will get the 4.0.4 otA?

Not necessarily. The link posted here is only for an upgrade from 4.0.3. No one has posted a link from 2.3.6 so it is possible they are pushing only the upgrade for now. These rollouts take time so you aren't guaranteed a notification until it is fully rolled out.
Post Reply Subscribe to Thread

Tags
ics 4.0.4, ota ics update

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes