Remove All Ads from XDA

Need To Restore Nexus S 4g

149 posts
Thanks Meter: 38
By mightybryan, Senior Member on 23rd February 2013, 05:12 AM
Post Reply Email Thread
I have an extreme problem with my Nexus. I've been through thick and thin with this phone, and I'm hoping you guys will help with a solution to this problem.

The power button to my Nexus is broken completely. I stabbed it so much that the clicking black part is completely removed from the slot (on the motherboard).

One time, my Nexus S died, and I realized I had no way to turn it back on. I tried every single method (battery pulling, button pressing, USB connecting, etc) with no answer. I finally was able to find a solution. I used Odin to restore the bootloader tar md5 file, and thus auto rebooting the nexus (when the box is checked). This worked like a charm, until I realize I made a fatal mistake.

I chose an md5 file for the ORIGINAL Nexus S (not 4g).

I was able to easily go into recovery with Quick Boot from the Play Store. I installed Raspbean Jellybean (02-05-13 build), but the installation was very faulty. The home button is nonfunctional (it vibrates when pressed, but nothing happens) and Browser is not working as it just closes itself instantly. Like an idiot, I didn't install Gapps before rebooting into the ROM.

Stuck in that dilemma, I used the built in email app to sync my Gmail account to the phone. I sent a Quick Boot APK to myself to try and open so I could reach recovery, but it said there's no type of program that can open that file (maybe because Gapps isn't installed).

The last thing I tried was Odin again. I tried to restore the ICS release keys, but Odin will not recognize my phone anymore for nothing. I tried 3 different USBs (2 with shorts, and 1 normal one. I don't know if the type of USB has anything to do with it). Nothing.

So here I am with a faulty, Gappless ROM on my Nexus S 4G with a completely broken power.

I'm wondering if you guys have any solution/suggestion to get Odin to recognize my phone again so I can restore it and work from there.
Apart from that, ANY solution to this problem is highly acceptable and greatly appreciated (ways to get into recovery, etc). I don't want this to be the last of me and my sweet ole Nexus =(,

Thanks x1000 XDA!
23rd February 2013, 04:36 PM |#2  
mightybryan's Avatar
OP Senior Member
Thanks Meter: 38
Hey Guys. I was actually able to reach recovery, because the ROM I'm using has a Power Menu widget in it's quick settings (Go Figure). But my phone is still unable to be recognized by Odin in Download mode. The phone is also not recognized by my pc at all. It only charges, no matter what USB I try. I even tried mounting in recovery, no go.

Please help. Thanks!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes