FORUMS
Remove All Ads from XDA

Problem with MMS being received over Wifi? Possible fix

61 posts
Thanks Meter: 28
 
By Nerowoof, Member on 6th November 2014, 01:38 PM
Post Reply Email Thread
HI all and please forgive me if this has been covered, I did search!
I just jumped from the note 3 to note 4 and once again experienced the problem of mms messages being received over wifi. I could get them if i turned wifi off.
It appears that the Tmobile default APN has no port set for Multi media message port (at least mine didn't)
I created a new apn with all the default setting but added multi media message port 80 and it seems to have corrected the problem.

Im not rooted so no custom rom installed. (Yes, i had my note 3 rooted and was a rom freak

Please delete this if its covered somewhere else and accept my apologies.

I hope this can help some others out.
The Following 12 Users Say Thank You to Nerowoof For This Useful Post: [ View ] Gift Nerowoof Ad-Free
6th November 2014, 02:21 PM |#2  
crackpot's Avatar
Senior Member
Flag SC
Thanks Meter: 344
 
More
Quote:
Originally Posted by Nerowoof

HI all and please forgive me if this has been covered, I did search!
I just jumped from the note 3 to note 4 and once again experienced the problem of mms messages being received over wifi. I could get them if i turned wifi off.
It appears that the Tmobile default APN has no port set for Multi media message port (at least mine didn't)
I created a new apn with all the default setting but added multi media message port 80 and it seems to have corrected the problem.

Im not rooted so no custom rom installed. (Yes, i had my note 3 rooted and was a rom freak

Please delete this if its covered somewhere else and accept my apologies.

I hope this can help some others out.

Sweet lord baby Jesus, this worked! You, sir, are my new e-Hero!!!!

For the record I tested using Hangouts and I changed the APN settings in both the Hangouts app and Android itself. SM-N910T completely stock (unrooted).
6th November 2014, 02:26 PM |#3  
OP Member
Thanks Meter: 28
 
More
Quote:
Originally Posted by crackpot

Sweet lord baby Jesus, this worked! You, sir, are my new e-Hero!!!!

For the record I tested using Hangouts and I changed the APN settings in both the Hangouts app and Android itself. SM-N910T completely stock (unrooted).

YEAH! with all the help i have received from this forum im happy to help at least one person out!
6th November 2014, 03:13 PM |#4  
raw2000j's Avatar
Senior Member
Thanks Meter: 491
 
More
WiFi over mms doesn't work with wifi calling right picture messages?
6th November 2014, 03:54 PM |#5  
LaDoyers's Avatar
Senior Member
Thanks Meter: 121
 
More
Success! Mms works over wifi calling on the inverted message app. Thanks a bunch!
6th November 2014, 03:56 PM |#6  
Member
Thanks Meter: 6
 
More
This sounds very helpful could you post some pictures of how its supposed to look? I rarely do anything with the apn settings i usually wait for the flashable zip.
6th November 2014, 04:00 PM |#7  
Junior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by Nerowoof

HI all and please forgive me if this has been covered, I did search!
I just jumped from the note 3 to note 4 and once again experienced the problem of mms messages being received over wifi. I could get them if i turned wifi off.
It appears that the Tmobile default APN has no port set for Multi media message port (at least mine didn't)
I created a new apn with all the default setting but added multi media message port 80 and it seems to have corrected the problem.

Im not rooted so no custom rom installed. (Yes, i had my note 3 rooted and was a rom freak

Please delete this if its covered somewhere else and accept my apologies.

I hope this can help some others out.

Can someone give us a play by play on how to do this?

Sent from my SM-N910T using XDA Free mobile app
6th November 2014, 04:06 PM |#8  
LaDoyers's Avatar
Senior Member
Thanks Meter: 121
 
More
Just as the op instructed. Make an additional profile identical to the default. Then input "80" under "multimedia message port". Save and select the new profile.

Settings/more networks/mobile networks/apn

I took a screen shot of the default settings and used the pop up windows.
Attached Thumbnails
Click image for larger version

Name:	uploadfromtaptalk1415289907101.jpg
Views:	5396
Size:	248.8 KB
ID:	3002494  
The Following 2 Users Say Thank You to LaDoyers For This Useful Post: [ View ] Gift LaDoyers Ad-Free
7th November 2014, 05:38 PM |#9  
Senior Member
Flag Chicago, IL
Thanks Meter: 15
 
More
Would this also work on my wife's T-Mobile S5?

Also here it is (with the update for MMS over WiFi) broken down to help people visualize:

Name: T-Mobile US LTE
APN: fast.t-mobile.com
Proxy: Not set
Port: Not set
Username: Not set
Password: Not set
Server: Not set
MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
Multimedia message proxy: Not set
Multimedia message port: 80
MCC: 310
MNC: 260
Authentication type: None
APN type: default,mms,supl
APN protocol: IPv6
APN roaming protocol: IPv4
Enable/disable APN: APN enabled
Bearer: Unspecified
Mobile virtual network operator type: None
Mobile virtual network operator value: Not set

---------- Post added at 11:38 AM ---------- Previous post was at 11:16 AM ----------

For hangouts I'm assuming you only inputted [name, mmsc,mms port, mcc,mnc]?

Quote:
Originally Posted by crackpot

Sweet lord baby Jesus, this worked! You, sir, are my new e-Hero!!!!

For the record I tested using Hangouts and I changed the APN settings in both the Hangouts app and Android itself. SM-N910T completely stock (unrooted).

The Following 2 Users Say Thank You to inco9nito99 For This Useful Post: [ View ] Gift inco9nito99 Ad-Free
7th November 2014, 05:41 PM |#10  
crackpot's Avatar
Senior Member
Flag SC
Thanks Meter: 344
 
More
Quote:
Originally Posted by inco9nito99

Would this also work on my wife's T-Mobile S5?

Also here it is (with the update for MMS over WiFi) broken down to help people visualize:

Name: T-Mobile US LTE
APN: fast.t-mobile.com
Proxy: Not set
Port: Not set
Username: Not set
Password: Not set
Server: Not set
MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
Multimedia message proxy: Not set
Multimedia message port: 80
MCC: 310
MNC: 260
Authentication type: None
APN type: default,mms,supl
APN protocol: IPv6
APN roaming protocol: IPv4
Enable/disable APN: APN enabled
Bearer: Unspecified
Mobile virtual network operator type: None
Mobile virtual network operator value: Not set

---------- Post added at 11:38 AM ---------- Previous post was at 11:16 AM ----------

For hangouts I'm assuming you only inputted [name, mmsc,mms port, mcc,mnc]?

I don't really see why it wouldn't work on the S5, assuming it is afflicted by this same issue with MMS and WiFi. And yes that was all I put in inside of Hangouts itself.
The Following User Says Thank You to crackpot For This Useful Post: [ View ] Gift crackpot Ad-Free
8th November 2014, 12:39 AM |#11  
Member
Thanks Meter: 3
 
More
Will give it a try, thanks
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes