FORUMS
Remove All Ads from XDA

[Q] 5Ghz wifi very unstable

592 posts
Thanks Meter: 9
 
By rockuman_ex, Senior Member on 21st November 2014, 05:14 AM
Post Reply Email Thread
Just got my N910G (AUS), and I found the wifi is VERY unstable when it is connected to 5Ghz band, but stable on 2.4Ghz.

Tried it on 2 different modems/routers, same.

Never had any problem with my other phones connecting to 5Ghz (M7, Z2).

Any idea?

The phone is stock, non-rooted.
 
 
21st November 2014, 07:16 AM |#2  
henklbr's Avatar
Senior Member
Flag Netherlands
Thanks Meter: 2,193
 
More
Router: Linksys Smart Wi-Fi EA6500 | firmware: 1.1.29.162351
Country: Netherlands
ISP: ZIGGO



Left: 2.4 GHz
Right: 5 GHz
21st November 2014, 08:04 AM |#3  
OP Senior Member
Thanks Meter: 9
 
More
Quote:
Originally Posted by henklbr

Router: Linksys Smart Wi-Fi EA6500 | firmware: 1.1.29.162351
Country: Netherlands
ISP: ZIGGO



Left: 2.4 GHz
Right: 5 GHz

I'm not saying I get poor speed, I'm saying my connection is unstable (lots of disconnections).
Speed is fine.
21st November 2014, 08:22 AM |#4  
Ausboy 2011's Avatar
Senior Member
Thanks Meter: 493
 
More
Factory reset or try latest update/ odin flash latest fw.
21st November 2014, 11:39 AM |#5  
Senior Member
Thanks Meter: 174
 
More
You might also fiddle around with which channel your router is set to for the 5ghz band. Turn off the smart network switching too.
21st November 2014, 01:05 PM |#6  
iridaki's Avatar
Retired Forum Moderator / Recognized Themer
Flag Edinburgh, Scotland
Thanks Meter: 5,211
 
Donate to Me
More
Quote:
Originally Posted by Ausboy 2011

Factory reset or try latest update/ odin flash latest fw.

Factory reset is not a solution to every little problem. In fact, it's not a solution at all. If you don't find out what's wrong, you could hard reset your phone, set it up from scratch and still be faced with the same issue.

Sent from my SM-P600 using Tapatalk
21st November 2014, 02:14 PM |#7  
OP Senior Member
Thanks Meter: 9
 
More
Quote:
Originally Posted by Ausboy 2011

Factory reset or try latest update/ odin flash latest fw.

It's a new phone with the latest firmware, i dont think factory reset going to help

Quote:
Originally Posted by rcobourn

You might also fiddle around with which channel your router is set to for the 5ghz band. Turn off the smart network switching too.

Smart network switching is already turned off. Tried different channels, same results

Quote:
Originally Posted by iridaki

Factory reset is not a solution to every little problem. In fact, it's not a solution at all. If you don't find out what's wrong, you could hard reset your phone, set it up from scratch and still be faced with the same issue.

Sent from my SM-P600 using Tapatalk

Agree
21st November 2014, 02:17 PM |#8  
OP Senior Member
Thanks Meter: 9
 
More
Quote:

1. Go to dial keypad and press *#0011#
2. Press menu key and press WiFi option
3. Turn Wifi Power Save Mode off

Did this and no dropout so far!

10th December 2016, 02:38 AM |#9  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by rockuman_ex

Did this and no dropout so far!

Just change the 5ghz wifi channel to that which is obviously suitable for all your devices. Also had this issue but my PC was able to connect to both 5ghz channel on my 2 dual band routers while the phablet won't. I fiddled and discovered the lower channels worked perfectly
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes