FORUMS
Remove All Ads from XDA

[Audio mod] [V2] Viper4Android [Nougat]

485 posts
Thanks Meter: 809
 
By CrsMthw, Senior Member on 12th February 2017, 09:34 PM
Post Reply Email Thread
24th October 2017, 08:03 AM |#41  
Junior Member
Thanks Meter: 0
 
More
thank you
 
 
15th November 2017, 09:18 AM |#42  
Junior Member
Thanks Meter: 0
 
More
Hello CrsMthw,
I tried to install viper4android with your method on my SM-920C Note 5 - ROM Nougat NN9 (Android v7.0) but the driver seems not working.
So I tried to uninstall them via the app menu and reboot system but when I open the app again v4a doesn't prompt me to install the drivers, they seems installed but not working.
I've Magisk v14 installed.
Any suggestion? Ty in advance

-edit-

nevermind, I managed to get it working, my kernel was set to "enforced", setting it to "permissive" did the trick
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20171115-100416.png
Views:	324
Size:	106.8 KB
ID:	4332940   Click image for larger version

Name:	Screenshot_20171115-100431.jpg
Views:	320
Size:	103.8 KB
ID:	4332941  
15th November 2017, 02:17 PM |#43  
Senior Member
Flag Bangalore
Thanks Meter: 77
 
More
Quote:
Originally Posted by Gianluca89


nevermind, I managed to get it working, my kernel was set to "enforced", setting it to "permissive" did the trick

Can you share how you set the kernel to permissive?
15th November 2017, 03:38 PM |#44  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by vishnu8058

Can you share how you set the kernel to permissive?

flashed the permissive stock Kernel from the NougatNN thread: https://forum.xda-developers.com/sho...07&postcount=2
LDkernel-Nougat-N920X-Pure-Stock.zip

this kernel come with SuperSU so I've removed it from the settings of the app (restoring the stock boot.img) then I've flashed this script to be sure SuperSu is fully removed, after this I've installed via recovery Magisk Beta v14.3.
4th February 2018, 01:33 PM |#45  
Junior Member
Thanks Meter: 3
 
More
HELP PLS
I'ts not working on my note 5 + i cant remove it.
can you please instruct how can i completely uninstall it from the device...?
Thank you!



Quote:
Originally Posted by CrsMthw

Hey guys!! so earlier I have come up with Dolby Atmos mod for Samsung Nougat devices, but it still bugged me that Viper4Android was not working!! So after countless hours of brainstorming, I finally got viper4android to work on Nougat!!
So here you go!! Also works with my Dolby Atmos!

Tested devices:
- S6 edge+
- Note 5

Screenshot:



Requirements:
- Samsung device
- Nougat rom (N-lite V3 rom users, please wait for V4 rom. Pre-installed busybox on V3 interferes with viper driver installation)
- Rooted by Magisk (Dolby does not need root. Only viper needs root by magisk)

Installation instructions:
- Flash attached viper zip file and UPDATE zip file in TWRP. Users already using this mod, please see update instructions below.
- Reboot
- Install Busybox by Meefik here - https://play.google.com/store/apps/d....busybox&hl=en
- Open Viper4android app and install drivers if it prompts.
- Enjoy!! Flash DolbyAtmos zip if you want

Update instructions:
- Uninstall Viper4android drivers from the menu in Viper4android app.
- Flash the update zip.

DolbyAtmos thread here: https://forum.xda-developers.com/s6-...atmos-t3553494

Download Mirror:
MEGA - Main zip
MEGA - Update zip

Thanks and Credits:
- @CaptainTiiti for the countless hours of support and guidance and motivation, without him, this project would have never made it here
- @topjohnwu for the magisk stuff
- The developers behind Viper4Android
- @worstenbrood for the original dolby atmos mod
- @gtaelbordo for the kindness and support, and for the icons of DolbyAtmos


Hope you like it. Leave a Thanks if you do.
Also join me on telegram chat at https://t.me/su_community
See you soon!

30th March 2019, 05:28 AM |#46  
Junior Member
Flag Guatemala
Thanks Meter: 3
 
More
Working fine note 5
26th April 2019, 04:16 AM |#47  
duytruong01's Avatar
Junior Member
Thanks Meter: 6
 
More
Great Work
Post Reply Subscribe to Thread

Tags
audio mod, nougat, samsung, v4a, viper4android

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes