FORUMS
Remove All Ads from XDA

[NX563J+NX595J][Project Treble][Android 8.X-9.X][GSI][A-only][1.5]

483 posts
Thanks Meter: 4,439
 
By NFound, Senior Member on 2nd September 2018, 04:41 PM
Post Reply Email Thread
Hi friends

Project Treble on Nubia Z17 Series

Requirements:
Installed TWRP 3.2.3-X

Installation:
1. Flashing the Project-Treble-NXxXxJ-XX
(when finished, the script will automatically reload you in the recovery)
2. Flash any GSI image from the profile topic
3. Reboot and enjoy!

Installation instructions: video instruction


Download

All successful flashing!

Thanks:
- Mokee team fo the base
The Following 12 Users Say Thank You to NFound For This Useful Post: [ View ] Gift NFound Ad-Free
 
 
2nd September 2018, 09:30 PM |#2  
Senior Member
Thanks Meter: 61
 
More
Quote:
Originally Posted by NFound

Hi friends

Project Treble on Nubia Z17S

Requirements:
Installed TWRP 3.2.3-X

Installation:
1. Flashing the Project-Treble-NX595-v1.0
(when finished, the script will automatically reload you in the recovery)
2. Flash any GSI image from the profile topic
Note: for Android 9.x we also add patches (if required) and in TWRP 3.2.3-3 go to Reboot and press Signer
3. Reboot and enjoy!

Note2: DT2W, autobrightness, power profile and other already included!
Android 8.x bugs: not found at this time
Bugs Android 9.x: does not work NFC (in the process of elimination)

Download

All successful firmware!

PS I'm used Havoc OS GSI, all work

Thanks:
- Mokee team fo the base

Is that a vendor image for z17s ?
It makes me wonder cause it is round about 185mb my mokee vendor (403mb installed) is not able to got nfc function too on most gsis i searched and searched but no luck and auto brightness also not work i see some workaround but that not worked for me it says read only vendor partition but can that be solved with your new recovery and the install procedure you wrote by pressing signer also for nx563j? That would be fine
Wait i test by myself ....
3rd September 2018, 07:54 AM |#3  
NFound's Avatar
OP Senior Member
Flag Yekaterinburg
Thanks Meter: 4,439
 
Donate to Me
More
In OP added video instruction: https://www.youtube.com/watch?v=eOk_IVl4E0s
3rd September 2018, 08:09 AM |#4  
Topogigi's Avatar
Senior Member
Flag Turin
Thanks Meter: 1,525
 
More
Quote:
Originally Posted by aljoscha81

Is that a vendor image for z17s ?
It makes me wonder cause it is round about 185mb my mokee vendor (403mb installed) is not able to got nfc function too on most gsis i searched and searched but no luck and auto brightness also not work i see some workaround but that not worked for me it says read only vendor partition but can that be solved with your new recovery and the install procedure you wrote by pressing signer also for nx563j? That would be fine
Wait i test by myself ....

For nx563j: Auto brightness works with these instructions:

https://forum.xda-developers.com/pro...ptive-t3741965

Remember to remount /vendor in RW mode before applying the terminal command with:

mount -o remount,rw /vendor
3rd September 2018, 06:02 PM |#5  
Senior Member
Thanks Meter: 61
 
More
Quote:
Originally Posted by Topogigi

For nx563j: Auto brightness works with these instructions:

https://forum.xda-developers.com/pro...ptive-t3741965

Remember to remount /vendor in RW mode before applying the terminal command with:

mount -o remount,rw /vendor

I lost led light for buttons on my device by the mod is there a way to activate again?
3rd September 2018, 11:04 PM |#6  
Senior Member
Flag La Coruña, Spain
Thanks Meter: 212
 
Donate to Me
More
Quote:
Originally Posted by aljoscha81

I lost led light for buttons on my device by the mod is there a way to activate again?

Was it working before? I flashed Mokee first and after that, full wipe and I flashed GSI, but the led buttons never worked
4th September 2018, 12:07 AM |#7  
Senior Member
Thanks Meter: 26
 
More
MTP not working. I think it's a common pie issue.
4th September 2018, 07:17 AM |#8  
NFound's Avatar
OP Senior Member
Flag Yekaterinburg
Thanks Meter: 4,439
 
Donate to Me
More
In OP added .zip for NX563J
The Following 2 Users Say Thank You to NFound For This Useful Post: [ View ] Gift NFound Ad-Free
4th September 2018, 03:04 PM |#9  
Junior Member
Thanks Meter: 0
 
More
Fingerprint on GSI Roms
For NX563J is fingerprint working on any GSI Rom?
4th September 2018, 06:00 PM |#10  
Topogigi's Avatar
Senior Member
Flag Turin
Thanks Meter: 1,525
 
More
Quote:
Originally Posted by aljoscha81

I lost led light for buttons on my device by the mod is there a way to activate again?

I have my leds working. I flashed this overlay:

https://forum.xda-developers.com/sho...0&postcount=38

Ambient Display is not working, but leds are there.

I will try the new Project Treble Vendor Image for nx563j in OP and report in a while.

---------- Post added at 06:28 PM ---------- Previous post was at 06:26 PM ----------

Quote:
Originally Posted by sippi90

For NX563J is fingerprint working on any GSI Rom?

AFAIK, yes

---------- Post added at 07:00 PM ---------- Previous post was at 06:28 PM ----------

Ok, I gave new NX563J Treble image a try.

Pros:
DT2W works out of the box
Auto brightness works out of the box (was working with patch with mokee vendor/boot images)
Cons:
Camera not working (was working well with mokee vendor/boot images)
Face Unlock not working (it wasn't working with mokee vendor/boot images too)
WIFI Hotspot not working (it wasn't working with mokee vendor/boot images too)
MTP for file transfer not working (it wasn't working with mokee vendor/boot images too)
Battery Stats for applications not working (it wasn't working with mokee vendor/boot images too)

For me, Camera is a deal breaker: back to Mokee vendor/boot images for the moment....

One more note: Installing the zip file causes the Recovery to reboot. Had to extract and flash vendor and boot images manually and flash them individually....
4th September 2018, 07:20 PM |#11  
Junior Member
Thanks Meter: 2
 
More
Hi, I'm using an NX563J and I have a problem.

I did everything you said:
1- Installed TWRP 3.2.3-3
2- Flash the Project-Treble-NX563J-v1.0
3- Flash HavocP-arm64_aonly_vanilla_nosu-0830
After that I reboot and the it get stucked when it sais "android", and never start.

Did I make a mistake? What can I do now?
Regards!
The Following User Says Thank You to Gonzalo.90 For This Useful Post: [ View ] Gift Gonzalo.90 Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes