FORUMS

No fastboot devices but can use adb devices.

2 posts
Thanks Meter: 0
 
By CallumL701, Junior Member on 22nd October 2016, 12:49 AM
Post Reply Email Thread
Hey, I am having trouble pushing TWRP onto my op3 via fastboot. I managed to unlock my bootloader successfully but after that, I know cannot flash TWRP. When I type in "adb devices" It returns a string, however "fastboot devices" does nothing. I've uninstalled and re-installed oneplus usb, fastboot and adb drivers countless time and even reset my PC twice. Any ideas? This is really frustrating as I was on TWRP fine before I had to RMA my op3 where they put it back to stock. Any ideas? Thanks
22nd October 2016, 01:03 AM |#2  
Senior Member
Thanks Meter: 319
 
More
I have the same problem ADB works but Fastboot not.... I have all drivers correct installed..

Rom: OOS 3.2.7
PC: Windows 10

Gesendet von meinem ONEPLUS A3003 mit Tapatalk
22nd October 2016, 11:15 AM |#3  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by ELoTRIX

I have the same problem ADB works but Fastboot not.... I have all drivers correct installed..

Rom: OOS 3.2.7
PC: Windows 10

Gesendet von meinem ONEPLUS A3003 mit Tapatalk

Yeah me too, same ROM and PC OS. Very strange
22nd October 2016, 01:22 PM |#4  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by CallumL701

Yeah me too, same ROM and PC OS. Very strange

Got the same problem too, after unlocking the bootloader the fastboot devices cannot find anything
Tested several drivers and even another laptop :/

Rom: OOS 3.2.7
PC: Windows 10
22nd October 2016, 01:35 PM |#5  
null0seven's Avatar
Senior Member
Flag Iasi
Thanks Meter: 1,183
 
More
But phone starts ok in OOS system?
If, yes, download TWRP 3.0.2.1 original & TWRP 3.0.2.1-19 modified. Put them in phone sd card. Download FLashify from Play store and flash recovery .img. Then go recovery to test if it works.
One of those will work.
22nd October 2016, 02:29 PM |#6  
Senior Member
Thanks Meter: 319
 
More
Quote:
Originally Posted by inflames19

Got the same problem too, after unlocking the bootloader the fastboot devices cannot find anything
Tested several drivers and even another laptop :/

Rom: OOS 3.2.7
PC: Windows 10

Quote:
Originally Posted by CallumL701

Yeah me too, same ROM and PC OS. Very strange

I've solved that problem by installing Windows 7 on a Virtual Machine the phone Was recognized and has installed the drivers by itself. And fastboot was working
I don't know why fastboot is not working on Windows 10....
The Following 3 Users Say Thank You to Mar-cel For This Useful Post: [ View ] Gift Mar-cel Ad-Free
22nd October 2016, 02:37 PM |#7  
Junior Member
Thanks Meter: 1
 
More
Thanks for the different solutions, I'll try it for myself.
But I'm still wondering why the unlock worked because there it used fastboot too
22nd October 2016, 03:13 PM |#8  
Sir Mohd's Avatar
Senior Member
Flag Riyadh
Thanks Meter: 25
 
More
1
me too its says : Witting for devices !!!


Rom: OOS 3.2.7
PC: Windows 10
22nd October 2016, 03:38 PM |#9  
rpsgrayfox's Avatar
Member
Thanks Meter: 78
 
More
Quote:
Originally Posted by CallumL701

Hey, I am having trouble pushing TWRP onto my op3 via fastboot. I managed to unlock my bootloader successfully but after that, I know cannot flash TWRP. When I type in "adb devices" It returns a string, however "fastboot devices" does nothing. I've uninstalled and re-installed oneplus usb, fastboot and adb drivers countless time and even reset my PC twice. Any ideas? This is really frustrating as I was on TWRP fine before I had to RMA my op3 where they put it back to stock. Any ideas? Thanks

Had the same issue, here's what fixed it for me:
(On Windows 10)
1 - Plug your device while on and install the OP3 drivers that appear as a removable disk, I reinstalled them also, so no harm in doing that again.
2 - Run admin command prompt from wherever you have your adb and fastboot
3 - get your device into fastboot/bootloader mode "adb reboot bootloader"
4 - press windows key + X and go to device manager, look for the Android device with exclamation mark
5 - right click on Android Device > update driver software > browse my computer... > let me pick... > look for Android and then select Android Fastboot Interface if memory serves me right.

And that's it. Fastboot should be recognized now. That's what worked for me when windows recognized adb but not fastboot, hope it helps out.

Remember to hit the thanks button if I helped you out.
The Following 8 Users Say Thank You to rpsgrayfox For This Useful Post: [ View ] Gift rpsgrayfox Ad-Free
22nd October 2016, 05:08 PM |#10  
Sir Mohd's Avatar
Senior Member
Flag Riyadh
Thanks Meter: 25
 
More
1
Quote:
Originally Posted by rpsgrayfox

Had the same issue, here's what fixed it for me:
(On Windows 10)
1 - Plug your device while on and install the OP3 drivers that appear as a removable disk, I reinstalled them also, so no harm in doing that again.
2 - Run admin command prompt from wherever you have your adb and fastboot
3 - get your device into fastboot/bootloader mode "adb reboot bootloader"
4 - press windows key + X and go to device manager, look for the Android device with exclamation mark
5 - right click on Android Device > update driver software > browse my computer... > let me pick... > look for Android and then select Android Fastboot Interface if memory serves me right.

And that's it. Fastboot should be recognized now. That's what worked for me when windows recognized adb but not fastboot, hope it helps out.

Remember to hit the thanks button if I helped you out.

I've done everything U said but when it on the Bootloader it says waiting for device

Thank you to try solve the problem
22nd October 2016, 05:15 PM |#11  
superiscch's Avatar
Senior Member
Flag Oostende
Thanks Meter: 397
 
More
Since there are a lot of people complaining I think the problem is bigger than we think :/ My OP3 nor OPO are seen
The Following User Says Thank You to superiscch For This Useful Post: [ View ] Gift superiscch Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes