The OnePlus 6 is officially on sale! Buy now →
FORUMS
Remove All Ads from XDA
OnePlus 6 On Sale

[KERNEL][OP3T] FrancoKernel - r40 - OxygenOS Oreo - r40 - LineageOS 15.1 roms

23,375 posts
Thanks Meter: 128,800
 
Post Reply Email Thread
16th May 2018, 06:18 AM |#4221  
Senior Member
Flag Kuala Lumpur
Thanks Meter: 848
 
More
Hmm.... Just migrated over from EX.... Running on LOS 15.1

Noticed that when i am charging it just says Charging..... With low/ex/caesium that i tried it says Charging Rapidly

Am i missing something? Can't seem to find something that points to the right direction.... TIA
 
 
16th May 2018, 05:32 PM |#4222  
gFknQ's Avatar
Senior Member
Thanks Meter: 407
 
More
Quote:
Originally Posted by chewdaniel

Hmm.... Just migrated over from EX.... Running on LOS 15.1

Noticed that when i am charging it just says Charging..... With low/ex/caesium that i tried it says Charging Rapidly

Am i missing something? Can't seem to find something that points to the right direction.... TIA

Deleted. Sorry not meant to your post

Sent from my OnePlus3T using XDA Labs

---------- Post added at 05:32 PM ---------- Previous post was at 05:30 PM ----------

Can you please add backlight dimmer back to the kernel. It is not applying from Franco kernel manager and there is no difference with battery life labs. And option not there at all in other kernel managers. @franciscofranco

Sent from my OnePlus3T using XDA Labs
18th May 2018, 12:19 PM |#4224  
Junior Member
Thanks Meter: 0
 
More
CPU settings never presist
Even when i use per app profile to clock my clusters to more than 1440(big) and 1280(little)
They always come back whenever i even start a game otherwise they always stay about what i set them to.
18th May 2018, 01:36 PM |#4225  
Paschfire's Avatar
Senior Member
Flag Ottawa
Thanks Meter: 531
 
Donate to Me
More
Quote:
Originally Posted by Sunny.gokug

Even when i use per app profile to clock my clusters to more than 1440(big) and 1280(little)
They always come back whenever i even start a game otherwise they always stay about what i set them to.

Device?
Rom - OOS/Beta/other?
Other modifications you're flashed?
Root?
FK version?
Are you using FK manager app? Other? Version?

Any useful information regarding your device and setup?

Providing a proper detailed explanation of the issue, even steps on how to reduce the issue would be very helpful.

You'd do yourself a favor doing some research on how to create a proper bug report, it goes along way when requesting for help.

Sent from my OnePlus 3T using XDA Labs
The Following User Says Thank You to Paschfire For This Useful Post: [ View ] Gift Paschfire Ad-Free
18th May 2018, 02:00 PM |#4226  
Senior Member
Thanks Meter: 5,028
 
Donate to Me
More
Quote:
Originally Posted by Sunny.gokug

Even when i use per app profile to clock my clusters to more than 1440(big) and 1280(little)
They always come back whenever i even start a game otherwise they always stay about what i set them to.

Nothing the kernel can do about, because qcom's perfd is chief in charge for cpu freqs.

Recently, I tried to allow the sd821 soc to use all freqs of LITTLE (perfd is always resetting the 2188800 MHz to 1593xxx MHz). This dirty hack allowed me to unleash the 2188800 MHz:

https://github.com/nvertigo/android_...0c6ac9b95357ce
https://github.com/nvertigo/android_...c21420f135d934

Basically you write your upper freq limits to /sys/module/msm_performance/parameters/cpu_max_freq and remove all write bits from that file.

If rooted you can easily do that on the command line (remember to use echo with redirection instead of write) to check, if it works for your values as well. If it's working you need to modify your bootimage or try to utilize init.d or /data/local/userinit.sh (if supported by your rom).

This is no kernel or kernelmanager app issue.

@franciscofranco: I don't know your keenelmanager, but I guess you write the new max value to scaling_max_freq. Sadly this is always rewritten when libqti-perfd.so write to /sys/module/msm_performance/parameters/cpu_max_freq. This is hardcoded in the shared lib:
Code:
ingo@adler /usr/local/src/oxygenos $ strings system/vendor/lib*/libqti-perfd.so |grep 1593
0:1593600 1:1593600 2:2342400 3:2342400
0:1593600 1:1593600 2:2342400 3:2342400
ingo@adler /usr/local/src/oxygenos $
Perhaps it is possible in your app to make /sys/module/msm_performance/parameters/cpu_max_freq writable write the new max to it and drop the write permission again.
19th May 2018, 08:12 AM |#4227  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Paschfire

Device?
Rom - OOS/Beta/other?
Other modifications you're flashed?
Root?
FK version?
Are you using FK manager app? Other? Version?

Any useful information regarding your device and setup?

Providing a proper detailed explanation of the issue, even steps on how to reduce the issue would be very helpful.

You'd do yourself a favor doing some research on how to create a proper bug report, it goes along way when requesting for help.

Sent from my OnePlus 3T using XDA Labs

Im on oneplus 3t Zunleashed 8.1 with fK 40 (magisk+twrp+unencrypted) and i even tried elemental x recently to get this (kind of) issue, because all i need this is for gaming and better fps but i dont see maximum output with even the highest settings it all gets set back to 1200/1440 on both cpu group.
And for starters im not a professional here, just a person with good reading and following steps in details.
20th May 2018, 08:40 AM |#4228  
omair2005's Avatar
Senior Member
Thanks Meter: 743
 
More
Quote:
Originally Posted by Sunny.gokug

Im on oneplus 3t Zunleashed 8.1 with fK 40 (magisk+twrp+unencrypted) and i even tried elemental x recently to get this (kind of) issue, because all i need this is for gaming and better fps but i dont see maximum output with even the highest settings it all gets set back to 1200/1440 on both cpu group.
And for starters im not a professional here, just a person with good reading and following steps in details.

Isn't that rom outdated? Try updating to havoc and flashing r40
The Following User Says Thank You to omair2005 For This Useful Post: [ View ] Gift omair2005 Ad-Free
21st May 2018, 11:20 PM |#4229  
Haidary.T's Avatar
Senior Member
Flag Montreal in Canada
Thanks Meter: 111
 
More
On the latest LineageOS 15.1 (March 21) I can't change the accent color under Display/Advanced/Style/Accent Colour. It crashes settings everytime I try to do so. I have tried reflashing the ROM without Franco kernel and it worked fine. As soon as I flashed the kernel again, it stops working. I have not flashed anything external other than this kernel. I tried searching the thread and I couldn't find anything. Thanks!
Yesterday, 04:48 AM |#4230  
VincentJoshuaET's Avatar
Senior Member
Flag Angat
Thanks Meter: 280
 
More
https://review.lineageos.org/#/c/215210

Can you merge this open commit? I'm using an unofficial build that includes the alert slider vibration commits. Thanks.
The Following User Says Thank You to VincentJoshuaET For This Useful Post: [ View ] Gift VincentJoshuaET Ad-Free
Yesterday, 04:56 AM |#4231  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Paschfire

Device?
Rom - OOS/Beta/other?
Other modifications you're flashed?
Root?
FK version?
Are you using FK manager app? Other? Version?

Any useful information regarding your device and setup?

Providing a proper detailed explanation of the issue, even steps on how to reduce the issue would be very helpful.

You'd do yourself a favor doing some research on how to create a proper bug report, it goes along way when requesting for help.

Sent from my OnePlus 3T using XDA Labs

Quote:
Originally Posted by omair2005

Isn't that rom outdated? Try updating to havoc and flashing r40

Im not sure about havoc os yet and my issue was with cpu clocks, which i even tried to get done with oxygen os too. If that cant be done any simple way, then i might give up and settle with what i have then.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes