FORUMS
Remove All Ads from XDA

TWRP stuck on splash screen?

474 posts
Thanks Meter: 55
 
By otto888, Senior Member on 19th January 2017, 12:13 PM
Post Reply Email Thread
I just got my 3T, flashed TWRP, flashed the new OOS Beta 2 build, and changed my 3T's splash image. Now out of nowhere, TWRP will get stuck in its logo. I didn't flash anything the last time it worked, it just randomly stopped working after a backup. I've gave it a few minutes, tried older/newer versions, and deleting the .twrps file on the internal storage. Does anyone know what's going on and how to fix it, preferably without wiping data?

Edit: I can boot into OOS just fine and everything but TWRP works.
19th January 2017, 12:31 PM |#2  
Senior Member
Flag Victoria BC
Thanks Meter: 44
 
More
Just fastboot flash the lastest twrp https://forum.xda-developers.com/one...us-3t-t3507308
19th January 2017, 12:48 PM |#3  
Junior Member
Flag Dresden
Thanks Meter: 7
 
More
I had the same problem a few hours ago...
I flashed the latest TWRP and then booted it via fastboot (fastboot boot twrp-3.0.3-1-oneplus3t.img.).
I waited 1-2 minutes, rebooted it into TWRP again (this time not via fastboot but with the buttons of the phone). After a few minutes I finally saw the usual TWRP UI.
I don't know why or how, but it worked.
The Following 3 Users Say Thank You to mximer For This Useful Post: [ View ] Gift mximer Ad-Free
19th January 2017, 02:51 PM |#4  
Jo_Jo_2000's Avatar
Member
Thanks Meter: 47
 
More
It also takes a long time for me here..
19th January 2017, 10:49 PM |#5  
OP Senior Member
Flag Alabama
Thanks Meter: 55
 
More
Quote:
Originally Posted by mximer

I had the same problem a few hours ago...
I flashed the latest TWRP and then booted it via fastboot (fastboot boot twrp-3.0.3-1-oneplus3t.img.).
I waited 1-2 minutes, rebooted it into TWRP again (this time not via fastboot but with the buttons of the phone). After a few minutes I finally saw the usual TWRP UI.
I don't know why or how, but it worked.

Thanks. I had to wait about 6 minutes, but it worked.
20th January 2017, 11:37 PM |#6  
Senior Member
Flag Helsinki
Thanks Meter: 765
 
More
I have similar problem but for me just get black screen with only notification led on... I have tried everything (reflash, dm verity zip, swap zip, f2fs version etc.) but nothing work. Im using RR rom, EXT4, decrypted. Only way to boot recovery is "fastboot boot twrp.img"
The Following User Says Thank You to zige For This Useful Post: [ View ] Gift zige Ad-Free
21st January 2017, 09:02 AM |#7  
amuzavali's Avatar
Senior Member
Flag Produlesti
Thanks Meter: 59
 
More
Quote:
Originally Posted by zige

I have similar problem but for me just get black screen with only notification led on... I have tried everything (reflash, dm verity zip, swap zip, f2fs version etc.) but nothing work. Im using RR rom, EXT4, decrypted. Only way to boot recovery is "fastboot boot twrp.img"

Me to

Trimis de pe al meu ONEPLUS A3003 folosind Tapatalk
21st January 2017, 09:22 AM |#8  
Member
Flag Bangalore
Thanks Meter: 3
 
More
Same thing happened with me. Followed the usual "flash recovery" and "boot" approach. Got stuck at splash forever.

Removed the USB cable, turned off the phone. Started the phone with "Volume Down+Power" combination and it booted in recovery after a few minutes of the splash screen.
21st January 2017, 11:15 AM |#9  
pitrus-'s Avatar
Senior Member
Thanks Meter: 443
 
More
Remember that it takes a while to boot up TWRP if you're using f2fs, the more files on the data partitions the longer it takes.
21st January 2017, 02:09 PM |#10  
Quote:
Originally Posted by pitrus-

Remember that it takes a while to boot up TWRP if you're using f2fs, the more files on the data partitions the longer it takes.

true ! kernel source been released hopefully some one makes an advance stock kernel.
The Following 3 Users Say Thank You to Arrowblue For This Useful Post: [ View ] Gift Arrowblue Ad-Free
21st January 2017, 05:41 PM |#11  
Senior Member
Thanks Meter: 96
 
More
I had the same problem recently, I found a solution on a reddit post somewhere;
Basically in terminal/CMD in fastboot mode wipe cache and userdata then reboot to recovery.

Code:
fastboot format cache
fastboot format userdata
Worked for me.
Disclaimer; Data will be lost!

Edit: found OP https://www.reddit.com/r/Nexus6P/com...splash_screen/
The Following 3 Users Say Thank You to bowlandspoon For This Useful Post: [ View ] Gift bowlandspoon Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes