FORUMS
Remove All Ads from XDA
OnePlus 6 Development Program

[KERNEL][OP5] FrancoKernel ⚡️- r31 - 19th June - Oreo & custom roms

23,457 posts
Thanks Meter: 129,307
 
Post Reply Email Thread
10th July 2018, 03:03 AM |#1781  
pycxe-01's Avatar
Member
Flag Oulu
Thanks Meter: 27
 
More
Quote:
Originally Posted by digger16309

One reason I thought it was the Kernel was because the device got very hot spending 2 minutes getting a very weak GPS lock. It was as if the device couldn't access all of the necessary CPU/GPU power to get a lock. I made several edits to my gps.conf file and set r31 to balanced, with no other Kernel changes and I have GPS back. After more testing I'll be able to determine if it was the file, the kernel, or combination of both.

Yes, my GPS & Location settings turned out to be a bit glitchy too! At least I used to get much better location results on OxygenOS before! Were you able to pinpoint your GPS issue?
 
 
10th July 2018, 05:20 AM |#1782  
Senior Member
Thanks Meter: 74
 
More
I am using OOS 5.1.3. and I noticed that after updating to r31, when I disconnect my wifi my mobile data(3G) doesn't turn ON. Even when I manually turn it OFF and ON, it doesn't turn ON. I need to turn on Airplane mode wait for 10 second and then turn it off and wait another 10 second to get Mobile data back. It also happens sporadically.

I know that it can be a coincidence. Is it happening because of the kernel update? I don't fiddle at all with FK manager other than Display lower max brightness. On Magisk side I only have V4Android.
Is there a way to fix this without clean installing the ROM?
10th July 2018, 06:11 AM |#1783  
ulxerker's Avatar
Senior Member
Thanks Meter: 774
 
More
Quote:
Originally Posted by pleomaxell

I am using OOS 5.1.3. and I noticed that after updating to r31, when I disconnect my wifi my mobile data(3G) doesn't turn ON. Even when I manually turn it OFF and ON, it doesn't turn ON. I need to turn on Airplane mode wait for 10 second and then turn it off and wait another 10 second to get Mobile data back. It also happens sporadically.

I know that it can be a coincidence. Is it happening because of the kernel update? I don't fiddle at all with FK manager other than Display lower max brightness. On Magisk side I only have V4Android.
Is there a way to fix this without clean installing the ROM?

This is no related to the kernel as I never had that issue. Are you running xposed or some kind of battery optimization apps? If so, try without them.
10th July 2018, 06:41 AM |#1784  
Cichy26's Avatar
Senior Member
Thanks Meter: 28
 
More
Quote:
Originally Posted by pleomaxell

I am using OOS 5.1.3. and I noticed that after updating to r31, when I disconnect my wifi my mobile data(3G) doesn't turn ON. Even when I manually turn it OFF and ON, it doesn't turn ON. I need to turn on Airplane mode wait for 10 second and then turn it off and wait another 10 second to get Mobile data back. It also happens sporadically.

This is not issue of any custom kernel. Here is big topic about it:
https://forum.xda-developers.com/one...3658071/page40
10th July 2018, 10:49 AM |#1785  
digger16309's Avatar
Senior Member
Thanks Meter: 42
 
More
Quote:
Originally Posted by pycxe-01

Yes, my GPS & Location settings turned out to be a bit glitchy too! At least I used to get much better location results on OxygenOS before! Were you able to pinpoint your GPS issue?

I believe so. The gps.conf file is borked in LOS. It looks to be the OnePlus version, but may be a mish-mash.

I posted a guide to fixing the problem here.
11th July 2018, 03:31 PM |#1786  
Senior Member
Thanks Meter: 74
 
More
Quote:
Originally Posted by ulxerker

This is no related to the kernel as I never had that issue. Are you running xposed or some kind of battery optimization apps? If so, try without them.

I don't have any battery optimization app. I bought the OP5 on July 2017 and this is the first time I am facing this problem.
11th July 2018, 08:44 PM |#1787  
digger16309's Avatar
Senior Member
Thanks Meter: 42
 
More
I turned up vibration to 100 in the Kernel settings but that is as high as I can go. The vibration (on LOS 15.1) is still very low. Is there any way to increase this beyond setting it at 100?
13th July 2018, 11:20 AM |#1788  
Junior Member
Thanks Meter: 1
 
More
Any updates on the Franco kernel update for the treble compatible update OB13?
The Following User Says Thank You to FeoRache For This Useful Post: [ View ] Gift FeoRache Ad-Free
13th July 2018, 12:09 PM |#1789  
Senior Member
Thanks Meter: 100
 
More
Quote:
Originally Posted by FeoRache

Any updates on the Franco kernel update for the treble compatible update OB13?

He does stable build only I guess
13th July 2018, 04:32 PM |#1790  
onliner's Avatar
Senior Member
Flag Queens
Thanks Meter: 520
 
More
Quote:
Originally Posted by FeoRache

Any updates on the Franco kernel update for the treble compatible update OB13?

Francisco is on a honeymoon, don't expect updates soon.
14th July 2018, 02:24 AM |#1791  
Senior Member
Thanks Meter: 100
 
More
Congratulations Franco. Wishing you a happy married life
The Following 2 Users Say Thank You to sleepwalking0593 For This Useful Post: [ View ] Gift sleepwalking0593 Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes