FORUMS
Remove All Ads from XDA

Touch screen on 5T randomly stops responding

3 posts
Thanks Meter: 0
 
By gasburger, Junior Member on 9th January 2019, 11:07 AM
Post Reply Email Thread
I've been having this issue where the touchscreen on my OP 5T will be working just fine but the next second just turn unresponsive to any touch, and no amount of rebooting fixes it.

So far, I've tried using the unbricking tool and restored it to OOS 5.1.3, wiped everything off the phone and tried the latest OOS 9.0.1, and even some custom ROMs like Pixel Experience, both the official Oreo version and some unofficial Pie versions.

I even tried installing custom kernels like the blu-spark kernel and the π kernel.

But here's the thing, all of these work right after making the change but the touchscreen stops working a day later. I'm still on the fence if this is a hardware or a software issue, because (do please correct me if I am wrong) a hardware issue would be if it was totally unresponsive and not work fine after installing a new ROM/kernel, which is not the case here, leading me to assume it has to be something in the software related?
27th February 2019, 09:01 PM |#2  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by gasburger

I've been having this issue where the touchscreen on my OP 5T will be working just fine but the next second just turn unresponsive to any touch, and no amount of rebooting fixes it.

So far, I've tried using the unbricking tool and restored it to OOS 5.1.3, wiped everything off the phone and tried the latest OOS 9.0.1, and even some custom ROMs like Pixel Experience, both the official Oreo version and some unofficial Pie versions.

I even tried installing custom kernels like the blu-spark kernel and the π kernel.

But here's the thing, all of these work right after making the change but the touchscreen stops working a day later. I'm still on the fence if this is a hardware or a software issue, because (do please correct me if I am wrong) a hardware issue would be if it was totally unresponsive and not work fine after installing a new ROM/kernel, which is not the case here, leading me to assume it has to be something in the software related?

Same problem. Did you solve this problem?
27th May 2019, 11:24 PM |#3  
Junior Member
Thanks Meter: 0
 
More
Has anyone found a permanent solution to this? Or at least a reason? My op 5t also stops responding randomly to the touch. This is really bad.
20th June 2019, 02:00 PM |#4  
Member
Thanks Meter: 8
 
More
I also have this problem as well. It seems that many users have this issue. OnePlus should take a close look at it
21st June 2019, 10:10 AM |#5  
Member
Flag Shah Alam
Thanks Meter: 1
 
More
I have been having this issue for more than 6 months. The problem came after one update during android Oreo if not mistaken (Which update i can't remember)
For my phone, the screen will be unresponsive during the below occasions:
1. After rebooting the phone, touchscreen is unresponsive for up to a minute
2. When browsing pictures in gallery
3. When taking picture using portrait mode
4. When google play is updating apps
5. When google photo is backing up photos.

I am also doubting if is a hardware or software issue, because it only happened in some occasion previously for my case. Tried wipe and install stable/open beta a few times, same thing.
After the latest open beta update, it got even worst, other than the above occasions, the screen start to stop working randomly (be it watching a youtube video or using chrome), its getting annoying as i need to restart my phone a few times a day.
I saw alot of people having this issue, but has yet to raise concern of OnePlus.
30th September 2019, 06:57 AM |#6  
Member
Melbourne
Thanks Meter: 9
 
More
I've recently had the same problem, I was still running Lineage 15.1 and had not updated my firmware in months because the official builds switched to 16, then suddenly 2 weeks ago the touch screen stops responding while I was actually using it. Reboots didn't help, clearing cache and flashing lineage didn't help. In the end I somehow got it to work again by flashing the last open beta - but even then it didn't work right after flashing it, I had to leave it over night then it mysteriously started responding again in the morning.

I've just had it happen again and I have tried removing the screen protector and completely discharging the battery as some people on the oneplus forum have reported this helps, but it did not work for me. I really can't be bothered going through the whole process of re-flashing open beta then flashing back to lineage and installing all my apps an restoring my data again, but the only other option at this point is to try take it apart to check the screen is still connected to the motherboard properly....
30th September 2019, 07:47 AM |#7  
Junior Member
Thanks Meter: 1
 
More
solution
I also faced this problem, then i tried to degrade it to android oreo, and somehow i never faced touch issue, i think this is a bug in android pie,
1st October 2019, 02:16 AM |#8  
Member
Melbourne
Thanks Meter: 9
 
More
Quote:
Originally Posted by karyy

I also faced this problem, then i tried to degrade it to android oreo, and somehow i never faced touch issue, i think this is a bug in android pie,

I'm not sure about that, the first time I had the issue appear I was still running oreo, as I mentioned, I hadn't updated anything in months due to the lineage nightlies switching to Pie.... That said, certainly seems like most people who have reported it mentioned upgrading to Pie
2nd October 2019, 05:39 PM |#9  
Junior Member
Thanks Meter: 0
 
More
Facing same issue..
I have a similar issue too..
It started several months ago, when the screen used to randomly stop working, a quick hard reboot usually solved the issue.
But about a month ago, the screen stopped responding altogether and any amount of reboot did not work. So too the device to Oneplus service, there they flashed it to 9.0.7, and the screen started working again, and continued working for a few more hours, until it stopped responding again.
Tried flashing several times using the unbricking tool, but all efforts in vain.
Finally after a month or so, I bought a new phone, and today I just wanted to see if anything has changed on OP5T, and to my surprise, the touch screen started working again.
So this time I enabled USB Debugging, permanently enabled OTG, so that even if the screen stops working, I can use an external keyboard/mouse.
But OP5T is no longer my primary device, and hence I have moved on to a different manufacturer, as I saw absolutely no point in buying another Oneplus and god knows what will happen a year down the line...
8th December 2019, 12:20 PM |#10  
Junior Member
Thanks Meter: 0
 
More
Has anyone found a solution to this? I am facing the same problem with my oneplus 5T.
9th December 2019, 05:14 PM |#11  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by chandle-stick

Has anyone found a solution to this? I am facing the same problem with my oneplus 5T.

I had the problem. Had to send it back to OnePlus. They replaced the cpu under warrenty. Call 0neplus.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes