FORUMS
Remove All Ads from XDA
OnePlus 6 Development Program

Various app crashes

39 posts
Thanks Meter: 2
 
By oli356, Member on 12th June 2018, 08:11 AM
Post Reply Email Thread
Bought my 5T last week (used) and immediately I installed magisk to root and xposed. Since then though I'm facing bizarre issues that come and go.

I was unable to add a Gmail account from settings as Google play services would crash
The Facebook messenger app would crash as soon as I open it, I downloaded the lite app and its OK.

The most common issue im seeing is Instagram crashing when I try to swap accounts. I can try to swap account, the app will hang and eventually crash. I try again and it will crash. But like an hour later it will be fine...
Also clearing dalvick and cache from TWRP seems to get it to work immediately.

I've had other things crash to which is strange as on my OP2 I had no such behaviour. The phone is lightning fast but these crashes are super annoying.

Anyone have any suggestions on what I could do? Not sure if reinstalling Oxygen OS could help and what's the most efficient way to do this while getting magisk/xposed back.
 
 
14th June 2018, 08:52 AM |#2  
Senior Member
Flag karachi
Thanks Meter: 65
 
More
I have a 5T that has magisk installed. I did not install xposed yet and am not facing any if these issues. Maybe try uninstalling Xposed and cleaning cache?
14th June 2018, 09:36 AM |#3  
Aswin08's Avatar
Senior Member
Thanks Meter: 325
 
More
Quote:
Originally Posted by oli356

Bought my 5T last week (used) and immediately I installed magisk to root and xposed. Since then though I'm facing bizarre issues that come and go.

I was unable to add a Gmail account from settings as Google play services would crash
The Facebook messenger app would crash as soon as I open it, I downloaded the lite app and its OK.

The most common issue im seeing is Instagram crashing when I try to swap accounts. I can try to swap account, the app will hang and eventually crash. I try again and it will crash. But like an hour later it will be fine...
Also clearing dalvick and cache from TWRP seems to get it to work immediately.

I've had other things crash to which is strange as on my OP2 I had no such behaviour. The phone is lightning fast but these crashes are super annoying.

Anyone have any suggestions on what I could do? Not sure if reinstalling Oxygen OS could help and what's the most efficient way to do this while getting magisk/xposed back.

Should be cause of some xposed modules, elaborate the versions of magisk, xposed and the modules installed. And your oos version too. And substratum?
14th June 2018, 09:44 AM |#4  
OP Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by Aswin08

Should be cause of some xposed modules, elaborate the versions of magisk, xposed and the modules installed. And your oos version too. And substratum?

I've got xposed 90.2-beta3(systemless) installed, version 3.1.5
Android 8.1.0 - Oxygen OS 5.1.2
Magisk manager is 5.7.0 and installed version is 16.4 (though it says latest version is 16.0)

Only have 3 xposed modules actually installed.. ChromePie, SnapTools Beta and Xinsta. I could disable the xposed status for a few days and see how I get on, I assume that is enough without uninstalling it? Not sure
14th June 2018, 09:48 AM |#5  
Aswin08's Avatar
Senior Member
Thanks Meter: 325
 
More
Quote:
Originally Posted by oli356

I've got xposed 90.2-beta3(systemless) installed, version 3.1.5
Android 8.1.0 - Oxygen OS 5.1.2
Magisk manager is 5.7.0 and installed version is 16.4 (though it says latest version is 16.0)

Only have 3 xposed modules actually installed.. ChromePie, SnapTools Beta and Xinsta. I could disable the xposed status for a few days and see how I get on, I assume that is enough without uninstalling it? Not sure

There should not be issue with things what you have mentioned above. These modules too are app specific, and what about substratum and magisk modules?
14th June 2018, 09:51 AM |#6  
OP Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by Aswin08

There should not be issue with things what you have mentioned above. These modules too are app specific, and what about substratum and magisk modules?

yeah exactly, like I uninstalled xinsta but it didn't stop it crashing (sometimes) when switching accounts... Even Magisk just crashed a minute ago as soon as I opened it to get the version, it was fine when I re-opened it.

Substratum I've never heard of before
Magisk modules all I have is Xposed framework and Youtube Vanced
14th June 2018, 10:34 AM |#7  
Aswin08's Avatar
Senior Member
Thanks Meter: 325
 
More
Quote:
Originally Posted by oli356

yeah exactly, like I uninstalled xinsta but it didn't stop it crashing (sometimes) when switching accounts... Even Magisk just crashed a minute ago as soon as I opened it to get the version, it was fine when I re-opened it.

Substratum I've never heard of before
Magisk modules all I have is Xposed framework and Youtube Vanced

Again no issues could be caused by these. Maybe try updating the apps you specified or try different older version
Try this older fb messenger for example https://androidfilehost.com/?fid=889964283620770051
14th June 2018, 09:27 PM |#8  
Princeland's Avatar
Member
Thanks Meter: 4
 
More
Quote:
Originally Posted by oli356

Bought my 5T last week (used) and immediately I installed magisk to root and xposed. Since then though I'm facing bizarre issues that come and go.

I was unable to add a Gmail account from settings as Google play services would crash
The Facebook messenger app would crash as soon as I open it, I downloaded the lite app and its OK.

The most common issue im seeing is Instagram crashing when I try to swap accounts. I can try to swap account, the app will hang and eventually crash. I try again and it will crash. But like an hour later it will be fine...
Also clearing dalvick and cache from TWRP seems to get it to work immediately.

I've had other things crash to which is strange as on my OP2 I had no such behaviour. The phone is lightning fast but these crashes are super annoying.

Anyone have any suggestions on what I could do? Not sure if reinstalling Oxygen OS could help and what's the most efficient way to do this while getting magisk/xposed back.

You have deleted Google or system apps related to Google services?
17th June 2018, 07:37 PM |#9  
OP Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by Aswin08

Again no issues could be caused by these. Maybe try updating the apps you specified or try different older version
Try this older fb messenger for example https://androidfilehost.com/?fid=889964283620770051

It just seems to be related to quite a few apps so trying different versions would be annoying, might try it with Instagram as its the most annoying.. Just went into recovery and wiped dalvic cache to switch accounts again.

Quote:
Originally Posted by Princeland

You have deleted Google or system apps related to Google services?

Nope
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes