FORUMS
Remove All Ads from XDA

[GUIDE][APP]Up To Date Google Camera Port For The 5T 9/7

1,100 posts
Thanks Meter: 852
 
By 3lMghraby, Senior Member on 20th December 2018, 11:36 PM
Post Reply Email Thread
I decided to start this thread because all the other GCAM port threads aren't up to date ,specially with the increasing number of APKS

so,let's get started

Disclamer
The Camera2api port for our device is buggy as hell not only that but the dual pixel technology libraries are f**** by OnePlus so to overcome that and get both portrait mode working and front camera hdr+
you must be rooted(or at least have a custom recovery)
for non root you can still use HDR+ only for the back camera with lots of dots!


Downloads
A-rooted downloads 1-the lib fix FOR ANDROID 8.1 ONLY
FOR ANDROID 9 PIE OOS 9.0.6 and above
2-Pixel Colours(optional)For OOS 9.0.6 and above you need Pixel Colours v3.0 HERE

B-APK download that's a bit easy
1-New Best Version Urnyx based on GCam 6.2 is excellent thanks Urnyx Download latest here
2-Gcam based on 5.1 Urnyx05 v6.2 for any OS for the 5t oreo and up of course
Settings
-For Gcam based on 5.1 only This one contains the settings I personally use with the current Google camera version Urnyx05 6.2 to get best results after testing many times(you can find yourself better settings anyways).
-the settings are attached as images in the post feel free to test them out.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_Camera_20181221-002019.png
Views:	19776
Size:	120.4 KB
ID:	4669785   Click image for larger version

Name:	Screenshot_Camera_20181221-002022.png
Views:	19636
Size:	156.8 KB
ID:	4669786   Click image for larger version

Name:	Screenshot_Camera_20181221-002026.png
Views:	19440
Size:	167.7 KB
ID:	4669787   Click image for larger version

Name:	Screenshot_Camera_20181221-002031.png
Views:	17458
Size:	114.9 KB
ID:	4669788   Click image for larger version

Name:	Screenshot_Camera_20181221-002040.png
Views:	16898
Size:	115.0 KB
ID:	4669789   Click image for larger version

Name:	Screenshot_Camera_20181222-190601.png
Views:	16012
Size:	61.9 KB
ID:	4670813  
The Following 61 Users Say Thank You to 3lMghraby For This Useful Post: [ View ] Gift 3lMghraby Ad-Free
21st December 2018, 02:46 PM |#2  
Senior Member
Thanks Meter: 28
 
More
Thanks, been looking for something like this an updated one. Using Urnyx and thanks for the settings
21st December 2018, 03:17 PM |#3  
3lMghraby's Avatar
OP Senior Member
Thanks Meter: 852
 
More
Quote:
Originally Posted by 5star02707

Thanks, been looking for something like this an updated one. Using Urnyx and thanks for the settings

You're Welcome
21st December 2018, 05:37 PM |#4  
Kokalebougre's Avatar
Senior Member
Flag Paris
Thanks Meter: 76
 
More
Lib fix breaks any audio mod like v4a, ainur, Dolby...
If you have audio mods and lib fix installed, any audio mod will not work and camera will not work in any app including stock camera app
You have to choose between camera or audio
The Following User Says Thank You to Kokalebougre For This Useful Post: [ View ] Gift Kokalebougre Ad-Free
21st December 2018, 05:57 PM |#5  
3lMghraby's Avatar
OP Senior Member
Thanks Meter: 852
 
More
Quote:
Originally Posted by SUPER KOKA

Lib fix breaks any audio mod like v4a, ainur, Dolby...
If you have audio mods and lib fix installed, any audio mod will not work and camera will not work in any app including stock camera app
You have to choose between camera or audio

use a custom kernel
and set it to permissive using a magisk module
or any other app
The Following 2 Users Say Thank You to 3lMghraby For This Useful Post: [ View ] Gift 3lMghraby Ad-Free
21st December 2018, 05:59 PM |#6  
Kokalebougre's Avatar
Senior Member
Flag Paris
Thanks Meter: 76
 
More
Quote:
Originally Posted by AlMaghraby

use a custom kernel
and set it to permissive using a magisk module
or any other app

I'm just warning the others before they come complaining about that
The Following User Says Thank You to Kokalebougre For This Useful Post: [ View ] Gift Kokalebougre Ad-Free
21st December 2018, 06:09 PM |#7  
3lMghraby's Avatar
OP Senior Member
Thanks Meter: 852
 
More
Quote:
Originally Posted by SUPER KOKA

I'm just warning the others before they come complaining about that

You can get both with permissive kernel
The Following 2 Users Say Thank You to 3lMghraby For This Useful Post: [ View ] Gift 3lMghraby Ad-Free
21st December 2018, 10:55 PM |#8  
Ritwik Rahman's Avatar
Senior Member
Flag Dhaka
Thanks Meter: 42
 
More
Works on OB20?
21st December 2018, 11:36 PM |#9  
3lMghraby's Avatar
OP Senior Member
Thanks Meter: 852
 
More
Quote:
Originally Posted by Ritwik Rahman

Works on OB20?

stated in the OP you need magisk to get it fully working
22nd December 2018, 02:13 PM |#10  
Senior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by SUPER KOKA

Lib fix breaks any audio mod like v4a, ainur, Dolby...
If you have audio mods and lib fix installed, any audio mod will not work and camera will not work in any app including stock camera app
You have to choose between camera or audio

In my case, using the Lib Fix in the link, doesn't break the stock camera (didn't try any audio mod). But if I update the module from magisk (to the last version), that one is breaking the stock camera.
I am using blu spark kernel. What does it mean to set it to permissive and how do I do that? Any side effects (potentially unwanted) by doing that?
22nd December 2018, 04:07 PM |#11  
3lMghraby's Avatar
OP Senior Member
Thanks Meter: 852
 
More
Quote:
Originally Posted by derei

In my case, using the Lib Fix in the link, doesn't break the stock camera (didn't try any audio mod). But if I update the module from magisk (to the last version), that one is breaking the stock camera.
I am using blu spark kernel. What does it mean to set it to permissive and how do I do that? Any side effects (potentially unwanted) by doing that?

kernel is either enforcing or permissive
hence the name suggests
permissive 'permits' apps from overriding system policies
enforcing enforces system policies
so use permissive when you have an app that requires it only
It theoritically impacts security
specially if you don't know what apps to install or don't get them from a trusted source
The Following 2 Users Say Thank You to 3lMghraby For This Useful Post: [ View ] Gift 3lMghraby Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes