FORUMS
Remove All Ads from XDA

problem with bluetooth

791 posts
Thanks Meter: 44
 
By westentertainer, Senior Member on 18th September 2018, 04:20 PM
Post Reply Email Thread
hi i love my op6 but there is one annoying thing Bluetooth auto connect ..my phone is connected to my tic watch pro with no problems but when i get in my car that has a alpine halo 9 i have to connect it manually ,also my company car is continually searching for my phone..i have never had this problem with any of the phones i have had [i have had every flagship phone that has come out .IOS or android.] any body shed some light on this for me thanks
 
 
19th September 2018, 04:04 PM |#2  
westentertainer's Avatar
OP Senior Member
Thanks Meter: 44
 
More
nobody got the same problem then
19th September 2018, 06:39 PM |#3  
Member
Flag Maputo
Thanks Meter: 20
 
More
Relax, someone will come eventually... And no, I don't have.
19th September 2018, 07:53 PM |#4  
Senior Member
Thanks Meter: 324
 
More
Quote:
Originally Posted by westentertainer

hi i love my op6 but there is one annoying thing Bluetooth auto connect ..my phone is connected to my tic watch pro with no problems but when i get in my car that has a alpine halo 9 i have to connect it manually ,also my company car is continually searching for my phone..i have never had this problem with any of the phones i have had [i have had every flagship phone that has come out .IOS or android.] any body shed some light on this for me thanks

Everyone who has a smart watch that can make BT phone calls has this problem.
The car kit connects as "Connected (no phone)."

This bug was introduced by Google with Pixel XL after 7.0.2 update, and they never fixed it.
Individual manufacturers fix this in their own Android skins except Google, Xaiomi and now Oneplus.
BTW, the bug was not present in 5.1.5. OOS, and was introduced in 5.1.6 or 5.1.7 (I skipped the 5.1.6 update.) So, it's likely that OP simply and lazily copied Google code at that point.

If you want to get rid of this annoyance, one possible way is to disable Phone Audio option in the watch BT properties on the phone.
Of course, you could also flash 5.1.5.
19th September 2018, 07:57 PM |#5  
westentertainer's Avatar
OP Senior Member
Thanks Meter: 44
 
More
Quote:
Originally Posted by nabbed

Everyone who has a smart watch that can make BT phone calls has this problem.
The car kit connects as "Connected (no phone)."

This bug was introduced by Google with Pixel XL after 7.0.2 update, and they never fixed it.
Individual manufacturers fix this in their own Android skins except Google, Xaiomi and now Oneplus.
BTW, the bug was not present in 5.1.5. OOS, and was introduced in 5.1.6 or 5.1.7 (I skipped the 5.1.6 update.) So, it's likely that OP simply and lazily copied Google code at that point.

If you want to get rid of this annoyance, one possible way is to disable Phone Audio option in the watch BT properties on the phone.
Of course, you could also flash 5.1.5.

Thank you. What would I loose disabling phone audio on watch ?
19th September 2018, 08:01 PM |#6  
Senior Member
Thanks Meter: 324
 
More
Quote:
Originally Posted by westentertainer

Thank you. What would I loose disabling phone audio on watch ?

Then you couldn't talk and listen to phone calls on the watch. You could initiate and receive the phone calls on the watch, but the audio would automatically go to the phone instead.
19th September 2018, 08:03 PM |#7  
westentertainer's Avatar
OP Senior Member
Thanks Meter: 44
 
More
Quote:
Originally Posted by nabbed

Then you couldn't talk and listen to phone calls on the watch. You could initiate and receive the phone calls on the watch, but the audio would automatically go to the phone instead.

Thank you
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes