FORUMS
Remove All Ads from XDA

[Guide] How to keep TWRP + data decryption when upgrading to OOS 10

1,503 posts
Thanks Meter: 1,436
 
By SyCreed, Senior Member on 2nd November 2019, 10:04 AM
Post Reply Email Thread
Disclaimer
I'm not responsible for any issue you may incounter while doing the steps below.
Do it on your own risk.


UPDATE;
SO! mauronofrio updated his twrp so there is no need in key master anymore.
Quote:
Originally Posted by mauronofrio

TWRP 3.3.1-24 OnePlus 6T (Fajita) by mauronofrio:
- Fixed Decryption on Android 10 (Old Keymaster is not more needed).

TWRP 3.3.1-24 Pie Unofficial by mauronofrio
TWRP 3.3.1-24 Q Unofficial by mauronofrio
TWRP 3.3.1-24 Unofficial Installer by mauronofrio

THIS GUIDE WILL WORK ONLY IF YOU'RE UPGRADING FROM 9 TO 10 !!!

Before you're doing anything, delete all your magisk modules and substratum layers.
The guide was already provided by mauronofrio, but i dunno why people still struggling on getting everything working fine. I'm explaining here my own steps on flashing everything.

How to:
1. Flash full OOS 10.0 zip via local update . (DO NOT REBOOT)
2. Flash fajita twrp 3.3.1-24.zip by @mauronofrio via Magisk Manager (DO NOT REBOOT)
3. Flash magisk to 2nd slot via MAgisk Manager (Magisk Manager → Tap on Install → Then select Install to Inactive Slot)
4. REboot and wait :3

proofs attached.
Attached Thumbnails
Click image for larger version

Name:	photo_2019-11-02_10-42-34.jpg
Views:	3500
Size:	44.3 KB
ID:	4863685   Click image for larger version

Name:	photo_2019-11-02_10-42-35.jpg
Views:	3524
Size:	79.6 KB
ID:	4863687   Click image for larger version

Name:	photo_2019-11-02_10-44-48 (2).jpg
Views:	3502
Size:	46.0 KB
ID:	4863689   Click image for larger version

Name:	photo_2019-11-02_10-45-13.jpg
Views:	3416
Size:	50.5 KB
ID:	4863691   Click image for larger version

Name:	2.jpg
Views:	3370
Size:	58.2 KB
ID:	4863695  
The Following 27 Users Say Thank You to SyCreed For This Useful Post: [ View ] Gift SyCreed Ad-Free
2nd November 2019, 10:18 AM |#2  
cultofluna's Avatar
Senior Member
Thanks Meter: 1,563
 
More
Quote:
Originally Posted by SyCreed

Disclaimer
I'm not responsible for any issue you may incounter while doing the steps below.
Do it on your own risk.

I was upgrading from 9.0.17 (6t stable) with 19.4 magisk.

Before you're doing anything, delete all your magisk modules and substratum layers.
The guide was already provided by mauronofrio, but i dunno why people still struggling on getting everything working fine. I'm explaining here my own steps on flashing everything.

How to:
1. Flash full OOS 10.0 zip via OTA updater. (DO NOT REBOOT)
2. Download EXKM (you can find it in play store)
2a. flash OldKeyMaster.zip via EXKM ( DO NOT REBOOT)
3. Flash fajita twrp 3.3.1-20.zip by @mauronofrio via Magisk Manager (DO NOT REBOOT)
4. Flash magisk to 2nd slot via MAgisk Manager
5. REboot and wait :3

All the needed .zip files found in TWRP theme
https://forum.xda-developers.com/one...#post80639099\

proofs attached.

Nice...
I'll recommend you to add in the OP that users SHOULDN'T
try this if they're already on stable 10
Oldkeymaster zip should not be enough to decrypt they will need to format data too..
This guide is working only if you're upgrading from 9.0.17 to stable 10
The Following 4 Users Say Thank You to cultofluna For This Useful Post: [ View ] Gift cultofluna Ad-Free
2nd November 2019, 10:35 AM |#3  
TDoric's Avatar
Senior Member
Flag Pula
Thanks Meter: 93
 
More
What is the purpose of OldKeyMaster.zip?

I don't have a custom kernel, and I don't need TWRP. I have a stock recovery and unlocked bootloader, rooted with magisk 20.1.

That's all I need.
2nd November 2019, 10:36 AM |#4  
Junior Member
Thanks Meter: 2
 
More
Hey there. I lost TWRP and root after updating to 10. I did not follow this guide because I didn't see it before I updated. Would I be able to flash magisk the same way I did before the update? Thank you everyone.
2nd November 2019, 10:38 AM |#5  
SyCreed's Avatar
OP Senior Member
Flag Hadera
Thanks Meter: 1,436
 
Donate to Me
More
Quote:
Originally Posted by the bolt of thunder

Hey there. I lost TWRP and root after updating to 10. I did not follow this guide because I didn't see it before I updated. Would I be able to flash magisk the same way I did before the update? Thank you everyone.

there is patched boot.img with magisk that you can flash.
The Following 3 Users Say Thank You to SyCreed For This Useful Post: [ View ] Gift SyCreed Ad-Free
2nd November 2019, 10:40 AM |#6  
Junior Member
Thanks Meter: 2
 
More
Thank you. You made me a happy soul.

And thank you for the guide above. We appreciate it.
2nd November 2019, 10:49 AM |#7  
Member
Thanks Meter: 14
 
More
Hey, thanks for the guide but how do I flash TWRP via Magisk Manager as mentioned in OP? Or you meant EXM for that as well?
2nd November 2019, 11:15 AM |#8  
Electric1447's Avatar
Senior Member
Flag Israel
Thanks Meter: 67
 
More
In OTA Updater you mean via settings?
2nd November 2019, 11:16 AM |#9  
Senior Member
Thanks Meter: 71
 
More
Quote:
Originally Posted by Anwar Syed

Hey, thanks for the guide but how do I flash TWRP via Magisk Manager as mentioned in OP? Or you meant EXM for that as well?

I flashed it like it was a module and everything works fine for me and I thought I would of messed it up because I usually do
The Following 4 Users Say Thank You to wezmeister17 For This Useful Post: [ View ] Gift wezmeister17 Ad-Free
2nd November 2019, 11:35 AM |#10  
Member
Thanks Meter: 14
 
More
Quote:
Originally Posted by wezmeister17

I flashed it like it was a module and everything works fine for me and I thought I would of messed it up because I usually do

TWRP Installer zip as module? That's something new! All working well?
2nd November 2019, 12:59 PM |#11  
Senior Member
Thanks Meter: 71
 
More
Quote:
Originally Posted by Anwar Syed

TWRP Installer zip as module? That's something new! All working well?

It might of been wrong as it crashed but I closed magisk after and carried on as explained and I have had to go back to twrp as I installed a module that caused a bootloop so can say everything is working as it should be
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes