[Guide] Notification FIX - Works 100%

10th November 2018 11:26 PM 17 Thanks
mazdamiata210 Senior Member
So if you are having issues with notifications not coming in or coming in late this is finally how to fix it 100% on every app. It seems to have a very slight impact on battery but nothing major. From what I saw it was about 1% per hour drain... Which is worth it for a working phone

Anyways, the way to fix this requires it to be set from a computer on every restart of the phone which is probably the biggest problem with this method. I'm working on a way to maybe have a script run at every start up to fix the issue. Which will probably require root. We'll see...

1. Download and install the ADB drivers - Follow the guide here: https://www.xda-developers.com/insta...s-macos-linux/

2. Once you have ADB installed and enabled on your phone like the guide says in step 1 above, you want to be on the ADB command prompt...

Type in the command:

Code:
adb shell dumpsys deviceidle disable
The command prompt should return with:

Code:
Deep idle mode disabled
Light idle mode disabled
That's it! Now your notifications will work fine. I've tested this for a day and every notification came through on time.

Just like to add that I have adaptive battery off, and every app is set to optimize. Not sure if this makes a difference or not.

Again this must be applied on every restart (which sucks) but at least it's something, for now.
10th November 2018 11:53 PM 1 Thanks
suaverc118 Senior Member
What notification problems are there?
10th November 2018 11:54 PM 2 Thanks
mazdamiata210 Senior Member
Quote:
Originally Posted by suaverc118

What notification problems are there?

"if you are having issues with notifications not coming in or coming in late"
11th November 2018 12:32 AM 0 Thanks
AlkaliV2 Senior Member
Quote:
Originally Posted by mazdamiata210

"if you are having issues with notifications not coming in or coming in late"

What he likely meant is more specifically what applications are you having issues with. Through extended idle I'll admit OOS kills every background task, but using the Oneplus messaging app and normal google applications I'm no longer getting late notifications like I was on my Oneplus 3. There is another setting that showed up under my notifications this morning that basically detected that I had gone to sleep and put all applications on hold until I woke up, though I cannot find this setting after clicking that notification this morning.
11th November 2018 02:17 AM 3 Thanks
magnumtripod Senior Member
I have issues with notifications not notifying me until I wake up my phone
11th November 2018 02:19 AM 2 Thanks
mazdamiata210 Senior Member
Quote:
Originally Posted by magnumtripod

I have issues with notifications not notifying me until I wake up my phone

Yeah exactly the problem, doesn't matter what app... It's random... Follow my post it'll fix it

It's a general android issue with how doze mode works. This disables doze mode. Should work on any phone honestly.
11th November 2018 02:22 AM 0 Thanks
magnumtripod Senior Member
I'll try it tomorrow and run a few tests to see how it works
11th November 2018 02:53 AM 1 Thanks
ram4ufriends Senior Member
Quote:
Originally Posted by magnumtripod

I have issues with notifications not notifying me until I wake up my phone

Disable sleep optimization in battery - optimization
11th November 2018 02:54 AM 0 Thanks
mazdamiata210 Senior Member
Quote:
Originally Posted by ram4ufriends

Disahle sleep optimization in battery - optimization

It doesn't do anything, the problem still happens
12th November 2018 03:37 AM 0 Thanks
stardamore Junior Member
Quote:
Originally Posted by mazdamiata210

Yeah exactly the problem, doesn't matter what app... It's random... Follow my post it'll fix it

It's a general android issue with how doze mode works. This disables doze mode. Should work on any phone honestly.

Or, you could just turn off adaptive battery.

[embedded image could not be found]
close
Advanced Search
close