FORUMS
Remove All Ads from XDA

[APP/THEME][ROOT] OPFPControl — Custom Fingerprint Icons and Colors

4,560 posts
Thanks Meter: 3,381
 
By Zacharee1, Recognized Developer / Retired Forum Moderator on 12th February 2019, 04:05 PM
Post Reply Email Thread
13th February 2019, 12:46 AM |#11  
Zacharee1's Avatar
OP Recognized Developer / Retired Forum Moderator
Thanks Meter: 3,381
 
Donate to Me
More
Quote:
Originally Posted by Armand Bernard

I'm afraid I don't get a notification after reboot, even after waiting for several minutes and reopening the app.

For reference, I have Substratum System UI themes but they're all deactivated, and I have the modified system using that Magisk mod I mentioned earlier, so that might be conflicting somehow.

Check /system/priv-app for an OPFPIcon folder.

I was having issues making this where installing it to /vendor/overlay and /system/app would cause it to be deleted on a full reboot. I couldn't figure out why it did that, but I found that pushing to /system/priv-app worked for me. Maybe it's not working for you.

If not, I need to figure out what's going on.
The Following User Says Thank You to Zacharee1 For This Useful Post: [ View ]
 
 
13th February 2019, 02:13 AM |#12  
Junior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by Zacharee1

Check /system/priv-app for an OPFPIcon folder.

I was having issues making this where installing it to /vendor/overlay and /system/app would cause it to be deleted on a full reboot. I couldn't figure out why it did that, but I found that pushing to /system/priv-app worked for me. Maybe it's not working for you.

If not, I need to figure out what's going on.

So after applying the icon, there is a OPFPIcon.apk inside OPFPIcon folder. But after rebooting, it's gone.
The Following User Says Thank You to carterson For This Useful Post: [ View ] Gift carterson Ad-Free
13th February 2019, 02:49 AM |#13  
Senior Member
Thanks Meter: 366
 
More
Can you continue to take regular OTAs after modifying the icon with this method? With the updater, no TWRP.
13th February 2019, 02:53 AM |#14  
evilbait's Avatar
Senior Member
Flag mysore
Thanks Meter: 217
 
Donate to Me
More
App doesn't load. stuck on black screen.
The Following User Says Thank You to evilbait For This Useful Post: [ View ] Gift evilbait Ad-Free
13th February 2019, 03:32 AM |#15  
Senior Member
Thanks Meter: 28
 
More
Quote:
Originally Posted by peanutpajamas

Wow this is great! Now it works on beta to! One prob though, attached I have 2 screenshots, one with the old method and one with this new one, the old one had the original dimensions, the new one ruins the shape, what to do?
(Ignore the bug report)

I figured out the problem, for some reason the old method was able to handle any aspect ratio while this new method can only use a square or else it will force it into a square, just putting this out there.
Thanks Zacharee1 for putting this together!
13th February 2019, 06:55 AM |#16  
cultofluna's Avatar
Senior Member
Thanks Meter: 1,306
 
More
Doesn't work for me ,tried different icons , getting a prompt to reboot but after the restart , stock fp still there....
OB4
The Following User Says Thank You to cultofluna For This Useful Post: [ View ] Gift cultofluna Ad-Free
13th February 2019, 10:11 AM |#17  
Member
Thanks Meter: 9
 
More
Quote:
Originally Posted by carterson

So after applying the icon, there is a OPFPIcon.apk inside OPFPIcon folder. But after rebooting, it's gone.

^ Yeah, same for me.

I'm on 9.0.11 btw
The Following User Says Thank You to Armand Bernard For This Useful Post: [ View ] Gift Armand Bernard Ad-Free
13th February 2019, 11:35 AM |#18  
Senior Member
Thanks Meter: 66
 
More
Quote:
Originally Posted by carterson

So after applying the icon, there is a OPFPIcon.apk inside OPFPIcon folder. But after rebooting, it's gone.

I am experiencing the same issue. I'm on 9.0.12. I do have Substratum installed running the Swift Black theme, so not sure if this has any effect on it.
13th February 2019, 01:39 PM |#19  
Dbrdmkr's Avatar
Member
Thanks Meter: 5
 
More
Same here. On 9.0.12. Using swift installer.
After select the new icon, I get a the opficon folder with apk. Although. It doesn't apply on reboot.
13th February 2019, 03:00 PM |#20  
Zacharee1's Avatar
OP Recognized Developer / Retired Forum Moderator
Thanks Meter: 3,381
 
Donate to Me
More
I've updated the attachment with a new version. I've tested and it sticks through a reboot for me.
The Following 3 Users Say Thank You to Zacharee1 For This Useful Post: [ View ]
13th February 2019, 03:25 PM |#21  
Senior Member
Thanks Meter: 66
 
More
Thanks for the new version. Just tried to install though but keep getting the error message in the attached image.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20190213-152223.jpg
Views:	3070
Size:	58.1 KB
ID:	4704803  
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes