FORUMS
Remove All Ads from XDA

[KERNEL] [blu_spark r60 OP7/Pro] [OOS /Custom A10]

6,209 posts
Thanks Meter: 54,929
 
By eng.stk, Senior Member on 30th June 2019, 07:14 AM
Post Reply Email Thread
Announcement from eng.stk: blu_spark r60 unified is up!
21st July 2019, 06:54 PM |#111  
dabug123's Avatar
Recognized Developer
Flag brunswick
Thanks Meter: 7,541
 
Donate to Me
More
Quote:
Originally Posted by ram4ufriends

Just curious... Official TWRP is working on Q as well, right?

Idk
22nd July 2019, 04:48 PM |#112  
vtec303's Avatar
Senior Member
Flag Manchester
Thanks Meter: 384
 
More
Quote:
Originally Posted by dabug123

Idk

Blu_spark recovery is working with Q, cheers.
23rd July 2019, 12:52 AM |#113  
iRhyiku's Avatar
Senior Member
Thanks Meter: 312
 
More
Unified for 7/pro but not 5G I assume?
23rd July 2019, 02:33 AM |#114  
Quote:
Originally Posted by iRhyiku

Unified for 7/pro but not 5G I assume?


Indeed.


Sent from my blu_spark'd OnePlus
23rd July 2019, 09:33 AM |#115  
antnyhills's Avatar
Member
Ogden, UT
Thanks Meter: 46
 
Donate to Me
More
Quote:
Originally Posted by vtec303

Blu_spark recovery is working with Q, cheers.

I'm getting an Android version error when trying to install it with Q. Sure it works?
23rd July 2019, 10:19 AM |#116  
vtec303's Avatar
Senior Member
Flag Manchester
Thanks Meter: 384
 
More
Quote:
Originally Posted by antnyhills

I'm getting an Android version error when trying to install it with Q. Sure it works?

This is how I made it work,
Device should already be on OOS 9.5.9, Blu_spark twrp, rooted with magisk 19.3(installing Q if you are on 9.5.10 have given many people black screen issues), if these conditions are met than carry on,
Reboot to twrp,
Don't wipe anything,
Flash Q DP3,
Flash Blu_spark twrp zip file,
Reboot twrp,
Flash magisk 19.3,
Wipe dalvik cache,
Reboot system, all done.
System will take some time to boot may be reboot itself before full system reboot, when fully booted just leave it for 10 minutes let it do its thing, should be ok than. But keep in mind my device is fully decrypted so if you are not decrypted device might behave differently, be on a safe side and backup all data before hand, hope this helps, cheers.
29th July 2019, 08:27 PM |#117  
Senior Member
Flag Chennai
Thanks Meter: 47
 
More
Dev, kernel working great in op7. Better battery life than stock.
I have weird problem, in op it said swap disabled, default io is zen,
But when i flashed the kernel and open exkernel manager, nothing is changed, swapfile is enabled, io is cfq,
I manually changed to zen and swapfile disabled and vibration strength also not showing in exkernel.
Is it flashing problem.. I tried in clean stock rom.
30th July 2019, 03:47 AM |#118  
Senior Member
Thanks Meter: 31
 
More
Quote:
Originally Posted by methuntt

Dev, kernel working great in op7. Better battery life than stock.
I have weird problem, in op it said swap disabled, default io is zen,
But when i flashed the kernel and open exkernel manager, nothing is changed, swapfile is enabled, io is cfq,
I manually changed to zen and swapfile disabled and vibration strength also not showing in exkernel.
Is it flashing problem.. I tried in clean stock rom.

Try restore Stock boot (or using Restore_stock_file.zip in Kiri thread), then flash blu_spark > Magisk > blu_spark again.
The first time I flashed this kernel I also have that problem, but after trying with above steps, everything is fine.
30th July 2019, 06:08 PM |#119  
Senior Member
Flag Chennai
Thanks Meter: 47
 
More
Quote:
Originally Posted by starrynighthn

Try restore Stock boot (or using Restore_stock_file.zip in Kiri thread), then flash blu_spark > Magisk > blu_spark again.
The first time I flashed this kernel I also have that problem, but after trying with above steps, everything is fine.

I tried but it didn't worked out.
I'm manually changed everything in exkernel manager.
31st July 2019, 03:32 AM |#120  
Senior Member
Thanks Meter: 31
 
More
Quote:
Originally Posted by methuntt

I tried but it didn't worked out.
I'm manually changed everything in exkernel manager.

Or maybe some apps cause the problem. I also uninstalled FX Kernel Manager
1st August 2019, 03:31 AM |#121  
Info 2 blu_spark r29 release (unified)
All right crew!

New build is up
This kernel is unified, good to go on OP7/Pro (I only can test on Pro).
Added a custom ROM variant, at the moment I will only support ROMs that follow CAF/AOSP wifi module usage (I tested on OMNI). So if you use a custom ROM with builtin driver (like LOS), you're out of luck.
Also checkout latest recommended blu_spark extras with blu_twrp v9.103.


blu_spark_r29 release

Quote:

  • cpufreq: blu_schedutil: add some compat oem bits (new! better oem integration, freq stats, etc)
  • Synchronize codes for Oneplus 7 Pro Oxygen OS 9.5.11
  • Reduce some debug and logging
  • int_sqrt: Improve 3x faster integer sqrt
  • Add custom ROM goodies support (check git)
  • fingerprint: silead/goodix: add haptic feedback control similar to gestures (custom only)
  • AnyKernel3 updates


Keep in mind: I will give no active support for custom ROMs (including OOS based ones).
I am only interested on debugging stuff in stock and stable OOS (with logs and reproducible steps to replicate the issue).
Don't spam this thread with LOS or other ROMs stuff like "this don't work, my app doesn't open, etc" or debugging features.
Also don't go spam and bug reporting on ROM threads if using this.


No mirrors please
If you like my work, donations are always welcome.
Don't forget to hit thanks and rate the thread nicely, it's free
The Following 23 Users Say Thank You to eng.stk For This Useful Post: [ View ] Gift eng.stk Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes