FORUMS

SafetyNet (Magisk/EdXposed) Tests Failing After Supposed Server-Side Changes

29 posts
Thanks Meter: 9
 
By dipleg, Junior Member on 5th April 2020, 02:15 AM
Post Reply Email Thread
Discussion Thread

It appears that Google has flipped some sort of switch a few days ago and many people who are rooted with magisk along with the Xposed/EdXposed framework are failing both BasicItegrity and CtsProfile checks.

From Magisk dev topjohnwu:

https://mobile.twitter.com/topjohnwu...56080779198464

https://mobile.twitter.com/topjohnwu...30555523149824

https://mobile.twitter.com/topjohnwu...63069643051009

EdXposed discussion:

https://github.com/ElderDrivers/EdXposed/issues/435
5th April 2020, 06:44 AM |#2  
vincentallen2's Avatar
Senior Member
Thanks Meter: 70
 
More
Yup, even my rooted Essential PH-1 is failing, and it's not even a TEE device

Sent from my PH-1 using Tapatalk
5th April 2020, 07:53 AM |#3  
Senior Member
Thanks Meter: 257
 
More
Use the Canary Version v0.4.6.3 (4536) of EdXposed and SafetyNet wont fail anmyore.
The Following 6 Users Say Thank You to Hirs_E_Fruit For This Useful Post: [ View ] Gift Hirs_E_Fruit Ad-Free
5th April 2020, 02:21 PM |#4  
Senior Member
Thanks Meter: 78
 
More
Did you have a Link vor this Version pls
5th April 2020, 04:18 PM |#5  
Senior Member
Thanks Meter: 257
 
More
Quote:
Originally Posted by Kevinkuensken

Did you have a Link vor this Version pls

Swipe 2 times right in your EdXposed Manager...
6th April 2020, 11:12 AM |#6  
Senior Member
Flag Bakersfield
Thanks Meter: 53
 
Donate to Me
More
I have the same issue on the 7 Pro. SafetyNet is suddenly being tripped, and it stops being tripped if the EdXposed module is disabled/removed. This happened on Saturday, and I hadn't even rebooted. Something has definitely changed on Google's end. I have had no issues with Magisk + EdXposed for months on end.
6th April 2020, 11:29 AM |#7  
Senior Member
Thanks Meter: 49
 
More
Quote:
Originally Posted by Hirs_E_Fruit

Use the Canary Version v0.4.6.3 (4536) of EdXposed and SafetyNet wont fail anmyore.

I cant find 4536 version there. Can you share file link?
The Following User Says Thank You to satyajeetb For This Useful Post: [ View ] Gift satyajeetb Ad-Free
6th April 2020, 11:54 AM |#8  
Senior Member
Flag Bakersfield
Thanks Meter: 53
 
Donate to Me
More
Quote:
Originally Posted by Hirs_E_Fruit

Use the Canary Version v0.4.6.3 (4536) of EdXposed and SafetyNet wont fail anmyore.

Thanks! I can confirm that switching to the current Canary Build (4542) fixed the SafetyNet issue. Whatever Google silently pushed has been resolved.

Marvelous. Now I can play Pokémon GO

---------- Post added at 03:54 AM ---------- Previous post was at 03:53 AM ----------

Quote:
Originally Posted by satyajeetb

I cant find 4536 version there. Can you share file link?

Just update to the latest Canary Build. Any newer version will also pass Safety Net.
The Following User Says Thank You to aenews For This Useful Post: [ View ] Gift aenews Ad-Free
6th April 2020, 10:01 PM |#9  
Account currently disabled
Thanks Meter: 14
 
More
Or you could just used a magisk module to pass safety net like before.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20200406-140107.jpg
Views:	1142
Size:	122.8 KB
ID:	4988285  
6th April 2020, 10:46 PM |#10  
Senior Member
Flag Bakersfield
Thanks Meter: 53
 
Donate to Me
More
Quote:
Originally Posted by xdg4y

Or you could just used a magisk module to pass safety net like before.

This failure to pass SafetyNet is for EdXposed users. Neither any Magisk module nor any Xposed module (i.e. HiddenCore) will resolve the issue. You can get the SafetyNet test seemingly passed in Magisk at best, but Google Pay and Pokémon GO would not work.

Updating to the newer EdXposed builds is the only way to truly resolve the issue after whatever update Google pushed on the back-end.
7th April 2020, 06:08 AM |#11  
vincentallen2's Avatar
Senior Member
Thanks Meter: 70
 
More
Which module are you referring to? I don't have edxposed installed on my phone, and it's failing to pass safetynet with just magisk installed

Sent from my PH-1 using Tapatalk
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes