FORUMS

I think I lost fastboot*D* (?)

37 posts
Thanks Meter: 15
 
By pfdeadpool, Member on 26th March 2020, 01:18 AM
Post Reply Email Thread
**solved with unbrick tool, see post #3, thanks

OnePlus 7t GM1905 (North America)

'fastboot reboot fastboot'
Phone boots to Chinese screen (and stops).
computer powershell stuck at '< waiting for any device >'
If I manually select boot to fastboot on phone, I get error: 'fastboot: error: Failed to boot into userspace fastboot; one or more components might be unbootable.'

History:
I got my phone - first OnePlus
I installed msm xtended rom, no problems
I installed AOSIP rom, no problems
I installed Omnirom (had to dump a payload file, but got it up and running)

Problems:
I wanted to go back to msm xtended rom
The phone won't reboot into fastbootd. It also wasn't recognizing with the same USB port and cable I was using yesterday.
I can still boot into stock OnePlus 7t, and access recovery, sometimes wifi/bluetooth does not turn on, but otherwise seems pretty normal.
I can try to flash roms (including stock), but they fail on the 'fastboot reboot fastboot' command. Also have problems with fastboot -w.
SDK 29.0.6
I used OP 7t cable, & 2 Anker cables (all USB A - USB C)
I flashed a Xiaomi between yesterday & today; maybe I need to reinstall drivers for the OP 7t(?) I don't think the 7t is recognized in device manager; at least I did not understand how to see it in device manager following these directions for Unbrick tool. https://forum.xda-developers.com/one...ce-to-t3994835

Thanks for any advice or tips on searching. And thank you for the development. Seems like searching for "fastbootd" is a bit tricky
26th March 2020, 03:27 PM |#2  
Senior Member
Flag Kansas City
Thanks Meter: 178
 
More
Fastbootd is a tricky fish and I'm not shocking you're having issues. Sounds like you might want to use the MSM Tool and completely factory reset your device. Should also replace/fix fastbootd
26th March 2020, 07:29 PM |#3  
OP Member
Thanks Meter: 15
 
More
Thanks, using the unbrick tool solved it.

To anyone searching in the future----
#1, unless you have used omnirom in the past & know you like it, I would suggest avoiding it. I liked xtended the best, then AOSIP, then Omnirom. xtended & AOSIP are easy to flash

I was having problems with getting the 7t recognized in the unbrick tool. https://forum.xda-developers.com/one...ce-to-t3994835
basically, I was having trouble getting it recognized as (QDLOADER 9008 or QHUSB_BULK in faq)
solution was to start unbrick tool, select O2, get ready to click start- power on, keep holding down vol up & vol down; and when phone was recognized in unbrick tool (still never saw QLOADER or QHUSB), quickly hit start on unbrick tool.
i didn't click 'enum', didn't have time.
more info in post #28 & #33, and others in that thread

I forget which drivers I ended up having installed. You can find OnePlus drivers online, & the qualcomm stuff is listed in that unbrick thread faq
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes