FORUMS

[ROM][UNOFFICIAL][instantnoodlep][10] LineageOS 17.1

7,835 posts
Thanks Meter: 16,322
 
By LuK1337, Recognized Developer on 25th June 2020, 03:53 PM
Post Reply Email Thread


LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

Instructions :
  • Download the latest build and gapps
  • $ adb reboot bootloader
  • $ fastboot -w (this will wipe your data)
  • $ fastboot flash recovery recovery.img
  • $ fastboot reboot fastboot
  • $ fastboot erase scratch
  • $ fastboot flash boot boot.img
  • $ fastboot flash dtbo dtbo.img
  • $ fastboot flash system system.img
  • $ fastboot flash product product.img
  • $ fastboot flash vbmeta vbmeta.img
  • $ fastboot flash vbmeta_system vbmeta_system.img
  • $ fastboot reboot
Downloads :Reporting Bugs
  • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
  • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
  • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
  • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

Code:
What is your--
LineageOS version:
LineageOS Download url:
Gapps version:
 
Did you--
wipe:
 restore with titanium backup:
reboot after having the issue:
 
Are you using--
a task killer:
a non-stock kernel:
other modifications:
 
Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
XDA:DevDB Information
[ROM][UNOFFICIAL][instantnoodlep][10] LineageOS 17.1, ROM for the OnePlus 8 Pro

Contributors
LuK1337
Source Code: https://github.com/luk1337

ROM OS Version: Windows 8 Mobile
ROM Kernel: Linux 4.x

Version Information
Status: Testing

Created 2020-06-25
Last Updated 2020-07-01
The Following 18 Users Say Thank You to LuK1337 For This Useful Post: [ View ]
25th June 2020, 05:05 PM |#2  
Senior Member
Thanks Meter: 49
 
More
Yessss, thanks mate. Any known bugs?
25th June 2020, 05:18 PM |#3  
areyouanand's Avatar
Senior Member
Flag mysore
Thanks Meter: 230
 
Donate to Me
More
Great to see LOS builds popping up, thanks for the efforts.
25th June 2020, 08:32 PM |#5  
Senior Member
Thanks Meter: 78
 
More
Can this be flashed in TWRP?
25th June 2020, 09:56 PM |#7  
Senior Member
Thanks Meter: 87
 
More
Are gapps included or do we need to flash separately?
25th June 2020, 09:58 PM |#8  
Quote:
Originally Posted by blaze9090

Are gapps included or do we need to flash separately?

Look at downloads list and answer this question yourself.
The Following 3 Users Say Thank You to LuK1337 For This Useful Post: [ View ]
26th June 2020, 02:17 AM |#9  
Panzer87's Avatar
Senior Member
Thanks Meter: 99
 
More
Running great on my end. Fingerprint is working too!! Awesome work Dev!
The Following 2 Users Say Thank You to Panzer87 For This Useful Post: [ View ] Gift Panzer87 Ad-Free
26th June 2020, 04:23 AM |#10  
areyouanand's Avatar
Senior Member
Flag mysore
Thanks Meter: 230
 
Donate to Me
More
Flashing ROM via fastboot for the first time, getting the following error


PS E:\android\platform-tools_r30.0.3-windows\platform-tools> fastboot -w
Erase successful, but not automatically formatting.
File system type f2fs not supported.
Erase successful, but not automatically formatting.
Can't determine partition type.
FAILED (remote: GetVar Variable Not found)
erasing 'userdata'...
OKAY [ 5.457s]
erasing 'cache'...
FAILED (remote: Check device console.)
finished. total time: 5.466s
PS E:\android\platform-tools_r30.0.3-windows\platform-tools>


PS: proceeded to flash the files anyway and it is stuck in OOS bootanimation.
26th June 2020, 05:07 AM |#11  
Member
Flag Gulfport
Thanks Meter: 17
 
More
Thanks for your work!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes