FORUMS
Remove All Ads from XDA

[MOD] Custom camera HAL with 4K UHD/DCI and 30 FPS video recording [Apr. 22, 2016]

6,308 posts
Thanks Meter: 36,906
 
By Sultanxda, Recognized Developer on 15th February 2016, 10:58 AM
Post Reply Email Thread
21st April 2016, 11:12 AM |#501  
Member
Thanks Meter: 17
 
More
The snapdragon camera app can not click pics why?
(I am not rooted so I flashed the zip)
Is there any other camera app which can be used with this mod?
I really wanted to click pics through snapdragon app but I cant

Sent from my ONE E1003 using XDA-Developers mobile app
 
 
21st April 2016, 12:00 PM |#502  
eng.stk's Avatar
Senior Member
Thanks Meter: 53,435
 
Donate to Me
More
Quote:
Originally Posted by Sultanxda

And the blue tint is now fixed.

Amazing work mate, thanks!
The Following User Says Thank You to eng.stk For This Useful Post: [ View ] Gift eng.stk Ad-Free
21st April 2016, 12:58 PM |#503  
Junior Member
Thanks Meter: 0
 
More
im getting only 38fps in 1080p instead of 60fps.
21st April 2016, 01:11 PM |#504  
Tiongkia's Avatar
Senior Member
Flag Singapore
Thanks Meter: 199
 
More
Works fine with oss 2.21
21st April 2016, 06:48 PM |#505  
Sultanxda's Avatar
OP Recognized Developer
Flag California
Thanks Meter: 36,906
 
Donate to Me
More
Quote:
Originally Posted by johnny.tifosi

I just flashed the latest HAL and Snapdragon Camera for the first time today. The UHD and DCI modes work nicely. However both the highspeed and slowmo 1080p 60 fps modes only produce a 38fps video. I can get 60fps only on 720p. Since the phone is capable of 4K 30fps video I suppose it is not due to insufficient hardware. Is it maybe due to the HAL?

I'm seeing 57 FPS (1080p @ 60) and 117 FPS (720p @ 120) in CM12.1 and CM13. I don't know which ROM you're using, but it's working fine for me.
The Following User Says Thank You to Sultanxda For This Useful Post: [ View ]
21st April 2016, 07:30 PM |#506  
Member
Thanks Meter: 19
 
More
What camera are you guys using for CM13.1? I can't seem to find a decent one that works. Snapdragon does not want to start so I gave up on it.
21st April 2016, 07:40 PM |#507  
Senior Member
Thanks Meter: 241
 
More
When I want to use this with CM13 and the stock camera, I must flash this mod and the oxygen cam or only this?
21st April 2016, 08:49 PM |#508  
Odysseus Rex's Avatar
Member
Thanks Meter: 102
 
More
Quote:
Originally Posted by phoberus

When I want to use this with CM13 and the stock camera, I must flash this mod and the oxygen cam or only this?

This is a HAL mod, not a camera apk, so you must install the camera by yourself and flash the HAL mod.
The Following 2 Users Say Thank You to Odysseus Rex For This Useful Post: [ View ] Gift Odysseus Rex Ad-Free
21st April 2016, 10:00 PM |#509  
Member
Thanks Meter: 17
 
More
Quote:
Originally Posted by Oedipus Rex

This is a HAL mod, not a camera apk, so you must install the camera by yourself and flash the HAL mod.

Hello,
I flashed Snapdragon app v2.0 and it takes great vids but as soon as I click a pic it just hangs on the pic and doesn't take the pic.. If you have used the app can you confirm that if I am the only one facing this issue and also tried Google Camera v2.7 it force closes when clicking a pic video is fine but can't record fhd with 60fps on any app other than Snapdragon cam
Would like to know which app runs perfect with this mod for me SD cam doesn't take pics at all.
Am I wrong somewhere?
Thanks!

Sent from my ONE E1003 using XDA-Developers mobile app
21st April 2016, 10:07 PM |#510  
Odysseus Rex's Avatar
Member
Thanks Meter: 102
 
More
Quote:
Originally Posted by oneplusx

Hello,
I flashed Snapdragon app v2.0 and it takes great vids but as soon as I click a pic it just hangs on the pic and doesn't take the pic.. If you have used the app can you confirm that if I am the only one facing this issue and also tried Google Camera v2.7 it force closes when clicking a pic video is fine but can't record fhd with 60fps on any app other than Snapdragon cam
Would like to know which app runs perfect with this mod for me SD cam doesn't take pics at all.
Am I wrong somewhere?
Thanks!

Sent from my ONE E1003 using XDA-Developers mobile app

Never had any problem with camera or hal (I'm using Snapdragoncam from cm13 tree). I really don't know what your problem could be.

Did you try cleaning the camera cache after flashing the HAL?
21st April 2016, 10:16 PM |#511  
Member
Thanks Meter: 17
 
More
Quote:
Originally Posted by Oedipus Rex

Never had any problem with camera or hal (I'm using Snapdragoncam from cm13 tree). I really don't know what your problem could be.

Did you try cleaning the camera cache after flashing the HAL?

The SD camera app always shows 0 data and 0 cache so option of clearing data and cache is blacked out (on OOS 2.2.1 and flashed the SD app zip)

Sent from my ONE E1003 using XDA-Developers mobile app

---------- Post added at 09:16 PM ---------- Previous post was at 09:14 PM ----------

Is the SD cam not compatible with OOS?

Sent from my ONE E1003 using XDA-Developers mobile app
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes