Remove All Ads from XDA

[E971] No data on JB modem after OTA. EFS restore doesn't help

1 posts
Thanks Meter: 0
By totallyonyx, Junior Member on 13th November 2014, 01:17 AM
Post Reply Email Thread
I've been having issues with my E971 on Rogers ever since I tried to flash an E975 ROM on it some time back. The phone is unable to connect to the network and shows 'Service Disabled'. I am unable to manually add an APN or search for networks. If I take the SIM out of the phone it shows my IMEI but if the SIM is in the phone it shows as null.

I used a KDZ to go back to the stock Jelly Bean version of Android and still had the same issue. I thought it might be an issue with the modem so I rooted the phone and flashed houstonn's Rogers JB modem and still couldn't solve the issue. If I flash the ICS modem on the 4.1.2 ROM I'm able to connect to the network but WiFi doesn't work. I tried installing various different AOSP based custom firmwares and was able to get data using the ICS modem but again no WiFi. Using the JB modem on an AOSP ROM would give be an external modem(undefined) subsystem crash. At this point I got my hands on a stock ICS bin file for the E971 and flashed it using LGNPST. On 4.0.4 both my data and my WiFi worked so I backed up my EFS manually using adb and ran the OTA updates on the phone. Unfortunately once I had updated to 4.1.2 the network stopped working and once again I got the 'Service disabled' messaged. Manually restoring my EFS didn't solve the issue.

It seems that for some reason my phone is unable to work with the JB modem. I find it odd that after restoring to stock the OTA would end up breaking it like that. I'm not sure if I'm backing up and restoring the EFS wrong or if the phone is just broken in some way. Any help would be greatly appreciated!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes